Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

AXL addUser request on ccm5+

Could anyone post a simple working example? I'm having the hardest time getting even the most simplistic command to work

(e.g. <newUser><lastname>test</lastname><userid>test</userid></newUser>)

ccm always bitches about a parsing error so I figure it expects a different order / and or different notation, but I have nothing to go on except the wsdl file, and this request corresponds to the wsdl as far as I can tell.

5 REPLIES

Re: AXL addUser request on ccm5+

password and pin are required elements

Re: AXL addUser request on ccm5+

Not according to the WSDL, but okay.. my first attempt was with pin and password.

As a sidenote.. I'm currently porting a user management solution from ccm 4.2 to 6.1 so the code works on ccm4.. it's not like I'm starting out fresh.

So, do you have a working sample of a request that works on ccm6 (or 5.. when it wouldn't work on 6.1.1 I figured I'd try on 5.1.3 but it didn't work there either).

Re: AXL addUser request on ccm5+

do you mind posting the whole SOAP request incl envelope and body?

Silver

Re: AXL addUser request on ccm5+

Pin and password are not required. Here is my working example (CUCM 5.1.3.2104-1):

Request:

http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2000/10/XMLSchema-instance" xmlns:xsd="http://www.w3.org/1999/XMLSchema">

http://www.cisco.com/AXL/1.0" xsi:schemaLocation="http://www.cisco.com/AXL/1.0 http://ccmserver/schema/axlsoap.xsd" sequence="1">

JanDzbanjan.dzban911

Response:

http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">

http://www.cisco.com/AXL/1.0" xmlns:xsi="http://www.cisco.com/AXL/1.0">

{15CA4682-C5B6-4C31-9C76-E3222D21F217}

But I think your problem is that your CUCM have LDAP synchronization enabled for user accounts. Adding users then is impossible, you can only import them.

--

regards,

PK

Re: AXL addUser request on ccm5+

Thanks for posting a working example.

Since Friday, I'm actually good. I opened a case, sent in traces and the traces showed that my command was incomplete

(it contained something like <> which of course won't work).. the weird thing is that the getUser command worked and the header building part is not dependant on the operation type.

I also had rebooted the ccm after installing some locales, so I suspect that the reboot took care of things as now adding users is no longer a problem.

196
Views
0
Helpful
5
Replies