Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

axl problems

Hi,

i have problems to add CSS and LineGroup using SOAP-AXL.

If i add partition (addRoutePartition)it's all ok, but if i add an object that has members (addCSS or addLineGroup) i haven't code errors but the objects is not created.

Can you help me?

This is the code:

axlquery("addLineGroup","

<lineGroup>

<name>LGtest</name>

<distributionAlgorithm>Circular</distributionAlgorithm>

<rnaReversionTimeout>10</rnaReversionTimeout>

<huntAlgorithmNoAnswer>Stop hunting</huntAlgorithmNoAnswer>

<members>

<member>

<lineSelectionOrder>1</lineSelectionOrder>

<dnPatternAndPartition>

<dnPattern>9300</dnPattern>

<routePartitionName>LabPT</routePartitionName>

</dnPatternAndPartition>

</member>

</members>

</lineGroup>

", callManager, callManagerUserId, callManagerPassword);

7 REPLIES
New Member

Re: axl problems

You aren't getting a SOAP fault? That would be a bug in itself, one would think.

Re: axl problems

Have you tried just adding an empty group, then adding members via update? Also, have you tried adding members via line css rather than dn and partition, or dn and partition uuid rather than partition name? I know there are generally more and less convenient ways of doing things, but internally everything is connected to the uuids and if you do a get on an existing linegroup, you'll see members with uuids (I think.. I haven't done it but that's my experience with other get operations).

And I'd like to re-iterate my question.. do you get no error whatsoever? For an add operation, you should get a uuid back.. do you get it and if you search the appropriate DB table, is it there?

New Member

Re: axl problems

I would like to confirm, this is an issue. I attempted adds of CSS alone, adds of CSS with members that are UUID of route partitions (looking them up before building the string) and attempted adds of CSS with members of RoutePartition Name.

No dice.

The simple object adds are fine (Route Partition).

My string is being built correctly, I'm able to confirm that during debugging. The axl post looks like it goes through as there are NO ERRORS.

New Member

Re: axl problems

Here is an example post:

http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2000/10/XMLSchema-instance" xmlns:xsd="http://www.w3.org/1999/XMLSchema"> http://www.cisco.com/AXL/1.0" xsi:schemaLocation="http://www.cisco.com/AXL/1.0 http://192.168.200.90/schema/axlsoap.xsd" sequence="1234"> bryce-PhoneDevice-CSSbryce-PSTN-911-PTDenis-PSTN-911-PTDenis-IPPhones-PTDenis-PSTN-LD-PT

Re: axl problems

you are missing index, see my reply on your other post

New Member

Re: axl problems

Thanks for your help in both posts.

Referring to my other, with index included, it still does nothing. (Response 200 ok sent back, no DB writing, no errors).

New Member

Re: axl problems

The issue was in the string build of the members, a tag wasnt closed. Thanks!

238
Views
0
Helpful
7
Replies
CreatePlease login to create content