Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

AXL Serviceability code not working on CM6.0, Please Help

Hi,

I am trying to run the AXL Serviceability code against my CM6.0.

But unfortunately, when executed, i get an error which asks me to check the XML document structure.

When viewed the xml request code snippet in an xml editor, its all fine...all the open tags have the corresponding closing tags.

I did try with various xml messages; the output is always the same.

Please help me in this regards.

Thanks

Shank

Request Header:

POST /realtimeservice/services/RisPort HTTP/1.1

Content-Type: text/xml; charset=utf-8

SOAPAction: "http://schemas.cisco.com/ast/soap/action/#RisPort#SelectCmDevice"

Authorization: Basic xxxxxxxxxxxxxxxxxxxxx

Host: x.x.x.x

Content-Length: 240

Soap Message:

<?xml version="1.0" encoding="utf-8"?>

<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/" xmlns:tns="http://schemas.cisco.com/ast/soap/" xmlns:types="http://schemas.cisco.com/ast/soap/encodedTypes" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">

<soap:Header>

<tns:AstHeader id="id1">

<SessionId xsi:type="xsd:string">2006-02-01T07:16:21</SessionId>

</tns:AstHeader>

</soap:Header>

<soap:Body soap:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">

<tns:SelectCmDevice>

<CmSelectionCriteria href="#id1"/>

</tns:SelectCmDevice>

<tns:CmSelectionCriteria id="id1" xsi:type="tns:CmSelectionCriteria">

<MaxReturnedDevices xsi:type="xsd:unsignedInt">4294967295</MaxReturnedDevices>

<Class xsi:type="tns:DeviceClass">Phone</Class>

<Model xsi:type="xsd:unsignedInt">0</Model>

<Status xsi:type="tns:CmDevRegStat">Any</Status>

<SelectBy xsi:type="tns:CmSelectBy">Name</SelectBy>

<SelectItems href="#id2"/>

</tns:CmSelectionCriteria>

<soapenc:Array id="id2" soapenc:arrayType="tns:SelectItem[1]">

<Item href="#id3"/>

</soapenc:Array>

<tns:SelectItem id="id3" xsi:type="tns:SelectItem">

<Item xsi:type="xsd:string">SEP0017E00CCC11</Item>

</tns:SelectItem>

</soap:Body>

</soap:Envelope>

Response:

HTTP/1.1 500 Internal Server Error

Server: Apache-Coyote/1.1

Set-Cookie: JSESSIONIDSSO=95D6DB9B11D5BBEA9A74F5E72D34D3A0; Path=/

Set-Cookie: JSESSIONID=921AACE45DDADBE70DD99DD6C432D633; Path=/realtimeservice; Secure

Set-Cookie: SoapSession.id=1742396451575972205

Content-Type: text/xml;charset=utf-8

Transfer-Encoding: chunked

Date: Tue, 06 May 2008 16:13:25 GMT

Connection: close

23f

<?xml version="1.0" encoding="utf-8"?>

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<soapenv:Body>

<soapenv:Fault>

<faultcode>soapenv:Server.userException</faultcode>

<faultstring>org.xml.sax.SAXParseException: XML document structures must start and end within the same entity.</faultstring>

<detail><ns1:hostname xmlns:ns1="http://xml.apache.org/axis/">test.myhome.com</ns1:hostname>

</detail>

</soapenv:Fault>

</soapenv:Body>

</soapenv:Envelope>

0

2 REPLIES
New Member

Re: AXL Serviceability code not working on CM6.0, Please Help

try removing at the beginning of the request body.

HTH,

Alberto

Re: AXL Serviceability code not working on CM6.0, Please Help

You might wanna search for the thread where I asked for a SelctCmDevices example.. then use that as a starting point. That's how I finally managed to get things working on my CCM 5.1 and 6.1.

153
Views
0
Helpful
2
Replies