Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

AXL with VMWARE doesnt work

Hi people,

I am trying to test axl applications in a callmanager (ver. 5.1.1.2000-2) running inside a vmware. The PC is an Windows XP Pro, core2duo with 2G memory.

I have tried to run the java example illustrated in the Developers Guide for Release 5.0, but it returns nothing, in fact, returns special caracters "".

I also have tried with php and returns the same thing.

The java code is attached here.

Is my code correct?

The PC is running with IIS, PHP 5 and Netbeans 5.5 with JDK 1.6.

The PC has IP 10.1.1.100, the callmanager inside the vmware has IP 10.1.1.1. The files are in the PC, and when I call them, I got the error above described.

Any one got the same problem?

Can any one post a correct example?

Thanks.

7 REPLIES

Re: AXL with VMWARE doesnt work

Hi,

You cannot just open a socket to a secure connection (HTTPS)

have a look at the axlsqltoolkit, it has an example of how to connect.

New Member

Re: AXL with VMWARE doesnt work

Hi Monteiro,

Finally it works.

Is possible to update an registry ou only query the database?

Some thing like:

update device set description='abcde' where pkid='089d9f80df98fdf'

I have triend this and I got the following response:

http://schemas.xmlsoap.org/soap/envelope/">

SOAP-ENV:Client

Method only for queries

http://www.cisco.com/AXL/1.0">-79750

Method only for queries

executeSQLQuery

Thanks!

Re: AXL with VMWARE doesnt work

I am not sure how you can update via executesqlquery

(you couldn't in cm4.x)

It's better to do a updatePhone via AXL

New Member

Re: AXL with VMWARE doesnt work

Hi Monteiro,

Can you give me a example using updatePhone?

Thank you.

Re: AXL with VMWARE doesnt work

did you access the AXL schema?

>

SEP0000AABBCCDDThis is a test

Re: AXL with VMWARE doesnt work

In CCM 5.x and higher you can use executeSQLUpdate to update the database (insert, update or delete) - there is no equivalent in CCM 4 and lower.

New Member

Re: AXL with VMWARE doesnt work

Hi Stephan,

You are right!

The axlsqltoolkit example for CCM 5.1 works with executeSQLUpdate.

Thanks!

Also thanks to Monteiro.

175
Views
0
Helpful
7
Replies
CreatePlease to create content