Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

axlapi.wsdl - axl API wsdl . AXIS 1.4

Hi all!

I'm trying to get a Web Service from AXLAPI.wsdl using AXIS 1.4 to access AXL SOAP in CCM 5.1.

This file generates wrong classes, I tried to follow the suggestion proposed by the readme file in axlsqltoolkit but I had the following error (Could not convert Lcom.cisco.www.AXL.API._1_0.XUserAssociatedGroupsUserGroupUserRolesUserRole). If one of you is an XML WSDL expert and reach the solution, please tell us!

Maurizio Ferro

to bean field 'userRoles', type [Lcom.cisco.www.AXL.API._1_0.XUserAssociatedGroupsUserGroupUserRolesUserRole;

2 REPLIES
New Member

Re: axlapi.wsdl - axl API wsdl . AXIS 1.4

I don't know the answer to the problem exactly--but .NET has a very similar problem.

If you look at the .NET-versioned WSDL Readme.txt, you can see that it has an issue at runtime. The resolution for .NET is the following (I don't know if it maps to what to the java code but maybe it'll give you a pointer).

From readme:

Resolving Errors which Manifest During JIT

With the current code, one can compile and attempt to instantiate the AXLAPIService class. However, one error will manifest as the types are inspected and loaded.

- Class XUserUserGroup has a field which was generated incorrectly. One must remove one of the ?[]? from the two ?[][]? brackets after XUserUserGroupUserRolesUserRole field:

public XUserUserGroupUserRolesUserRole[] userRoles;

Re: axlapi.wsdl - axl API wsdl . AXIS 1.4

If following the readme doesn't help, you should open a case regardless of whether you manage to find your own solution.

279
Views
0
Helpful
2
Replies