Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

BAT Import "Subscript out of range"

I'm attempting to import phones and users with the BAT version 5.0(2) and CCM 4.0. The file is validated fine, but when I do the insert, the browser returns the error dialog:

Error Number: -2146828279

Description: Subscript out of range

The users then appear to be imported, but not the devices. Looking up the error on google indicates that it's a VBA scripting problem. I tried firefox, but it doesn't seem to work at all.

Thanks for any suggestions,

Mark

5 REPLIES
Community Member

Re: BAT Import "Subscript out of range"

UPDATE: I just attempted to insert only the phones and only the users. The phone insert failed with the same error. The user insert worked properly. I suspect there is some problem with either my browsers or the verion of BAT I am running.

Mark

Community Member

Re: BAT Import "Subscript out of range"

Hello, I am having a same type of issue when I try to import 7912 sets…My 7940 and 7960 imported w/ no issues (Phone and Users). When I import the 7912 the Users import fine however the phone kick out the following error “Error Number:2146828275, Description Type Mismatch…I do not see anywhere on the Cisco site that references the error number…How did you make out w/ your issue?

Community Member

Re: BAT Import "Subscript out of range"

The core issue for me was that ANY data the Callmanager didn't like would result in that error - two problems I had were not putting leading zeros on the number of lines (it requires 2 digits), and trying to use commas in the description (even enclosed in quotes which the documentation says will work, it doesn't). I did have to load the new device pack for 7911 support when I did this install, but I only had 4 7911's so I did them manually, and no 7912's.

Good Luck,

Mark

Community Member

Re: BAT Import "Subscript out of range"

Cool....Thanks for the update

Re: BAT Import "Subscript out of range"

I have run into this issue when the verison of BAT was not upgraded after a CallManager upgrade. Re-run the BAT install from the current CallManager's plugins.

363
Views
0
Helpful
5
Replies
CreatePlease to create content