Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.
New Member

Big problem with adsl pppoe voice, LLQ and QoS

Hello.

It has been very hard to me to deploy a solution it seemed easy....

I'm using a 827-4v as spoke and a 1760 as a hub, IPSEC tunnels, voIP, both routers connect directly to the internet via an ADSL link as a pppoe CLIENT, the hub has fixed IP address, the spoke dynamic.

I have a working tunnel between them, I can send data even voice but when there is network congestion the voice packets suffers the most.

READ about QoS, concluded that LLQ and LFI are features to resolve my problem, but when I configure the routers the only thing I have achieved is packet priority but NOT BANDWIDTH RESERV.

I HAVE NO IDEA WHAT AM I DOING WRONG, hundreds of docs explain how to do it PLEASE read my configs:

HUB --- Cisco 1760

-------------------

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

service internal

!

hostname cuu00

!

enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxx

!

username cisco password 7 xxxxxxxxxxxx

memory-size iomem 15

voice-card 0

!

aaa new-model

!

!

aaa authorization network hw-client-groupname local

aaa session-id common

ip subnet-zero

no ip source-route

!

!

ip telnet source-interface FastEthernet0/0

!

ip cef

vpdn enable

!

vpdn-group pppoe

request-dialin

protocol pppoe

!

!

class-map match-all voip

match access-group 100

!

!

policy-map qos_map

class voip

set precedence 5

priority 128

class class-default

set precedence 0

!

!

!

voice call carrier capacity active

!

!

!

!

!

!

!

!

!

mta receive maximum-recipients 0

!

crypto isakmp policy 1

encr 3des

authentication pre-share

crypto isakmp key xxxxxxx address 0.0.0.0 0.0.0.0

crypto isakmp keepalive 40

!

!

crypto ipsec transform-set rtpset esp-3des esp-sha-hmac

!

crypto dynamic-map rtpmap 10

set transform-set rtpset

match address 115

!

!

crypto map rtptrans 10 ipsec-isakmp dynamic rtpmap

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.100.15 255.255.255.0

ip nat inside

ip tcp adjust-mss 1452

speed auto

no cdp enable

h323-gateway voip interface

h323-gateway voip bind srcaddr 192.168.100.15

!

interface ATM1/0

bandwidth 512

no ip address

no atm ilmi-keepalive

pvc 8/81

pppoe-client dial-pool-number 1

!

dsl operating-mode auto

!

interface Dialer1

mtu 1492

bandwidth 512

ip address xxxxxxxxxxxxxxxxx

ip nat outside

encapsulation ppp

dialer pool 1

service-policy output qos_map

no cdp enable

ppp chap hostname xxxxxxxxx

ppp chap password 7 xxxxxxxxxxxxx

ppp pap sent-username xxxxxxxx password 7 xxxxxxxxxxxxxxxxx

ppp multilink

ppp multilink fragment-delay 48

ppp multilink interleave

crypto map rtptrans

!

ip nat inside source route-map nonat interface Dialer1 overload

ip nat inside source static tcp 192.168.100.187 80 INTERNET_FIXED_IP 80 extendable

ip nat inside source static tcp 192.168.100.187 53 INTERNET_FIXED_IP 53 extendable

ip nat inside source static tcp 192.168.100.187 7 INTERNET_FIXED_IP 7 extendable

ip nat inside source static tcp 192.168.100.187 21 INTERNET_FIXED_IP 21 extendable

ip nat inside source static tcp 192.168.100.187 110 INTERNET_FIXED_IP 110 extendable

ip nat inside source static tcp 192.168.100.187 25 INTERNET_FIXED_IP 25 extendable

ip nat inside source static tcp 192.168.100.187 23 INTERNET_FIXED_IP 4444 extendable

ip nat inside source static udp 192.168.100.187 53 INTERNET_FIXED_IP 53 extendable

ip nat inside source static udp 192.168.100.187 7 INTERNET_FIXED_IP 7 extendable

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 192.168.6.0 255.255.255.0 Dialer1

ip http server

ip pim bidir-enable

!

!

access-list 100 permit ip any any dscp cs5

access-list 115 permit ip 192.168.100.0 0.0.0.255 192.168.6.0 0.0.0.255

access-list 199 deny ip 192.168.100.0 0.0.0.255 192.168.6.0 0.0.0.255

access-list 199 permit ip 192.168.100.0 0.0.0.255 any

no cdp run

!

route-map nonat permit 10

match ip address 199

!

snmp-server community public RO

no snmp-server enable traps tty

radius-server retransmit 3

radius-server authorization permit missing Service-Type

call rsvp-sync

!

voice-port 0/0

!

voice-port 0/1

!

voice-port 0/2

!

voice-port 0/3

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 1 pots

destination-pattern 00

port 0/0

!

dial-peer voice 2 pots

preference 1

destination-pattern 00

port 0/1

!

dial-peer voice 3 pots

preference 2

destination-pattern 00

port 0/2

!

dial-peer voice 4 pots

preference 3

destination-pattern 00

port 0/3

!

dial-peer voice 106 voip

destination-pattern 06

session target ipv4:192.168.6.101

codec g726r32

ip qos dscp cs5 media

ip qos dscp cs5 signaling

!

!

!

line con 0

password 7 xxxxxxxxxxxxxx

line aux 0

password 7 xxxxxxxxxxxxxx

modem Dialin

modem autoconfigure discovery

transport input all

speed 115200

flowcontrol hardware

line vty 0 4

password 7 xxxxxxxxxxxxxxxxx

!

end

SPOKE --- Cisco 827-4V

-----------------------

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname cuu01

!

logging queue-limit 100

no logging console

enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxx

!

ip subnet-zero

no ip domain lookup

ip dhcp excluded-address 192.168.6.101

!

ip dhcp pool CLIENT

import all

network 192.168.6.0 255.255.255.0

default-router 192.168.6.101

!

!

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

!

!

!

crypto isakmp policy 1

encr 3des

authentication pre-share

crypto isakmp key xxxx address INTERNET_IP_OF_HUB

crypto isakmp keepalive 40

!

!

crypto ipsec transform-set rtpset esp-3des esp-sha-hmac

!

crypto map rtp 1 ipsec-isakmp

set peer INTERNET_IP_OF_HUB

set transform-set rtpset

match address 115

!

!

!

class-map match-all voice

match access-group 101

!

!

policy-map qos-map

class voice

priority 96

!

!

!

!

interface Ethernet0

ip address 192.168.6.101 255.255.255.0

ip nat inside

ip tcp adjust-mss 1452

no cdp enable

h323-gateway voip interface

h323-gateway voip bind srcaddr 192.168.6.101

hold-queue 100 out

!

interface ATM0

no ip address

atm vc-per-vp 128

no atm ilmi-keepalive

pvc 8/35

pppoe-client dial-pool-number 1

!

dsl operating-mode auto

!

interface Dialer1

bandwidth 128

ip address negotiated

ip mtu 1492

ip nat outside

service-policy output qos-map

encapsulation ppp

ip tcp adjust-mss 1452

no ip mroute-cache

dialer pool 1

dialer remote-name redback

dialer-group 1

no cdp enable

ppp authentication pap chap callin

ppp chap hostname xxxxxxxxxxxx

ppp chap password 7 xxxxxxxxxxxxxxxxxx

ppp pap sent-username xxxxxxxxxxx password 7 xxxxxxxxxxxxxxxxx

ppp multilink

ppp multilink fragment-delay 75

ppp multilink interleave

crypto map rtp

!

ip nat inside source route-map nonat interface Dialer1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 192.168.100.0 255.255.255.0 Dialer1

ip http server

no ip http secure-server

!

!

access-list 101 permit ip any any precedence critical

access-list 115 permit ip 192.168.6.0 0.0.0.255 192.168.100.0 0.0.0.255

access-list 120 deny ip 192.168.6.0 0.0.0.255 192.168.100.0 0.0.0.255

access-list 120 permit ip 192.168.6.0 0.0.0.255 any

dialer-list 1 protocol ip permit

no cdp run

!

route-map nonat permit 10

match ip address 120

!

snmp-server community public RO

snmp-server enable traps tty

call rsvp-sync

!

voice-port 1

!

voice-port 2

!

voice-port 3

!

voice-port 4

!

dial-peer voice 1 pots

destination-pattern 06

port 1

!

dial-peer voice 2 pots

preference 1

destination-pattern 06

port 2

!

dial-peer voice 3 pots

preference 2

destination-pattern 06

port 3

!

dial-peer voice 4 pots

preference 3

destination-pattern 06

port 4

!

dial-peer voice 600 voip

destination-pattern 00

session target ipv4:192.168.100.15

codec g726r32

ip qos dscp cs5 media

!

!

line con 0

password 7 xxxxxxxxxxxxxxxxx

login

stopbits 1

line vty 0 4

exec-timeout 120 0

password 7 xxxxxxxxxxxxxxxxx

login

length 0

!

scheduler max-task-time 5000

end

*************************************

When I apply the service-policy in the 1760 a note

appears telling me that CBWFQ is only supported on MLPPP interfaces, READ a "TALK to the expert" and somebody said that MLPPP IS NOT supported with pppoe... is this true???

HOW CAN I reserve bandwidth for the voice to be encrypted ????

What is wrong with the config's above???

ANY HELP WILL BE VEEERRRYYY appreciated...

1 REPLY
New Member

Re: Big problem with adsl pppoe voice, LLQ and QoS

Hi

I read you configurations and have some considerations to you.

To guarantee bandwith end-to-end you need rsvp and all routers between path need have rsvp enable. WHat is not possible in your net.

To resolve you problem llq is the best solution.

I have some things about you configuration that can help you.

HUB --- Cisco 1760

class-map match-all voip

match access-group 100

change to

class-map match-all voip

match ip dscp cs5

class-map match-all signaling

match ip dscp cs3

-Never transport signaling with voice, this comunication need 0.5kbps per voice conversation.

policy-map qos_map

class voip

set precedence 5

priority 128

class class-default

set precedence 0

change to:

policy-map qos_map

class voip

!set precedence 5 - no need this

priority 128

class signaling

bandwidth 10

!assuming that you use 2 voice calls

class class-default

random-detect

!set precedence 0 no need this, all traffic that no

!match with precedence classes go into this call per

!default

crypto dynamic-map rtpmap 10

set transform-set rtpset

match address 115

qos pre-classify

!qos pre-classify you order router classify qos before send opver tunnel.

dial-peer voice 106 voip

destination-pattern 06

session target ipv4:192.168.6.101

codec g726r32

ip qos dscp cs5 media

ip qos dscp cs5 signaling

change-to:

dial-peer voice 106 voip

destination-pattern 06

session target ipv4:192.168.6.101

codec g726r32

!you need use this codec??g729 reduce bandwidth

!consumption

ip qos dscp cs5 media

ip qos dscp cs3 signaling

!you mark signaling widht different dscp

In SPOKE --- Cisco 827-4V , you make same configurations change (same 1760), and you qos must improve.

Any question my mail is j.medeiros@agm-tele.com, i QoS Certified.

Best Regards

Joao Medeiros

407
Views
0
Helpful
1
Replies
CreatePlease to create content