Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Call Manager 5.1.2 Route Pattern Problem

Hi,

I configured an MGCP Gateway with an FXO port. I created a Route Pattern that when 0 is pressed, it connects to the FXO port and give the PSTN dialtone. Everything works fine, the only thing is that on the display, when I press 0 I get "To Unknown Number". I have 0. in the pattern and I configured it to discard PreDot.

How can I display the dialed number instead on "To Unknown Number"?

Thanks for your help.

ALex

4 REPLIES
New Member

Re: Call Manager 5.1.2 Route Pattern Problem

What is your intent? Do you want to dial "0" (rather then the more common "9") to get outside dial tone and then dial the number?

Is "0." the complete Route Pattern?

If, for example, you want to dial "0" followed by "1", an Area Code, and 7 more digits, your Route Pattern should be "0.1[2-9]XX[2-9]XXXXXX"

The Display will show the digits that match your Route Pattern after the ".".

New Member

Re: Call Manager 5.1.2 Route Pattern Problem

Hi,

Thanks for the reply.

It does not really matter if it is a 0 or 9. All I want is that when I type 0 (or 9) I get the dialtone of the line connected to the FXO port and then type the telephone number.

The number could be either a local mobile/ficed number comprised of 8 digits or it could also be an overseas number with country code and aread code.

My current Route Pattern is 0.

Currently the CCM is set up to ask for an Authorisation code after the 0 is pressed.

Thanks again,

Alex

New Member

Re: Call Manager 5.1.2 Route Pattern Problem

please try this route pattern

"0.@"

New Member

Re: Call Manager 5.1.2 Route Pattern Problem

I actually tried the 0.@ but the @ implies a numbering plan and there is no numbering plan for Malta. I only have NANP.

I then tried 0.XXXXXXXX and it is now working.

Thanks for your help.

Alex

128
Views
0
Helpful
4
Replies
CreatePlease to create content