Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Call Manager 5 - 3750 Switch Config

I had a working CM setup until I put some QoS and VLANs onto my 3750G-24PS switch. Now, the phones will not find the CM.

What did I do wrong? Here is my config, showing the two types of port setups I have in use:

ip subnet-zero

ip routing

no ip domain-lookup

ip dhcp excluded-address 10.250.250.1 10.250.250.50

ip dhcp excluded-address 10.251.251.1 10.251.251.50

!

ip dhcp pool Data

network 10.250.250.0 255.255.255.0

default-router 10.250.250.1

dns-server 10.250.250.5

option 150 ip 10.250.250.5

!

ip dhcp pool IPPhones

network 10.251.251.0 255.255.255.0

default-router 10.251.251.1

dns-server 10.250.250.5

option 150 ip 10.250.250.5

!

ip dhcp-server 10.250.250.1

ip dhcp-server 10.251.251.1

!

mls qos map cos-dscp 0 8 16 26 32 46 48 56

mls qos

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

vlan dot1q tag native

!

!

interface GigabitEthernet1/0/1 <--- Phone connected here

switchport access vlan 1

switchport mode access

switchport voice vlan 100

mls qos trust device cisco-phone

mls qos trust cos

spanning-tree portfast

spanning-tree bpdufilter disable

spanning-tree bpduguard enable

!

interface GigabitEthernet1/0/2 <--- CM connected here

switchport trunk encapsulation dot1q

switchport mode trunk

switchport access vlan 1

switchport access vlan 100

spanning-tree portfast

spanning-tree bpdufilter disable

spanning-tree bpduguard enable

!

........

!

interface GigabitEthernet1/0/22 <--- To Router

description To Internet Router

no switchport

ip address 192.168.1.2 255.255.255.0

spanning-tree portfast

spanning-tree bpdufilter disable

spanning-tree bpduguard enable

!

!

interface Vlan1

description Data

ip address 10.250.250.1 255.255.255.0

!

interface Vlan100

description Voice

ip address 10.251.251.1 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.1

ip http server

!

!

!

control-plane

!

!

line con 0

line vty 0 4

no login

length 0

line vty 5 15

no login

!

!

end

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Call Manager 5 - 3750 Switch Config

Try removing the Dot1q trunk from your interface the CCM is connected to and remove all the other vlans except the voice vlan the CCM is connected to on that interface. Looks like you may have conflicting Switchport Access statements on your Interface. Make the interface connected to your CCM an access port not a trunk. Put this access port into the Voice Vlan.

5 REPLIES
New Member

Re: Call Manager 5 - 3750 Switch Config

Also, I just reset the switch back to factory default, and the phones STILL will not find the CCM. Any ideas?

New Member

Re: Call Manager 5 - 3750 Switch Config

Just to let everyone know, the reason the phones STILL did not communicate after resetting the switch to factory default was an error in the CCM. Cisco found corruption and recommended I wipe and reload the CCM. I have done so, and communication was restored.

I am going to try JodyHinson's recommendation this afternoon.

New Member

Re: Call Manager 5 - 3750 Switch Config

Try removing the Dot1q trunk from your interface the CCM is connected to and remove all the other vlans except the voice vlan the CCM is connected to on that interface. Looks like you may have conflicting Switchport Access statements on your Interface. Make the interface connected to your CCM an access port not a trunk. Put this access port into the Voice Vlan.

New Member

Re: Call Manager 5 - 3750 Switch Config

Thank you very much. I will try that.

A very stupid question:

Should my CallManager be on the same subnet as my IP Phones, or on the Data subnet (where my Windows servers are located)?

New Member

Re: Call Manager 5 - 3750 Switch Config

As long as you can route to them it does not matter, but I would warn you against putting them on your Data network. The whole point is to seperate the traffic, So either create a vlan specifically for your CCM Servers or put them on the IP Phone Network! I always install my servers on a different VLAN than the phones and other devices including Data.

680
Views
0
Helpful
5
Replies