Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

caller ID display problem

Voice and Video

Forum Topics > Conversations > Outline > Messages

Hi,

I can't get this caller ID display to work. at present, all outgoing calls display only the main pri number instead of individual number. The Telco has confirmed that the line can support individual caller ID display.

I have tried to configure the external phone number mask for each line like 68275XXX where XXX is my 3 digit extension. but it doesn't work out.

what are the steps to get this thing done? Can any other CCM/voice gateway setting offset what I have done?

append is my voice gate config:

!

logging buffered 4096 debugging

aaa new-model

aaa authentication password-prompt PASSWORD(Authorized-User-Only):

aaa authentication username-prompt USERNAME(Authorized-User-Only):

aaa authentication login default local

!

clock timezone SGP 8

ip subnet-zero

no ip source-route

!

ip audit notify log

ip audit po max-events 100

isdn switch-type primary-net5

no call rsvp-sync

no voice hunt unassigned-number

no voice hunt invalid-number

!

voice service voip

!

voice class codec 100

codec preference 1 g711ulaw

codec preference 2 g711alaw

!

!

!

!

!

voicecard mode gateway

!

controller E1 1/0

pri-group timeslots 1-31

description : : First E1 line to PSTN

!

controller E1 1/1

pri-group timeslots 1-31

description : : Second E1 Line to PSTN

!

translation-rule 68275

Rule 0 ^682756.% 6

Rule 1 ^682757.% 7

Rule 2 ^682758.% 8

!

!

!

!

interface Loopback0

ip address 192.168.1.1 255.255.255.0

h323-gateway voip interface

h323-gateway voip bind srcaddr 192.168.1.1

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/0.5

!

interface GigabitEthernet0/0

no ip address

no negotiation auto

!

interface GigabitEthernet0/0.1

description : : Virtual Routing Interface for Voice VLAN

encapsulation dot1Q 50

ip address 10.178.196.252 255.255.255.0

ip helper-address 10.178.223.11

!

interface GigabitEthernet0/0.2

description : : Virtual Routing Interface for User VLAN

encapsulation dot1Q 4

ip address 10.178.192.252 255.255.255.0

ip helper-address 10.178.223.11

!

interface GigabitEthernet0/0.4

encapsulation dot1Q 1 native

!

interface GigabitEthernet0/0.5

description : : Virtual Routing Interface for ETPL VLAN

encapsulation dot1Q 3

ip address 10.178.204.252 255.255.255.0

ip helper-address 10.178.204.4

!

interface GigabitEthernet0/0.10

description : : Virtual Routing Interface for Server VLAN

encapsulation dot1Q 2

ip address 10.178.223.250 255.255.255.0

ip helper-address 10.178.223.11

!

interface Serial1/0:15

description : : First E1 line D-Channel to PSTN

no ip address

no logging event link-status

isdn switch-type primary-net5

isdn incoming-voice voice

isdn T309-enable

isdn send-alerting

isdn sending-complete

no cdp enable

!

interface Serial1/1:15

description : : Second E1 line D-Channel to PSTN

no ip address

no logging event link-status

isdn switch-type primary-net5

isdn incoming-voice voice

isdn T309-enable

isdn send-alerting

isdn sending-complete

no cdp enable

!

ip default-gateway 10.178.223.1

ip http server

ip http access-class 80

ip classless

ip route 0.0.0.0 0.0.0.0 10.178.223.1

ip route 10.178.203.0 255.255.255.0 10.178.223.251

ip pim bidir-enable

!

logging trap debugging

!

voice-port 1/0:15

input gain 1

output attenuation 1

echo-cancel coverage 24

cptone SG

!

voice-port 1/1:15

input gain 1

output attenuation 1

echo-cancel coverage 24

cptone SG

!

dial-peer voice 10 voip

incoming called-number 68275...

destination-pattern 68275...

progress_ind setup enable 3

translate-outgoing called 68275

session target ipv4:10.178.196.1

dtmf-relay cisco-rtp h245-signal h245-alphanumeric

ip precedence 5

no vad

!

dial-peer voice 100 pots

preference 1

destination-pattern ........

progress_ind alert enable 8

direct-inward-dial

port 1/0:15

forward-digits all

!

dial-peer voice 101 pots

preference 1

destination-pattern 9........

progress_ind alert enable 8

direct-inward-dial

port 1/0:15

forward-digits all

!

dial-peer voice 102 pots

preference 1

destination-pattern 1800T

progress_ind alert enable 8

direct-inward-dial

port 1/0:15

forward-digits all

!

dial-peer voice 103 pots

preference 1

destination-pattern 6.......

progress_ind alert enable 8

direct-inward-dial

port 1/0:15

forward-digits all

!

dial-peer voice 104 pots

preference 1

destination-pattern 1...

progress_ind alert enable 8

direct-inward-dial

port 1/0:15

forward-digits all

!

dial-peer voice 105 pots

preference 1

destination-pattern 800T

progress_ind alert enable 8

direct-inward-dial

port 1/0:15

forward-digits all

!

dial-peer voice 106 pots

preference 1

destination-pattern 1..

progress_ind alert enable 8

direct-inward-dial

port 1/0:15

forward-digits all

!

dial-peer voice 200 pots

preference 2

destination-pattern ........

progress_ind alert enable 8

direct-inward-dial

port 1/1:15

forward-digits all

!

dial-peer voice 201 pots

preference 2

destination-pattern 9........

progress_ind alert enable 8

direct-inward-dial

port 1/1:15

forward-digits all

!

dial-peer voice 202 pots

preference 2

destination-pattern 1800T

progress_ind alert enable 8

direct-inward-dial

port 1/1:15

forward-digits all

!

dial-peer voice 203 pots

preference 2

destination-pattern 6.......

progress_ind alert enable 8

direct-inward-dial

port 1/1:15

forward-digits all

!

dial-peer voice 204 pots

preference 2

destination-pattern 1...

progress_ind alert enable 8

direct-inward-dial

port 1/1:15

forward-digits all

!

dial-peer voice 205 pots

preference 2

destination-pattern 800T

progress_ind alert enable 8

direct-inward-dial

port 1/1:15

forward-digits all

!

dial-peer voice 206 pots

preference 2

destination-pattern 1..

progress_ind alert enable 8

direct-inward-dial

port 1/1:15

forward-digits all

!

voicecard sccp manager 10.178.196.1 port 2000

voicecard sccp local Loopback0

voicecard conference

voicecard transcode

end

6 REPLIES
New Member

Re: caller ID display problem

Verify that you have the presentation bit set to allowed in your gateway config on CCM. Debug q931 on your voice gateway to show what calling number you are passing to the carrier.

New Member

Re: caller ID display problem

I have set the presentation bit to on. when I do a debug Q931, I can see the calling party number is the full number passing to the carrier. e.g. 68275606.

i am using CCM 3.1a.

do you think reinstalling the call manager will work?

New Member

Re: caller ID display problem

I had experienced a problem where the carrier was not passing on caller id but was passing all calls and masking them with the main DID number.

Might be an idea to check if they're restricting any caller id information.

New Member

Re: caller ID display problem

Hi,

If you see, in CCM traces or debugs from the GW, that the digits are send outbound, talk with your provider and make sure you have the exact digit format they expect to get from you. If you miss that format all calls are "Private" or no-CLID.. for example: your extension is 8001, your main,/lead number is 02-1234-8001 but your provider expects you to send 2-1234-8001 (note that the 0 has been ommited) they will add the extra 0!.

Again, you need to have a tlak with them to find out the exact digit format they expect to get from you.

Danny M.

New Member

Re: caller ID display problem

In CallManager, under the gateway, make sure you have the appropriate numbering plans setup. If you leave them as CallManager, The Telco may reject the IE. So in North America you would set the Calling Party IE Number Type Unknown to National and The Calling Numbering Plan to ISDN

New Member

Re: caller ID display problem

Hi folks,

Thanks so much. I tried to change the calling party IE number type to National and the Calling numbering plan to ISDN, it works.

Thank you very much,

Paul

188
Views
0
Helpful
6
Replies
CreatePlease login to create content