Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Caller-ID Failure - VG200/FXO-M1/CM3.2

Hey There,

I finally swapped out the FXO WIC's to FXO-M1's so that we could get Caller-ID on our Lab system. Its not working!!! Arrg.

When there is a call in progress I can see the Caller-ID Info on the VG200 (both number and name!) but it doesn't get passed along to CM. I am using MCGP. Here is the config:

12.2.(11)T5 on a VG200

Building configuration...

Current configuration : 1265 bytes

!

version 12.2

no parser cache

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname HDQ-VG1

!

enable secret 5 *************************

!

ip subnet-zero

!

!

!

voice call carrier capacity active

!

!

!

!

!

!

!

!

!

ccm-manager mgcp

!

!

interface FastEthernet0/0

ip address 192.168.1.10 255.255.255.0

no ip mroute-cache

duplex auto

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.1

no ip http server

ip pim bidir-enable

!

!

snmp-server community ******RO

snmp-server enable traps tty

call rsvp-sync

!

voice-port 1/0/0

input gain 8

caller-id enable

!

voice-port 1/0/1

input gain 8

caller-id enable

!

voice-port 1/1/0

input gain 8

caller-id enable

!

voice-port 1/1/1

input gain 8

caller-id enable

!

mgcp

mgcp call-agent 192.168.1.20 service-type mgcp version 0.1

!

mgcp profile default

!

dial-peer voice 1 pots

application mgcpapp

port 1/1/0

!

dial-peer voice 2 pots

application mgcpapp

port 1/1/1

!

dial-peer voice 3 pots

application mgcpapp

port 1/0/0

!

dial-peer voice 4 pots

application mgcpapp

port 1/0/1

!

!

line con 0

line aux 0

line vty 0 4

password ************

login

line vty 5 15

login

!

end

Is there something obvious? Whats the best way to troubleshoot this?

2 REPLIES
Silver

Re: Caller-ID Failure - VG200/FXO-M1/CM3.2

Not currently supported when running MGCP. The problem is all the call control signalling is backhauled to the CM when running MGCP, so the router doesn't know it has to look between the first and second rings for the caller ID information since the call control intelligence is on the Call Manager server..

Set up the gateway for H323 and it should work.

New Member

Re: Caller-ID Failure - VG200/FXO-M1/CM3.2

You can not do CLID with the FXO-M1 vic under MGCP mode. Not supported Revert to H.323 in order to do CLID.

101
Views
0
Helpful
2
Replies
CreatePlease to create content