Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

CallManager 4.1(3) and ACT Card on CMM Module Cat6k Config

Hi.

I have a problem using the ACT card for transcoding purposes. I already configured the ACT Mediacard resource-pool for transcoding and also I add the sccp configuration sourcing the traffic from the virtual GigabitEthernet1/0 on the CMM Module. I also add the dspfarm profile and associate the resource-pool. On the CCM I selected the IOS Enhanced Media Termination Point and I add the Device Name. The device shows as registered on the CallManager. On a remote site if I initate a conference I can see the dsps beign in used on the ACT card but the remote IP Phone is not hearing any conversation although the rest of the users in the conference (all at central site) are able to hear each other on the conference bridge.

Is this an error on the configuration part on the ACT? On the remote IP Phone (configured for G.729 accross the WAN) I see 0 frames received when the conference is established. I'm able to ping the Gigabit Ethernet IP address as well as the virtual fastethernet of the CMM from the remote IP Phone.

Any ideas?

-JJ

8 REPLIES

Re: CallManager 4.1(3) and ACT Card on CMM Module Cat6k Config

JJ,

I have had a similar issue with CMM, where there is no audio between 3 phones (all on g711 when I was testing, in the same lan), but they had a connection open to the ACT module for the conference session.

A sh sccp connection should reveal the 3 ip phones (ip addresses and codec, udp port etc). Can you paste the outputs of,

sh mediacard connection or sh sccp connection ?

I had a case open with Cisco TAC and the problem was with a bug. Suggested fix was an upgrade of IOS on CMM. What is your IOS version on the CMM ? Can you paste a sh version ?

HTH

PS: please remember to rate helpful replies.!

New Member

Re: CallManager 4.1(3) and ACT Card on CMM Module Cat6k Config

Thanks for your response.. Here is the show commands.

6509-CMM-GWY1#sh ver

Cisco IOS Software, Cat6K-lc Software (wscmm-I6S-M), Version 12.3(8)XY2, RELEASE

SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2004 by Cisco Systems, Inc.

Compiled Tue 16-Nov-04 12:19 by cmong

ROM: System Bootstrap, Version 12.2(1r)T2, RELEASE SOFTWARE (fc1)

6509-CMM-GWY1 uptime is 10 weeks, 4 days, 59 minutes

System returned to ROM by power-on

System restarted at 11:41:30 AST Fri Sep 30 2005

System image file is "bootflash:wscmm-i6s-mz.123-8.XY2.bin"

cisco WS-SVC-CMM Cat6k Voice Linecard (R7000) processor (revision 0xFF) with 196

608K/65536K bytes of memory.

Processor board ID SAD09010E57

R7000 CPU at 400MHz, Implementation 39, Rev 3.3, 256KB L2 Cache

Last reset from power-on

2 FastEthernet interfaces

1 Gigabit Ethernet interface

96 Serial interfaces

6 Channelized T1/PRI ports

32768K bytes of processor board bootflash (Read/Write)

Configuration register is 0x2102

6509-CMM-GWY1#

Total: 0

6509-CMM-GWY1#

6509-CMM-GWY1#sh mediacard connections

Id Type Slot/ RPort SPort RxPkts TxPkts Remote-Ip

DSP/Ch

1 xcode 4/1/1 19482 22392 203 0 172.16.56.34

2 xcode 4/1/2 31390 23256 198 0 172.16.55.12

Total: 2

6509-CMM-GWY1#

6509-CMM-GWY1#sh sccp conn

6509-CMM-GWY1#sh sccp connections

sess_id conn_id stype mode codec ripaddr rport sport

33560307 36347521 xcode sendrecv g711u 172.16.55.12 31390 23256

33560307 36347489 xcode sendrecv g729b 172.16.56.34 19482 22392

Total number of active session(s) 1, and connection(s) 2

6509-CMM-GWY1#

The IP Address 172.16.56.34 is the IP Phone across the WAN and the 172.16.55.12 is the IP Address of the CallManager. I'm using the IPVM service for conference right now and using the ACT for transcoding. The conference was initiated by the remote ip phone and 2 IP Phones from the central site were in the conference. They were able to talk to each other but i was unable to hear them and viceversa. I also tried to configured the ACT for conference resources but when I initate the conference from the remote ip phone I received a fast busy signal.

Here is the relevant config on the CMM for the ACT card:

----------------

interface GigabitEthernet1/0

ip address 172.16.57.5 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

no negotiation auto

no keepalive

!

interface FastEthernet3/0

description ** Ad-hoc Confr and Tcoding PA Mod 4 **

ip address 172.16.57.10 255.255.255.255

no ip redirects

no ip unreachables

no ip proxy-arp

half-duplex

!

mediacard 4

resource-pool xcode dsps 2

resource-pool cfb dsps 2

!

!

sccp local GigabitEthernet1/0

sccp ccm 172.16.55.12 identifier 2 version 4.1

sccp ccm 172.16.55.11 identifier 1 version 4.1

sccp

!

sccp ccm group 1

associate ccm 2 priority 1

associate ccm 1 priority 2

associate profile 2 register CFB00033235c614

associate profile 1 register MTP00033235c614

!

dspfarm

!

dspfarm profile 1 transcode

codec g711ulaw packetization-period 20

codec g711alaw packetization-period 20

codec g729r8 packetization-period 20

codec g729ar8 packetization-period 20

codec g723r63 packetization-period 30

codec g723r53 packetization-period 30

associate resource-pool xcode

!

dspfarm profile 2 conference adhoc

codec g711ulaw packetization-period 20

codec g711alaw packetization-period 30

codec g729r8 packetization-period 20

codec g729ar8 packetization-period 20

codec g723r63 packetization-period 30

codec g723r53 packetization-period 30

associate resource-pool cfb

!

!

----------------

On the CCM I added the conference as IOS Enhanced Conference Bridge and the Transcoder as IOS Enhanced Media Termination Point.

Any ideas?

-JJ

New Member

Re: CallManager 4.1(3) and ACT Card on CMM Module Cat6k Config

Hi.

Just to follow-up... I configured the ACT Card as a conference resource and the conference gets established using DSPs from the ACT card when initiating a conference bridge from a remote site that is configured for G.729 over the WAN. But the problem I'm having is that I don't have 2-WAY audio on all 3 participants...

However I can see the counters of the reveiced and trasmit packets that are incrementing with the show mediacard connection.

I think I will open a TAC case.

Any ideas?

-JJ

New Member

Re: CallManager 4.1(3) and ACT Card on CMM Module Cat6k Config

Hi,

When you add CMM ACTs in CCM 4.1(3) you need to add it as SVC-CMM not as enhanced IOS Media Termination point.

Once you inputted the Module and MAC information it generates a name for the Transcoder. Use that name to register the Transcoder in the CMM CLI.

HTH.

Jay

New Member

Re: CallManager 4.1(3) and ACT Card on CMM Module Cat6k Config

Hi Jay,

I already delete the Enhanced IOS MEdia Termination Point and I created the conference bridge by adding the SVC-CMM in the callmanager and then I used the Bridge name in the SCCP GROUP to register the device. The device is register properly but I'm still having 1-way audio on the parties involved in the conference using the DSPs from the ACT card. I'm using 12.3(8)XY6 on the CMM.

Regards,

-JJ

New Member

Re: CallManager 4.1(3) and ACT Card on CMM Module Cat6k Config

Hi,

Make sure your gig1/0 interface is in the proper VLAN and make sure you can ping the interface both ways.

You dont need to worry about Fa0/1 until you are planning to share the CMM between clusters.

I guess the one way audio is mainly a routing problem.

Thanks,

Jay

New Member

Re: CallManager 4.1(3) and ACT Card on CMM Module Cat6k Config

Hi

CMM ACT is using g1/0 only for signaling, but for media it is using fast ethernet interface. You must configure your fast ethernet interface connected to ACT (ip address from the same ip subnet as your g1/0 but with /32 netmask and assign it to the proper vlan) and everything should work.

Look here:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios123/123newft/123limit/123x/123xy8/gtcmm.htm#wp1200590

Regards

Wojtek

New Member

Re: CallManager 4.1(3) and ACT Card on CMM Module Cat6k Config

Hi,

I had not seen your configuration when I have sent my first post :-).

I have got similar configuration, but with 12.3.8XY6 and everything works fine.

In which way did you configure your default route, using "ip route 0.0.0.0 0.0.0.0 172.16.57.1" or "ip default-gateway 172.16.57.1"? In my case with "ip default-gateway X.Y.Z.W" I had one-way voice with calls between ISDN PRI and IP Phones...

Best Regards

Wojtek

369
Views
0
Helpful
8
Replies
CreatePlease to create content