Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CallManager and 2600 PRI via h.323

Does anyone have a sample configuration to share for a 2620 router used as a PRI gateway to CCM 3.0(8)?

1 REPLY
New Member

Re: CallManager and 2600 PRI via h.323

Here is a 3600 with PRI configured as H.323 gateway....enjoy

3640-GSX-R1#show run

Building configuration...

Current configuration:

!

version 12.1

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

service password-encryption

!

hostname 3640-GSX-R1

!

enable secret 5 $1$Tpeu$BBOAknyjPOkTCZB00sOsD.

!

!

!

!

!

voice-card 2

!

ip subnet-zero

ip tcp synwait-time 5

no ip domain-lookup

!

isdn switch-type primary-5ess

isdn voice-call-failure 0

call rsvp-sync

voice rtp send-recv

!

voice service pots

!

!

!

!

!

!

!

controller T1 2/0

framing esf

linecode b8zs

pri-group timeslots 1-24

!

controller T1 2/1

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation isl 10

ip address 172.16.1.251 255.255.255.0

no ip redirects

!

interface FastEthernet0/0.2

encapsulation isl 20

ip address 172.16.56.251 255.255.255.0

ip helper-address 172.16.1.11

no ip redirects

!

interface Serial2/0:23

no ip address

no logging event link-status

isdn switch-type primary-5ess

isdn incoming-voice voice

no cdp enable

!

router eigrp 1

network 172.16.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.1.250

no ip http server

!

!

voice-port 1/0/0

!

voice-port 1/0/1

!

voice-port 1/1/0

!

voice-port 1/1/1

!

voice-port 2/0:23

input gain 6

output attenuation 6

!

dial-peer cor custom

!

!

!

dial-peer voice 1 pots

destination-pattern 9T

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

direct-inward-dial

port 2/0:23

!

dial-peer voice 2 voip

destination-pattern 6302...

progress_ind setup enable 3

session target ipv4:172.16.56.2

dtmf-relay h245-alphanumeric

codec g711ulaw

!

dial-peer voice 3 voip

destination-pattern 6303...

progress_ind setup enable 3

session target ipv4:172.16.56.2

dtmf-relay h245-alphanumeric

codec g711ulaw

!

dial-peer voice 4 voip

destination-pattern 6304...

progress_ind setup enable 3

session target ipv4:172.16.56.2

dtmf-relay h245-alphanumeric

codec g711ulaw

!

dial-peer voice 5 pots

destination-pattern 9011T

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

port 2/0:23

!

dial-peer voice 100 pots

!

dial-peer voice 200 voip

!

gateway

!

!

line con 0

exec-timeout 0 0

logging synchronous

transport input none

line aux 0

modem InOut

modem autoconfigure discovery

speed 1200

flowcontrol hardware

line vty 0 4

password 7 10405B171303

login

!

end

116
Views
0
Helpful
1
Replies