Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Can only get port 0/0 on MRP3-8FXS to register

I am running 12.2(8)YN on the MRP3-8FXS and CCM 3.3(2)spC on the SPE's in a ICS7750. For some reason, only the first analog port will register with call manager. Here is the MRP3 config:

Am I missing something here?

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec localtime show-timezone

service password-encryption

!

hostname caknacaburfx02

!

no logging monitor

!

voice-card 0

!

ip subnet-zero

!

!

!

!

!

voice call carrier capacity active

!

!

!

!

!

!

!

!

!

ccm-manager redundant-host 10.72.84.30

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.72.84.30

ccm-manager config

!

!

!

interface FastEthernet0/0

ip address 10.72.84.35 255.255.255.0

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.72.84.1

no ip http server

!

!

logging 10.72.84.30

!

snmp-server community xxxxxxxx RO

snmp-server community xxxxxxxx RW

snmp-server enable traps tty

snmp-server host 10.72.84.30 public

call rsvp-sync

!

voice-port 0/0

!

voice-port 0/1

!

voice-port 0/2

!

voice-port 0/3

!

voice-port 0/4

!

voice-port 0/5

!

voice-port 0/6

!

voice-port 0/7

!

mgcp

mgcp call-agent 10.72.84.31 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 1 pots

application mgcpapp

port 0/0

!

dial-peer voice 2 pots

application mgcpapp

port 0/1

!

dial-peer voice 3 pots

application mgcpapp

port 0/2

!

dial-peer voice 4 pots

application mgcpapp

port 0/3

!

dial-peer voice 5 pots

application mgcpapp

port 0/4

!

dial-peer voice 6 pots

application mgcpapp

port 0/5

!

dial-peer voice 7 pots

application mgcpapp

port 0/6

!

dial-peer voice 8 pots

application mgcpapp

port 0/7

!

!

line con 0

exec-timeout 0 0

password xxxxxxxx

login

line aux 0

line vty 0 4

password xxxxxxxx

login

line vty 5 15

password xxxxxxxx

login

  • Other Collaboration Voice and Video Subjects
3 REPLIES
New Member

Re: Can only get port 0/0 on MRP3-8FXS to register

Here's a debug trace from when I do a reset (in CCM) of one of the unregistered ports (port 0/1):

*Mar 1 01:26:49.619: cmapp_xml_cfg_chg_msg: RESTART

*Mar 1 01:26:49.619: cmapp_xml_send_msg_to_cmapp: ep_name = AALN/S0/SU0/1, msg

= 1

*Mar 1 01:26:49.619: cmapp_xml_find_ep_by_name: Checking for ep_name [AALN/S0/S

U0/1]

*Mar 1 01:26:49.619: cmapp_xml_process_xml_event: ev_id = 1

*Mar 1 01:26:49.619: cmapp_xml_exec_fsm: Endpoint is [AALN/S0/SU0/1]

*Mar 1 01:26:49.619: cmapp_xml_exec_fsm: endpoint = AALN/S0/SU0/1 state = CMAPP

_XML_IDLE, event = CMAPP_XML_EVT_RESTART_GW

*Mar 1 01:26:49.623: cmapp_xml_process_restart: state = CMAPP_XML_IDLE, event =

CMAPP_XML_EVT_RESTART_GW

*Mar 1 01:26:49.623: cmapp_xml_convert_ep_name_to_file_name: Converted ep_name

AALN/S0/SU0/1 to file_name AALN_S0_SU0_1

*Mar 1 01:26:49.643: cmapp_xml_tftp_download_file line 116: File (tftp://10.72.

84.30/AALN_S0_SU0_1@caknacaburfx02.cnf.xml) read 1515 bytes

*Mar 1 01:26:49.643: cmapp_xml_get_xml_file: Read file tftp://10.72.84.30/AALN_

S0_SU0_1@caknacaburfx02.cnf.xml, len = 1515

*Mar 1 01:26:49.643: cmapp_xml_exec_fsm: New state = CMAPP_XML_FILE_DNLD

*Mar 1 01:26:49.643: cmapp_xml_find_ep_by_name: Checking for ep_name [AALN/S0/S

U0/1]

*Mar 1 01:26:49.643: cmapp_xml_exec_fsm: Endpoint is [AALN/S0/SU0/1]

*Mar 1 01:26:49.643: cmapp_xml_exec_fsm: endpoint = AALN/S0/SU0/1 state = CMAPP

_XML_FILE_DNLD, event = CMAPP_XML_EVT_FILE_DOWNLOADED

*Mar 1 01:26:49.647: cmapp_xml_file_dnld_done: state = CMAPP_XML_FILE_DNLD, eve

nt = CMAPP_XML_EVT_FILE_DOWNLOADED

*Mar 1 01:26:49.647: cmapp_prefix_process_tag_device:

*Mar 1 01:26:49.647: cmapp_prefix_process_tag_device: attr=[axl:XAnalogGateway]

*Mar 1 01:26:49.647: cmapp_process_tag_name:

*Mar 1 01:26:49.647: cmapp_xml_get_info_from_name: name = AALN/S0/SU0/1@caknaca

burfx02

*Mar 1 01:26:49.651: cmapp_process_tag_product:

*Mar 1 01:26:49.651: cmapp_process_tag_product: prev_tag = [] contents=

[Cisco MGCP FXS Port]

*Mar 1 01:26:49.651: cmapp_process_tag_product: port is FXS

*Mar 1 01:26:49.651: cmapp_parse_xml: Unknown tag

*Mar 1 01:26:49.651: cmapp_process_unknown_tag: processing unknown tag with con

tents [MGCP Station]

*Mar 1 01:26:49.651: cmapp_parse_xml: Unknown tag

*Mar 1 01:26:49.651: cmapp_process_unknown_tag: processing unknown tag with con

tents [Gateway]

*Mar 1 01:26:49.651: cmapp_process_tag_side:

*Mar 1 01:26:49.655: cmapp_parse_xml: Unknown tag

*Mar 1 01:26:49.655: cmapp_prefix_process_tag_vendor_config:

*Mar 1 01:26:49.655: cmapp_process_tag_networkLocale:

*Mar 1 01:26:49.655: cmapp_process_tag_networkLocale: NetworkLocale = Canada

*Mar 1 01:26:49.655: cmapp_process_tag_max_ports:

*Mar 1 01:26:49.659: cmapp_prefix_process_tag_ports:

*Mar 1 01:26:49.659: cmapp_prefix_process_tag_port:

*Mar 1 01:26:49.659: cmapp_prefix_process_tag_port: attr=[1]

*Mar 1 01:26:49.659: cmapp_prefix_process_tag_port: ts = 0

*Mar 1 01:26:49.659: cmapp_parse_xml: Unknown tag

*Mar 1 01:26:49.659: cmapp_parse_xml: Unknown tag

*Mar 1 01:26:49.663: cmapp_parse_xml: Unknown tag

*Mar 1 01:26:49.663: cmapp_process_unknown_tag: processing unknown tag with con

tents [false]

*Mar 1 01:26:49.663: cmapp_parse_xml: Unknown tag

*Mar 1 01:26:49.663: cmapp_process_unknown_tag: processing unknown tag with con

tents [Originator]

*Mar 1 01:26:49.663: cmapp_process_tag_digit_type: len = 4

*Mar 1 01:26:49.663: cmapp_parse_xml: Unknown tag

*Mar 1 01:26:49.663: cmapp_process_unknown_tag: processing unknown tag with con

tents [0]

*Mar 1 01:26:49.667: cmapp_parse_xml: Unknown tag

*Mar 1 01:26:49.667: cmapp_process_unknown_tag: processing unknown tag with con

tents [0]

*Mar 1 01:26:49.667: cmapp_parse_xml: Unknown tag

*Mar 1 01:26:49.667: cmapp_parse_xml: Unknown tag

*Mar 1 01:26:49.667: cmapp_process_unknown_tag: processing unknown tag with con

tents [Allowed]

*Mar 1 01:26:49.667: cmapp_parse_xml: Unknown tag

*Mar 1 01:26:49.667: cmapp_process_unknown_tag: processing unknown tag with con

tents [Disable]

*Mar 1 01:26:49.671: cmapp_parse_xml: Unknown tag

*Mar 1 01:26:49.671: cmapp_process_unknown_tag: processing unknown tag with con

tents [0]

*Mar 1 01:26:49.671: cmapp_parse_xml: Unknown tag

*Mar 1 01:26:49.671: cmapp_process_unknown_tag: processing unknown tag with con

tents [Not Set]

*Mar 1 01:26:49.671: cmapp_parse_xml: Unknown tag

*Mar 1 01:26:49.671: cmapp_process_unknown_tag: processing unknown tag with con

tents [

5000

0

100

250

1000

0

]

*Mar 1 01:26:49.675: cmapp_prefix_process_tag_trunk:

*Mar 1 01:26:49.675: cmapp_process_tag_kind: len = 4

*Mar 1 01:26:49.675: cmapp_process_tag_kind: contents = [POTS], ts = 0

*Mar 1 01:26:49.675: cmapp_process_tag_kind: Set timeslot 0 to 0 with contents

[POTS]

*Mar 1 01:26:49.675: cmapp_parse_xml: Unknown tag

*Mar 1 01:26:49.675: cmapp_process_unknown_tag: processing unknown tag with con

tents [Bothways]

*Mar 1 01:26:49.675: cmapp_parse_xml: Unknown tag

*Mar 1 01:26:49.675: cmapp_process_unknown_tag: processing unknown tag with con

tents [ONS]

*Mar 1 01:26:49.679: cmapp_parse_xml: Unknown tag

*Mar 1 01:26:49.679: cmapp_process_unknown_tag: processing unknown tag with con

tents [NoDbPadding]

*Mar 1 01:26:49.679: cmapp_parse_xml: Unknown tag

*Mar 1 01:26:49.679: cmapp_process_unknown_tag: processing unknown tag with con

tents [NoDbPadding]

*Mar 1 01:26:49.679: cmapp_prefix_process_tag_vendor_config:

*Mar 1 01:26:49.679: cmapp_parse_xml: Unknown tag

*Mar 1 01:26:49.679: cmapp_process_unknown_tag: processing unknown tag with con

tents [http://10.72.84.30/help]

*Mar 1 01:26:49.683: cmapp_xml_exec_fsm: New state = CMAPP_XML_FILE_PARSING

*Mar 1 01:26:49.683: cmapp_xml_find_ep_by_name: Checking for ep_name [AALN/S0/S

U0/1]

*Mar 1 01:26:49.683: cmapp_xml_exec_fsm: Endpoint is [AALN/S0/SU0/1]

*Mar 1 01:26:49.683: cmapp_xml_exec_fsm: endpoint = AALN/S0/SU0/1 state = CMAPP

_XML_FILE_PARSING, event = CMAPP_XML_EVT_XML_PARSING_DONE

*Mar 1 01:26:49.683: cmapp_xml_parsing_done: state = CMAPP_XML_FILE_PARSING, ev

ent = CMAPP_XML_EVT_XML_PARSING_DONE

*Mar 1 01:26:49.683: cmapp_xml_cleanup_file_buf: Cleaning up File buffer

*Mar 1 01:26:49.687: cmapp_xml_mgcpapp_is_down: MGCP is up: m2bpid=114, oper_st

ate = 2

*Mar 1 01:26:49.691: cmapp_xml_parsing_done:Signal MGCPAPP to clear TRANSIENT c

alls

*Mar 1 01:26:49.691: cmapp_xml_exec_fsm: New state = CMAPP_XML_WAIT_CLR

*Mar 1 01:26:49.691: cmapp_xml_find_ep_by_name: Checking for ep_name [AALN/S0/S

U0/1]

*Mar 1 01:26:49.691: cmapp_xml_exec_fsm: Endpoint is [AALN/S0/SU0/1]

*Mar 1 01:26:49.691: cmapp_xml_exec_fsm: endpoint = AALN/S0/SU0/1 state = CMAPP

_XML_WAIT_CLR, event = CMAPP_XML_EVT_CALLS_CLEARED

*Mar 1 01:26:49.695: cmapp_xml_mgcp_calls_cleared: state = CMAPP_XML_WAIT_CLR,

event = CMAPP_XML_EVT_CALLS_CLEARED

*Mar 1 01:26:49.695: cmapp_xml_mgcp_calls_cleared: Signal to MGCPAPP to unregis

ter

*Mar 1 01:26:49.695: cmapp_xml_configure_router

*Mar 1 01:26:49.695: cmapp_xml_start_mgcp:

*Mar 1 01:26:49.695: cmapp_xml_configure_router: Skip all interface configurati

ons

*Mar 1 01:26:49.695: cmapp_xml_start_mgcp:

*Mar 1 01:26:49.695: cmapp_xml_exec_fsm: New state = CMAPP_XML_CONFIGURING

*Mar 1 01:26:49.695: cmapp_xml_find_ep_by_name: Checking for ep_name [AALN/S0/S

U0/1]

*Mar 1 01:26:49.695: cmapp_xml_exec_fsm: Endpoint is [AALN/S0/SU0/1]

*Mar 1 01:26:49.695: cmapp_xml_exec_fsm: endpoint = AALN/S0/SU0/1 state = CMAPP

_XML_CONFIGURING, event = CMAPP_XML_EVT_RTR_CFG_DONE

*Mar 1 01:26:49.695: cmapp_xml_router_cfg_done: state = CMAPP_XML_CONFIGURING,

event = CMAPP_XML_EVT_RTR_CFG_DONE

*Mar 1 01:26:49.695: cmapp_xml_router_cfg_done: Signal to MGCPAPP to register

*Mar 1 01:26:49.699: cmapp_xml_router_cfg_done: Setting delete_flag

*Mar 1 01:26:49.699: cmapp_xml_exec_fsm: New state = CMAPP_XML_IDLE

*Mar 1 01:26:52.699: cmapp_xml_send_msg_to_callmgr: Sending CMBH_MSG_CFG_OK

*Mar 1 01:26:52.699: cmapp_xml_send_msg_to_callmgr:cmbh_pdu_send was successful

*Mar 1 01:26:52.699: cmapp_xml_delete_ep: Deleting endpoint AALN/S0/SU0/1

*Mar 1 01:26:52.699: cmapp_xml_cleanup_file_buf: Cleaning up File buffer

*Mar 1 01:26:52.699: cmapp_xml_delete_ep: num_ep is now 0

caknacaburfx02#

caknacaburfx02#

caknacaburfx02#

caknacaburfx02#

caknacaburfx02#sh debug

Call Manager:

Call Manager packet debugging is on

Call Manager config events debugging is on

Call Manager config errors debugging is on

Call Manager config packets debugging is on

Call Manager config XML debugging is on

caknacaburfx02#

Cisco Employee

Re: Can only get port 0/0 on MRP3-8FXS to register

Can you post "debug mgcp packet" while configuring "no mgcp/mgcp" on the MRP? You're looking to see if the CCM sends an AUEP for each of the analog end points. If it doesn't, there may be something wrong with your CCM config.

New Member

Re: Can only get port 0/0 on MRP3-8FXS to register

As it turns out, it depends wether the ports are configured Loop Start or Ground Start. If the are loop start, the ports won't regidter until a device is attached and goes off hook. Ground start ports will register right away.

207
Views
0
Helpful
3
Replies