Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

can't break dial tone 2600 fxs/fxo one direction only

pbx - fxs - 12.2(2)XT - f/r wan - 12.0(7)XK1 - fxo - pbx can't break 2nd dial tone

pbx - fxo - 12.2(2)XT - f/r wan - 12.0(7)XK1 - fxs - pbx works

User gets first dial tone, enters single digit, call gets routed and gets a second dial tone. It's the second dial tone that can't be broken.

Problem may have started after upgrading 1 router from 12.0(7)XK1 to 12.2(2), but not sure. We tested both ports by forcing calls using the preferrence and both calls fail. The customer can plug a phone into the pbx and break dial tone. Any suggestions or bugs?

Corpus_HQ#sh run

Building configuration...

Current configuration : 3921 bytes

!

version 12.2

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

!

hostname Corpus_HQ

!

boot system flash aaa1316.bin

logging buffered 4096 debugging

!

ip subnet-zero

!

!

ip name-server!

isdn switch-type basic-ni

isdn voice-call-failure 0

!

!

!

!

!

!

fax interface-type fax-mail

mta receive maximum-recipients 0

!

!

!

!

interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.0

ip directed-broadcast

duplex auto

speed auto

!

interface BRI0/0

description connected to CorpusPlant

no ip address

encapsulation ppp

dialer rotary-group 4

dialer-group 1

isdn switch-type basic-ni

isdn spid1

isdn spid2

no cdp enable

!

interface Serial0/0

no ip address

encapsulation frame-relay IETF

no ip mroute-cache

service-module t1 timeslots 1-24

service-module t1 remote-alarm-enable

cdp enable

frame-relay traffic-shaping

frame-relay lmi-type ansi

!

interface Serial0/0.2 point-to-point

description connected to Houston

ip address 192.168.250.9 255.255.255.252

no ip mroute-cache

frame-relay class houston

frame-relay interface-dlci 19 CISCO

!

interface Serial0/0.3 point-to-point

description connected to SanMarcos

ip address 192.168.250.5 255.255.255.252

no ip mroute-cache

frame-relay class dfw2

frame-relay interface-dlci 18

!

interface Dialer4

description connected to CorpusPlant

ip address 192.168.250.2 255.255.255.252

encapsulation ppp

no ip split-horizon

dialer in-band

dialer map ip 192.168.250.1 name CorpusPlant broadcast 6920959

dialer hold-queue 10

dialer load-threshold 10 outbound

dialer-group 1

no cdp enable

ppp authentication chap

!

router eigrp 1

passive-interface Dialer4

network 192.168.1.0

network 192.168.2.0

network 192.168.3.0

network 192.168.4.0

network 192.168.250.0

no auto-summary

no eigrp log-neighbor-changes

!

router rip

version 2

redistribute eigrp 1

passive-interface FastEthernet0/0

passive-interface Serial0/0.2

passive-interface Serial0/0.3

network 192.168.1.0

network 192.168.2.0

network 192.168.3.0

network 192.168.4.0

network 192.168.250.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.100

no ip http server

!

!

map-class frame-relay houston

no frame-relay adaptive-shaping

frame-relay fair-queue

frame-relay voice bandwidth 32000

frame-relay fragment 80

!

map-class frame-relay dfw2

no frame-relay adaptive-shaping

frame-relay cir 256000

frame-relay bc 2560

frame-relay be 0

frame-relay fair-queue

frame-relay fragment 320

frame-relay ip rtp priority 16384 16383 45

!

map-class frame-relay dfw1

no frame-relay adaptive-shaping

frame-relay cir 256000

frame-relay fair-queue

frame-relay voice bandwidth 120000

frame-relay fragment 320

dialer-list 1 protocol ip permit

!

call rsvp-sync

!

voice-port 1/0/0

echo-cancel coverage 16

description 1st fxo port

!

voice-port 1/0/1

echo-cancel coverage 16

description 2nd fxo port

!

voice-port 1/1/0

echo-cancel coverage 16

description 1st fxs port

!

voice-port 1/1/1

echo-cancel coverage 16

description 2nd fxs port

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 1 pots

preference 1

destination-pattern 6

port 1/0/0

!

dial-peer voice 2 pots

preference 2

destination-pattern 6

port 1/0/1

!

dial-peer voice 22 voip

destination-pattern 7

session target ipv4:192.168.250.6

dtmf-relay cisco-rtp

!

dial-peer voice 23 voip

destination-pattern 7

session target ipv4:192.168.250.6

dtmf-relay cisco-rtp

!

dial-peer voice 32 voip

destination-pattern 18

session target ipv4:192.168.250.10

dtmf-relay cisco-rtp

ip qos dscp cs5 media

!

!

line con 0

login

line aux 0

line vty 0 4

login

line vty 5 15

login

!

no scheduler allocate

!

end

2 REPLIES
New Member

Re: can't break dial tone 2600 fxs/fxo one direction only

It seems that there is a bug in the IOS version 12.2(2)XT which is causing the problem. A similar bug was found in the previous versions. You can have a look at the bug

CSCdj57424 . More over 12.2(2)XT is a Early Deployment version, which is not always reliable. You can use the stable version which is a General Deployment in 12.2 family of IOS versions.

New Member

Re: can't break dial tone 2600 fxs/fxo one direction only

Solution used - added memory to router with the 12.0(7)XK1 and upgraded the IOS to 12.2(2). Calls can now be placed in both directions. It appears that the two IOS's have a conflict or bug.

267
Views
0
Helpful
2
Replies
CreatePlease login to create content