Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Cannot break dial tone from analog phone on FXS port

I have an analog phone that can recieve calls just fine from IP phones, external, Unity, etc., but cannot make outgoing calls. Debug of the gateway (2600 with an FXS) shows the phone going off-hook but not passing any DTMF digits. This is a very vanilla configuration using MGCP. It's one of those "it worked fine yesterday" situations, but God knows what I've mis-typed now. CCM version 3.2.2c. Here's the config:

Thanks in advance!

Current configuration : 1209 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 2600

!

logging buffered 4096 debugging

enable password cisco

!

ip subnet-zero

!

!

ip domain-name a.b.com

ip name-server 172.16.1.1

!

mgcp

mgcp call-agent 172.16.2.1

mgcp dtmf-relay codec all mode out-of-band

call rsvp-sync

!

!

!

!

!

ccm-manager mgcp

!

!

!

interface Ethernet0/0

ip address 172.16.3.254 255.255.255.0

ip helper-address 172.16.2.1

full-duplex

!

interface Serial0/0

ip address 172.16.254.6 255.255.255.252

service-module t1 timeslots 1-24

!

interface Ethernet0/1

no ip address

shutdown

half-duplex

!

router ospf 100

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

!

ip classless

no ip http server

!

snmp-server community cisco RW

snmp-server enable traps tty

snmp-server host 172.16.2.1 cisco

!

voice-port 1/0/0

input gain 14

!

voice-port 1/0/1

input gain 14

!

dial-peer cor custom

!

!

!

dial-peer voice 1 pots

application mgcpapp

port 1/0/0

!

dial-peer voice 2 pots

application mgcpapp

port 1/0/1

!

!

line con 0

line aux 0

line vty 0 4

exec-timeout 0 0

password cisco

login

!

end

5 REPLIES
Blue

Re: Cannot break dial tone from analog phone on FXS port

Are you sure the phone is OK, a bad keypad could cause this. Have you tried reloading the router? Could be one of those mysterious one-time glitches. Do you have plenty of memory in the router?

Regards, Dave

Community Member

Re: Cannot break dial tone from analog phone on FXS port

I have 2 phones, one on each FXS port. Both are exhibiting the same behavior. I have bumped the code to 12.2 on the router, reloaded both the router & CCM, no errors in event log at all, no crazy logging messages from the router. In debug, I can see the phone go off-hook but it is not recieving any digits (I can hear the tones just fine on the phone). I also just reseated FXS & NM-2V with the same results.

Blue

Re: Cannot break dial tone from analog phone on FXS port

Do you get dial tone and can't break it, or are you not getting dial tone at all?

Are you sure this worked at one time?

Have you tried H323?

The reason for my interest, and the questions, is that I had a similar problem with MGCP on 26XXs except that I could not get dial tone at all (though if you listened carefully sometimes you hear a very short burst of dial tone). In bound calling was fine. A H323 config works fine. Plugging the same NM-2V in a 3640 with MGCP worked fine. I tried it in a 2620 and in a 2620XM with the same results.

I had a TAC ticket open on it for a month or so, and made little progress. I had a deadline to come up with a working solution including SRST with TCL IVR script so I just went with H323, but would still like to go to MGCP eventually.

Regards, Dave

Community Member

Re: Cannot break dial tone from analog phone on FXS port

So I guess this may be a bug with 2600 series and FXS ports? Anyone else have any insight on this? It seems that it may have stopped working after upgrading to 3.2.2c, that's my only guess.

Community Member

Re: Cannot break dial tone from analog phone on FXS port

The solution - I turned down the input gain, which I had previously cranked up, and now the FXS ports can understand the digits being passed. I guess the max setting is a little too much volume for the FXS ports to handle when they're listening for DTMF tones.

506
Views
0
Helpful
5
Replies
CreatePlease to create content