Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cannot make outbound call through ISDN30

Hello all,

I've a problem in outbound call with analog devices.

We use 2821 as SRST on branch office and connect to PSTN with ISDN30.

All of my VOIP & analog devices can reach from outside with their DID number.

But I can't make a outgoing call with the fax machine and analog phones.

All the VOIP phones can call outside with PSTN line.

Please see the attach for logical diagram.

What should I need to add in configuration to send out the fax using PSTN line.

Thank you for your help.

here's the srst router's config.

no ip domain lookup

!

isdn switch-type primary-5ess

!

voice-card 0

dspfarm

dsp services dspfarm

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

!

!

voice translation-rule 6562

rule 1 /6562/ //

!

!

voice translation-profile in

translate called 6562

!

!

crypto pki certificate chain TP-self-signed-3393231679

certificate self-signed 01 nvram:IOS-Self-Sig#3903.cer

!

!

controller E1 0/2/0

pri-group timeslots 1-31

!

controller E1 0/2/1

!

!

interface GigabitEthernet0/0

description Local

ip address 10.54.120.2 255.255.255.0

duplex full

speed 100

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.54.120.2

!

interface GigabitEthernet0/1

description to RemoteOffice

ip address 192.168.54.2 255.255.255.248

duplex full

speed 10

!

interface Serial0/2/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-5ess

isdn incoming-voice voice

no cdp enable

!

router eigrp 1

network 10.54.120.0 0.0.0.255

network 192.168.54.0 0.0.0.3

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 10.54.120.1

!

control-plane

!

voice-port 0/0/0

timeouts ringing infinity

description Fax 2401

station-id number 2401

caller-id enable

!

voice-port 0/0/1

timeouts ringing infinity

description Fax 2428

station-id number 2428

caller-id enable

!

voice-port 0/0/2

!

voice-port 0/0/3

!

voice-port 0/2/0:15

translation-profile incoming in

cptone SG

bearer-cap Speech

!

sccp local GigabitEthernet0/0

sccp ccm 10.40.120.12 identifier 1

sccp ccm 10.40.120.11 identifier 2

sccp ip precedence 3

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate ccm 2 priority 2

associate profile 1 register CFB002497FE1EA0

!

dspfarm profile 1 conference

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

associate application SCCP

shutdown

!

!

dial-peer voice 1 pots

incoming called-number .

direct-inward-dial

!

dial-peer voice 1001 pots

preference 2

destination-pattern 9[3-9].......$

port 0/2/0:15

forward-digits 8

!

dial-peer voice 1002 pots

preference 2

destination-pattern 9800.......$

port 0/2/0:15

forward-digits 10

!

dial-peer voice 1003 pots

preference 2

destination-pattern 91800.......$

port 0/2/0:15

forward-digits 11

!

dial-peer voice 1004 pots

preference 2

destination-pattern 91900.......$

port 0/2/0:15

forward-digits 11

!

dial-peer voice 1005 pots

preference 2

destination-pattern 999[3,5,9]

port 0/2/0:15

forward-digits 3

!

dial-peer voice 1006 pots

preference 2

destination-pattern 90T

port 0/2/0:15

prefix 0

!

dial-peer voice 1007 voip

preference 3

destination-pattern ....

voice-class codec 1

session target ipv4:10.40.120.12

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 1008 voip

preference 4

destination-pattern ....

voice-class codec 1

session target ipv4:10.40.120.11

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 1009 pots

preference 2

destination-pattern 2401

port 0/0/0

!

dial-peer voice 1010 pots

preference 2

destination-pattern 2428

port 0/0/1

!

call-manager-fallback

secondary-dialtone 9

max-conferences 16 gain -6

transfer-system full-consult

timeouts interdigit 5

ip source-address 10.54.120.2 port 2000

max-ephones 50

max-dn 80

keepalive 60

moh music-on-hold.au

multicast moh 239.1.1.2 port 16384

time-zone 43

1 REPLY

Re: Cannot make outbound call through ISDN30

First, I recommend turning on the ISDN Q931 debug during an outbound call. That debug setting provide a load of useful information when dealing with ISDN issues.

I don't personally use the 'forward-digits' command, but I'm not sure why it wouldn't work. I use the prefix command to put back what the PSTN is expecting. For example, If I have a POTS dial-peer with a destination pattern of 91800........., I would include a command of 'prefix 1800' to put back the digits that were stripped when matching the pattern.

So, get the debug and post it back here, or try using prefix instead of forward digits, and let us know how it works.

176
Views
0
Helpful
1
Replies
CreatePlease login to create content