Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cat4500 port config for phones

I'm starting a VoIP deployment and have a question on basic port configuration. Should I configure the port as a trunk port? The phones will have PCs attached. This is what I've done so far.

interface FastEthernet5/48

switchport trunk encapsulation dot1q

switchport trunk native vlan 30

switchport mode trunk

switchport voice vlan 31

qos trust device cisco-phone

qos trust cos

service-policy output autoqos-voip-policy

no snmp trap link-status

auto qos voip cisco-phone

tx-queue 3

priority high

shape percent 33

spanning-tree portfast

Does anyone see a problem? Should I do this another way?

Thanks,

Patrick

2 REPLIES
New Member

Re: Cat4500 port config for phones

The answer is...IT DEPENDS on what model switch are you placing the phones? The configuration you have put forward appears to be for an older model (say, a Cat 3524XL). The newer Cat 3550-24PWR switch recommends dispensing with 802.1Q trunking mode altogether and configuring an access (native) vlan and a voice vlan. Thus, PHONE ports would be configured as follows

interface FastEthernet5/48

mls qos trust cos

switchport access vlan 11

switchport voice vlan 111

switchport priority extend cos 0

priority-queue out

wrr-queue cos-map 4 5

spanning-tree portfast

spanning-tree bpduguard enable

no snmp trap link-status

(on the global config level, you would enable qos and map cos to dscp values 0 8 16 26 34 46 48 56)

On a Cat 4000/4500 series switch, the commands are slightly different:

interface FastEthernet5/48

qos trust cos

switchport access vlan 11

switchport voice vlan 111

qos trust extend cos 0

tx-queue 3

priority high

no snmp trap link-status

spanning-tree portfast

spanning-tree bpduguard enable

(again, globally enable qos and map cos to the same DSCP values as above)

As I understand it, CDPv2 is used at the link layer level to negotiate power, duplex, VTP domain and tagged VLAN information with a directly connected IP phone (the last item, however, is negotiated ONLY for switchports that are CAPABLE OF SUPPORTING 802.1Q, even though they are not explicitly configured for trunking!) 802.1Q tagged frames are then processed by the IP phone itself, whereas untagged (native/access VLAN) frames are passed to the local PC switch port on the phone. (In my experience, however, I have found that ATA18X analog gateways do not successfully negotiate the tagged voice VLAN -- in which case, you must configure the voice VLAN as the access VLAN.)

Also, as of CallManager 3.0(5), the CallManager server itself sets Cos and DSCP values for all registered IP phones and SCCP gateways, and they are user-configurable under the CallManager Service Parameters. If H323 and MGCP gateways are set up properly, they too will classify voice signaling and bearer traffic correctly. Therefore, there is no longer any need to place service output policies on ports directly connected to these devices.

New Member

Re: Cat4500 port config for phones

Thank you rmwall,

I got the other port config from a 3524XL. I changed my phone port config to look like this.

interface FastEthernet6/24

switchport access vlan 30

switchport voice vlan 31

qos trust device cisco-phone

qos trust cos

service-policy output autoqos-voip-policy

no snmp trap link-status

auto qos voip cisco-phone

tx-queue 3

priority high

shape percent 33

spanning-tree portfast

spanning-tree bpduguard enable

--Patrick

229
Views
0
Helpful
2
Replies