Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CCM 4.3 axl requests are ignored.

I am writing an app for a recently installed ccm 4.3 customer. Unfortunantly, my axl messages are being completely ignored. I get no response back when I send an AXL message. For giggles, I tried sending the same axl message to a 4.2(3) box and it works fine. I have seen nothing in documentation that says that 4.3 is any different that 4.2(3) axl wise. Any thoughts out there?

Here is an example of my sent message.

POST /CCMApi/AXL/V1/soapisapi.dll

Host: 10.1.3.40:80

Accept: text/*

Authorization: Basic *******************************=

Content-type: text/xml

Content-length: 335

<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">

<SOAP-ENV:Body><addRoutePartition><newRoutePartition><name>App1</name></newRoutePartition></addRoutePartition></SOAP-ENV:Body>

</SOAP-ENV:Envelope>

the only reply I get is this...

Received Packet len 35 (0 remaining)

<h1>Bad Request (Invalid Verb)</h1><h1>Bad Request (Invalid Verb)</h1>)</h1>

this is making me nuts....

1 REPLY

Re: CCM 4.3 axl requests are ignored.

try to replace with;

http://www.cisco.com/AXL/1.0" sequence="1234" xsi:schemaLocation="http://www.cisco.com/AXL/1.0 http://ccmserver/schema/axlsoap.xsd">

sometime "older" ccm's accept incorrect formatted SOAP messages..

123
Views
0
Helpful
1
Replies
CreatePlease login to create content