Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

[CCM 5.0/perfmon] Failed to add a counter

Hi,

I'm trying to add a counter to my "perfmon" session and I'm receiving a "IllegalArgumentException" error.

What's wrong ?

The same sample works fine with CCM 4.2..

Thanks

Seb

------ Request ------

POST /perfmonservice/services/PerfmonPort HTTP/1.0

Content-Type: text/xml; charset=utf-8

Accept: application/soap+xml, application/dime, multipart/related, text/*

User-Agent: Axis/1.4

Host: 127.0.0.1:8080

Cache-Control: no-cache

Pragma: no-cache

SOAPAction: "http://schemas.cisco.com/ast/soap/action/#PerfmonPort#PerfmonAddCounter"

Content-Length: 1023

Authorization: Basic Q0NNQWRtaW5pc3RyYXRvcjpjaXNjb2Npc2Nv

<?xml version="1.0" encoding="UTF-8"?><soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http:

//www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"><soapenv:Body><ns1:PerfmonAddCounter soapenv:en

codingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:ns1="http://schemas.cisco.com/ast/soap/"><SessionHandle xsi:type="ns

1:SessionHandleType">9099d012-ffff-ffff-8000-000000000000</SessionHandle><ArrayOfCounter soapenc:arrayType="ns1:CounterType[1]" xs

i:type="soapenc:Array" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"><ArrayOfCounter href="#id0"/></ArrayOfCounter></n

s1:PerfmonAddCounter><multiRef id="id0" soapenc:root="0" soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xsi:typ

e="ns2:CounterType" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/" xmlns:ns2="http://schemas.cisco.com/ast/soap/"><Name

xsi:type="xsd:string">\\gondor\Cisco CallManager\CallsActive</Name></multiRef></soapenv:Body></soapenv:Envelope>

------ Response ------

HTTP/1.1 500 Internal Server Error

Set-Cookie: SoapSession.id=-3497063133291605775

Content-Type: text/xml;charset=utf-8

Date: Wed, 07 Jun 2006 13:22:24 GMT

Server: Apache-Coyote/1.1

Connection: close

<?xml version="1.0" encoding="utf-8"?><soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http:

//www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"><soapenv:Body><soapenv:Fault><faultcode>soapenv

:Server.userException</faultcode><faultstring>java.lang.IllegalArgumentException: java.lang.ClassCastException@1024878</faultstrin

g><detail><ns1:hostname xmlns:ns1="http://xml.apache.org/axis/">Gondor.domain.com</ns1:hostname></detail></soapenv:Fault></soap

env:Body></soapenv:Envelope>

1 REPLY
New Member

Re: [CCM 5.0/perfmon] Failed to add a counter

Try bug - CSCsb01541

146
Views
0
Helpful
1
Replies
CreatePlease to create content