Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CCM3.3 and Extension Mobility / DCD Problem

Get Error:[101] when I try to invoke Extension Mobility Service. I've set up the service, subscribed to it, got the case sensitive bits right, read the Cisco Press troubleshooting for EM on 3.3., Checked the Tomcat Service etc.

In the Cisco Press Troubleshooting IP Telephony (page 778) it looks like I should have an EMApp user in DC Directory - I don't have this. I can add this through CCM but then I am unable to give Authenication Proxy Rights via DCD Admin - can not change anything through "CCM Administrator" login, just display despite what the docs say.

Any thoughts?

Rory

8 REPLIES
Cisco Employee

Re: CCM3.3 and Extension Mobility / DCD Problem

You mayt be running into this:

CSCdz60740 - Ext-Mobility login fails: Login Unsuccessful, error [101]

Symptom:

Ext-Mobility phone, when service is selected, display shows, "Login Unsuccessfull, Error: [101]".

Service never asks for UserID or PIN. After a period of time, or number of times trying, the

inetinfo.exe (IIS Service) starts pegging the CPU on all nodes in the cluster.

Conditions:

This worked in a previous release, we have since rebuilt the systems and restored data. Could be a

database or DCD problem from the upgrade and/or rebuild.

Workaround:

This seems to be caused by an error in the setup of the EM service virtual

directory. This virtual directory can be recreated with the following steps:

1) Start->Programs->Administrative Tools->Internet Information Services

2) Expand pc->DefaultWebsite in left pane

3) Right click Login Service, select Delete

4) Right click Default Web Site, select New->Virtual Directory

5) Follow the wizard:

a) Alias: LoginService

b) Directory: Browse to C:\CiscoWebs\LoginService

c) Select Read, Run, and Execute

6) Configure Virtual Directory --

a) Right Click Login Service, select Properties

b) In Virtual Directory Tab---

1) make sure Read and Log Visits are checked, none others

2) Make sure Execute Permissions are 'Scripts and Executables'

3) Make sure Application Protection is 'Low (IIS Process)'

c) In Documents tab, make sure only enabled default doc is 'Default.asp'

d) In Directory Security tab, click Edit button under Anonymous Access and Authentication Control

1) Make sure Anonymous access is checked, no other options are

2) Click Edit button under Anonymous Access

3) Set Username to CCMEML

4) Set password to CCMEML password

5) Click OK

6) Click OK

e) Click OK

New Member

Re: CCM3.3 and Extension Mobility / DCD Problem

Thanks Kevin, but when I do all this I get the same on the 7960. But the return code in the EMApp trace shows 401 (permission error I think). I've reloaded the server after making the change.

Here's the FIRST PART:

0: Apr 01 11:59:00.409 BST %EMApp-EMAPPSERVLET-7-UNK:UserID=CCMSysUser:Password=ciscocisco

1: Apr 01 11:59:00.456 BST %EMApp-EMAPPSERVLET-7-UNK:BEFORE CALLING INITIALIZE

2: Apr 01 11:59:00.456 BST %EMApp-6-UNK:Service URL from directory =http://EPCMA/LoginService/login.asp

3: Apr 01 11:59:00.456 BST %EMApp-6-UNK:Service URL=http://EPCMA/LoginService/login.asp Query URL=http://EPCMA/LoginService/query.asp

4: Apr 01 11:59:00.456 BST %EMApp-EMAPPSERVLET-7-UNK:AFTER CALLING INITIALIZE

5: Apr 01 11:59:00.487 BST %EMApp-EMAPPSERVLET-7-UNK:Posting to EM Service:

CCMSysUser

xxxxxxx

SEP000BBEE38FCB

6: Apr 01 11:59:00.487 BST %EMApp-EMAPPSERVLET-7-UNK:URL of EM Query Service:http://EPCMA/LoginService/query.asp

7: Apr 01 11:59:00.643 BST %EMApp-EMAPPSERVLET-7-UNK:java.io.IOException: Server returned HTTP response code: 401 for URL: http://EPCMA/LoginService/query.asp

at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)

at com.cisco.emapp.EMServiceCommunicator.postMsg(EMServiceCommunicator.java:117)

and THE ORIGINAL:

0: Mar 31 16:51:39.274 BST %EMApp-EMAPPSERVLET-7-UNK:UserID=CCMSysUser:Password=ciscocisco

1: Mar 31 16:51:39.852 BST %EMApp-EMAPPSERVLET-7-UNK:BEFORE CALLING INITIALIZE

2: Mar 31 16:51:39.868 BST %EMApp-6-UNK:Service URL from directory =http://EPCMA/LoginService/login.asp

3: Mar 31 16:51:39.868 BST %EMApp-6-UNK:Service URL=http://EPCMA/LoginService/login.asp Query URL=http://EPCMA/LoginService/query.asp

4: Mar 31 16:51:39.868 BST %EMApp-EMAPPSERVLET-7-UNK:AFTER CALLING INITIALIZE

5: Mar 31 16:51:39.899 BST %EMApp-EMAPPSERVLET-7-UNK:Posting to EM Service:

CCMSysUser

xxxxxxx

SEP000BBED80447

6: Mar 31 16:51:39.899 BST %EMApp-EMAPPSERVLET-7-UNK:URL of EM Query Service:http://EPCMA/LoginService/query.asp

7: Mar 31 16:51:40.383 BST %EMApp-EMAPPSERVLET-7-UNK:java.io.IOException: Server returned HTTP response code: 500 for URL: http://EPCMA/LoginService/query.asp

at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)

at com.cisco.emapp.EMServiceCommunicator.postMsg(EMServiceCommunicator.java:117)

New Member

Re: CCM3.3 and Extension Mobility / DCD Problem

Hi,

Where you able to solve this problem ???

I have ccm 3.3 with spB and im getting the same issue. The trace looks equal to yours.

Thanks.

Sergio

New Member

Re: CCM3.3 and Extension Mobility / DCD Problem

No luck yet. I've had a TAC case open for a week or more but no resolution yet. I've even reinstalled the system from scratch and the same problem is present after restoring the database.

Rory

New Member

Re: CCM3.3 and Extension Mobility / DCD Problem

Hi,

Solved this problem changing the pass of CCMEML Users to CCMEML.

Hopes this helps.

Sergio

New Member

Re: CCM3.3 and Extension Mobility / DCD Problem

Hi Sergio,

Think I done all this already - I take it you mean the CCMEML user in the Anonymous Login part of IIS for the LoginService?

Rory

New Member

Re: CCM3.3 and Extension Mobility / DCD Problem

do you know what the original CCMEML password is ?

The CCMEML account is for Extension Mobility Logout account ?

My situation is similar - except I get "Login Unsuccessfull, Error: [6]"

this occurred after changing the Windows Admin password (and DC changes)

Did this on our lab (7835 - running CCM 3.3 SPB) and on a ICS7750 also running CCM3.3spB and both do the same thing. Prior to password change, worked fine (after a little tinkering).

Did rename LoginService (IIS) and created new one, as stated. this did not make any difference - also tried to use different login and passwords - no help.

before I change the CCMEML password, would like to know what the original password is (as tried logging in with this account and any pw I tried did not work) also tried using the "adminutility.exe" to set the CCM passwords back to original - went through the motions, but not sure if did anything?

any input would be extremely appreciated

please also email me as well as updating this please

darren.staples@telus.com

thx in advance

New Member

Re: CCM3.3 and Extension Mobility / DCD Problem

Error 6 indicates that no device profile is associated with the user attempting to log in.

The CCMEML password is the same - CCMEML.

131
Views
0
Helpful
8
Replies