Cisco Support Community
Community Member

CCME & Auto Attendant

I am trying to test the functionality of the auto attendant with CCME on a 3640. When I call into the FXO port I get prompted correctly by the AA but when I enter the destination number , which I can see being collected via debug, nothing happens. Makes no difference if I wait for a time out or use the # just dead air.

Any ideas.



Cisco Internetwork Operating System Software

IOS (tm) 3600 Software (C3640-IK9O3S-M), Version 12.2(15)ZJ3, EARLY DEPLOYMENT R


TAC Support:

Copyright (c) 1986-2003 by cisco Systems, Inc.

Compiled Thu 25-Sep-03 22:53 by eaarmas

Image text-base: 0x60008950, data-base: 0x61E9C000

ROM: System Bootstrap, Version 11.1(19)AA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc


ROM: 3600 Software (C3640-IK9O3S-M), Version 12.2(15)ZJ3, EARLY DEPLOYMENT RELEA


ok-okc-ccmetest uptime is 1 day, 5 hours, 4 minutes

System returned to ROM by power-on

System restarted at 07:42:43 CST Wed Jan 14 2004

System image file is "flash:c3640-ik9o3s-mz.122-15.ZJ3"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

If you require further assistance please contact us by sending email to

cisco 3640 (R4700) processor (revision 0x00) with 126976K/4096K bytes of memory.

Processor board ID 10579049

R4700 CPU at 100Mhz, Implementation 33, Rev 1.0

Bridging software.

X.25 software, Version 3.0.0.

SuperLAT software (copyright 1990 by Meridian Technology Corp).

4 Ethernet/IEEE 802.3 interface(s)

2 Voice FXO interface(s)

2 Voice FXS interface(s)

DRAM configuration is 64 bits wide with parity disabled.

125K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x3922


tftp-server flash:P00303020214.bin


call application voice autoatt flash:its-CISCO.

call application voice autoatt aa-pilot 5555

call application voice autoatt oper 5001

call application voice autoatt en 0

call application voice autoatt language 1 en

call application voice autoatt set-location en 0 flash:

call rsvp-sync


voice-port 0/0/0


voice-port 0/0/1


voice-port 0/1/0


voice-port 0/1/1



mgcp profile default




dial-peer cor custom




dial-peer voice 5000 pots

destination-pattern 5000

port 0/0/0


dial-peer voice 5555 pots

application autoatt

incoming called-number 5555

port 0/1/0





load 7960-7940 P00303020214

max-ephones 24

max-dn 48

ip source-address port 2000

create cnf-files version-stamp 7960 Jan 12 2004 16:01:33

max-conferences 4




ephone-dn 1 dual-line

number 5001

label Line1

name Test Phone



ephone 1

mac-address 0010.A4B4.71BA

type 7960

button 1:1


System flash directory:

File Length Name/status

1 20736768 c3640-ik9o3s-mz.122-15.ZJ3

2 496521

3 369950 P00303020214.bin

4 1602 CiscoLogo.gif

5 953 Delete.gif

6 174 Tab.gif

7 870 uparrow.gif

8 864 downarrow.gif

9 4658 logohome.gif

10 843 sxiconad.gif

11 1347 Plus.gif

12 3743 admin_user.html

13 6315 ephone_admin.html

14 3603 normal_user.html

15 2418 telephony_service.html

16 10230 xml-test.html

17 16948 dom.js

18 560138 admin_user.js

19 77566 normal_user.js

20 2515 xml.template

21 301298 ata18x-v2-16-ms-030327b.zup

22 42484

23 26376

24 14352

25 19512

26 17167

27 17486

28 6876 its-CISCO.

[22745404 bytes used, 10284740 available, 33030144 total]

32768K bytes of processor board System flash (Read/Write)

sh call app voice summ

name description

session Basic app to do DID, or supply dialtone.

fax_hop_on Script to talk to a fax redialer

clid_authen Authenticate with (ani, dnis)

clid_authen_collect Authenticate with (ani, dnis), collect if that fails

clid_authen_npw Authenticate with (ani, NULL)

clid_authen_col_npw Authenticate with (ani, NULL), collect if that fails

clid_col_npw_3 Authenticate with (ani, NULL), and 3 tries collecting

clid_col_npw_npw Authenticate with (ani, NULL) and 3 tries without pw

Default Default system session application 2.0

CTAPP Call Treatment Action Application

DEFAULT.C.OLD Obsolete system session application

lib_off_app Libretto Offramp

autoatt flash:its-CISCO.

TCL Script Version 2.0 supported.

Call Treatment Action Application - Version 1.0.

TCL Script Version 1.1 supported.

Voice Browser Version 2.0 for VoiceXML 1.0 & 2.0 supported.



Re: CCME & Auto Attendant

Try giving the command "forward-digits all " under the dial peer configuration.

More details on the command can be found at :

Community Member

Re: CCME & Auto Attendant

Hey there,

I've got the exact same problem.

So don't bang your head against the wall too much!!

I'm trying the exact same thing on a 2651XM.

Hopefully someone knows what tweaks to make in the script file.



Community Member

Re: CCME & Auto Attendant

I am also having similar problems with the auto attendant. I am running mine on a 1760-v.

Can anyone post a working complete config?

Thanks - Kevin

Community Member

Re: CCME & Auto Attendant

For what is is worth I went back to 12.2.15.t10 from 12.2.15.zj3 on the IOS and to cme- from cme-3.0.3 and it starting working. I suspect there is some problem with the AA script but I wasn’t ready to spend the time to try and decipher it’s inter workings.


Community Member

Re: CCME & Auto Attendant


Can you send me a copy of the script you are using and the router config. I would like the team to investigate why this does not work in ZJ3.



Community Member

Re: CCME & Auto Attendant

The default AA script available on CCO designed for the 12.4T train doesn't work with 12.4(3)T2 (on my Cisco 2651).

No changes or modifications to the script. Just the one included with the the file on CCO.


Community Member

Re: CCME & Auto Attendant

Reply from engineering:

I've confirmed CSCed02484 is NOT in 4T. We need to commit it. However,there is a workaround. It should work if they configure direct-inward-dial on the POTS dialpeer.

Most likely you will see this bug fix in 4T4 due out end of March.



Community Member

Re: CCME & Auto Attendant

To confirm your problem is CSCed02484 (handoff fails from TCL script to enhanced session app), enable "debug voip ivr error." A "Cannot ACK this leg" error appears when you use the Auto-Attendant script.

A potential workaround is to configure your POTS dial-peer to have direct-inward-dial as shown in the following example:

dial-peer voice 1 pots

application aa

incoming called-number 12345


port 0:D

Community Member

Re: CCME & Auto Attendant

I have the same problem.

I used the workaround but when the incoming

call gets transfered to the operator ip phone, operator cannot transfer call anymore.

TCL Script goes back and plays welcome message.

Community Member

Re: CCME & Auto Attendant

I had the same problem last week on a 1760-v-ccme. We had to put direct-inward-dial on the dial peer with the aa application and we had to upgrade the ios to 12.3.4T2 We had just T.

Try upgrading the image and using the Direct inward dial command


dial-peer voice 100 pots

application aa-imageline

destination-pattern 1000

progress_ind setup enable 3


port 0/0


CreatePlease to create content