Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Checking the VLAN config - Phones wont register

I'm having trouble getting 7960 phones to register with ccm AFTER changing the VLAN config. This was working previously before the I seperated voice/data vlans. I have verified the DHCP scopes including the 150 option and dfgw. As you can see, CCM now sits on a different subnet with the ip helper-address added. From the 172.30.253.0 segment, I can ping 172.30.254.4(the router's interface). I believe the problem lies within the changes I made subinterfacing the router's ethernet port, but I'm not sure what that issue is. Here are the configs:

3524xl-pwr ver 12.0.5

interface FastEthernet0/2

description Uplink to Router voice and data vlan

switchport trunk encapsulation dot1q

switchport trunk native vlan 6

switchport mode trunk

switchport voice vlan 60

interface FastEthernet0/9

description Voice and data vlan - IPTphone

switchport trunk encapsulation dot1q

switchport trunk native vlan 6

switchport mode trunk

switchport voice vlan 60

3640 - Router v.12.2.15

interface FastEthernet1/0

no ip address

duplex auto

speed auto

no keepalive

!

interface FastEthernet1/0.6

description Router data vlan 6

encapsulation dot1Q 6 native

ip address 172.30.253.4 255.255.255.0

!

interface FastEthernet1/0.60

description Router voice vlan 60

encapsulation dot1Q 60

ip address 172.30.254.4 255.255.255.0

ip helper-address 172.30.253.2

1 REPLY
Silver

Re: Checking the VLAN config - Phones wont register

I think the problem is with the DNS option. If DNS option 6 and 15 is configured and if the DHCP server is one subnet away from the phone, then registration doesnt seem to work.

Try to remove the DNS option 6 and 15 and see if it solves your problem. Please share your findings on the forum so that others would benefit.

133
Views
0
Helpful
1
Replies
CreatePlease to create content