Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Cisco 7940 IP Phone Problem - Protocol Application Invalid

I am trying to upgrade my 7940 IP phone to SIP ver 7.5. But the problem is that the moment I plug the phone into a switch, it starts with its own stuff (Configuring VLAN, IP, Requesting configuration, etc). It does not allow me to make any changes to the settings and finally end up with "Protocol Application Invalid" message. There is no way I can make any changes to the network settings of the phone. I tried putting this phone on seperate switch to which only this phone and the TFTP server was connected with required configuration files. I am 100% sure about the files required for the upgrade and have them all in my root directory of TFTP Server. I have enebled DHCP server on 3550 switch, added option 150 and 66 for TFTP server, added the switch port to voice VLAN and all the possible required configuration.

But still the phone refuses to take the new files from TFTP server and hangs. Tried with reseting the phone using reset combination but still that doesnt help. Also my file for the phone upgrade are all correct with version no and mac address as required.

I have even packet captured the phone packets with ETHEREAL, and I could see that the phone receives it IP address from DHCP server, it even request for letting it know the mac for TFTP server which is replied by the TFTP server... but after that I can see the phone communcating with the TFTP server for taking the files. The above process keeps repeating.

I am not able to do any changes to the phone settings as the phone gets hanged and does not allow any key combination. I do not have any console cable with me. Please help...

Ketan Kashikar (kashikarketan@gmail.com)

CCNP, CCDP

9 REPLIES
New Member

Re: Cisco 7940 IP Phone Problem - Protocol Application Invalid

I have this a lot on my network. Usually putting the phone is both voice and access vlan 200 (voice vlan) should take care of this issue, make sure to shut no shut the port and change it back after the phone load has been updated.

interface FastEthernet0/2

switchport access vlan 200

switchport mode access

switchport voice vlan 200

New Member

Re: Cisco 7940 IP Phone Problem - Protocol Application Invalid

Dear Dvanzee,

As you rightly said, I have tried the above solutions. I have cisco 3550 switch and the port to which the IP Phone is connected is assigned to voice vlan. I have created VLAN 10 as voice vlan and issued the below commands on the switch;

sw(conf-if)# switchport voice vlan 10

sw(conf-if)# switchport mode access

sw(conf-if)# switchport access vlan 10

sw(conf-if)# shut

sw(conf-if)# no shut

I am playing around this problem for past 1 week. To check if the files which i have in the TFTP root are correct or not, I tried upgrading other working phone which was done sucessfully which confirms the files required are in place (with respective changes to the files).

Still for the faulty phone I get Protocol Application Invalid message. I have even tried reseting the phone by pressing "#" key while the phone boots and then providing rest combination of "123456789*0#" after which the phone got reseted but still no use... Same error.

I thank you for our time and help, but still if you can provide me with any other method which I can try to make this phone working or any other method to reset the phone????

Kind Regards,

Ketan Kashikar (kashikarketan@gmail.com)

New Member

Re: Cisco 7940 IP Phone Problem - Protocol Application Invalid

Dear Ketan ,

I passed by another Post 2 months ago that completely adviced with the Opposite , to Configue the Switch Port with only the Voice Vlan using command < Switch Access Vlan XX >.

Please try both and update us if one of the suggested solutions resolved your Problem.

Regards

M.Tag

New Member

Re: Cisco 7940 IP Phone Problem - Protocol Application Invalid

Dear Mohamedtag,

As you rightly said, I have tried both the above solutions. I have cisco 3550 switch and the port to which the IP Phone is connected is assigned to voice vlan. I have created VLAN 10 as voice vlan and issued the below commands on the switch;

sw(conf-if)# switchport voice vlan 10

sw(conf-if)# switchport mode access

sw(conf-if)# shut

sw(conf-if)# no shut

Also tried the other method of "switchport access vlan 10 and switchport voice vlan 10" but unfortunately non of these worked out for me. I am playing around this problem for past 1 week. To check if the files which i have in the TFTP root are correct or not, I tried upgrading other working phone which was done sucessfully which confirms the files required are in place (with respective changes to the files).

Still for the faulty phone I get Protocol Application Invalid message. I have even tried reseting the phone by pressing "#" key while the phone boots and then providing rest combination of "123456789*0#" adfter which the phone got reseted but still no use... Same error.

I thank you for our time and help, but still if you can provide me with any other methode which I can try to make this phone working or any other method to reset the phone????

Kind Regards,

Ketan Kashikar (kashikarketan@gmail.com)

Hall of Fame Super Red

Re: Cisco 7940 IP Phone Problem - Protocol Application Invalid

Hi Ketan,

Her is an excerpt from a Cisco document that seems to address this problem:

Problem

The 7960 IP phone fails to perform the boot process correctly. As the phone boots, this error message displays in the phone LCD:

Protocol Application Invalid

Solution

When you examine the sniffer trace between the DHCP server and the phone, you can identify that the phone accepts a DHCP offer from the data VLAN (the native VLAN) instead of the voice VLAN. The phone tries to communicate with the voice VLAN with the IP address that belongs to the data VLAN.

This problem can happen under these conditions:

With an IP Phone 7940/7960 with firmware version 7.2(2) and earlier

When a DHCP server sends a response packet in an untagged format

With a DHCP server switch port that is configured with voice VLAN or with a trunk that contains that voice VLAN

When option 150 is not set for the native VLAN on the DHCP server

When Cisco Discovery Protocol (CDP) on the switch and the phone do not converge in a timely fashion

----------------------------------------------------------------------------------------------------------------

The workaround for this problem is to complete these steps:

Configure option 150 in the native VLAN scope on the DHCP server.

Complete these steps:

Choose Start > Programs > Administrative Tools > DHCP.

Right-click the DHCP server and choose Set Predefined Options in the pop-up window.

Click Add.

Enter TFTP Server IP Address in the Name field.

Choose IP Address from the Data type menu.

Enter 150 in the Code field

Click OK.

Choose 150 TFTP Server IP Address from the Option name menu.

Enter the IP address of the TFTP server in the IP Address field, which is in the Value area.

Click OK.

-----------------------------------------------------------------------------------------------------------------

Remove the voice VLAN command from the phone switch port and leave the switch port as an access port on the native VLAN.

For example, if the phone is connected to a Catalyst 3550 multilayer switch, remove this line:

switchport voice vlan 205

Reboot the 7940/7960 IP phone.

The phone upgrades its load with the use of an IP address on the native VLAN.

Add the voice vlan command back to the switch port.

Reboot the 7940/7960 IP phone.

The phone now comes up with an IP address on the voice VLAN.

Here is a link to the actual doc:

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a008055c1fe.shtml

Hope this helps!

Rob

Please remember to rate helpful posts..........

New Member

Re: Cisco 7940 IP Phone Problem - Protocol Application Invalid

Hi Rob,

First of all thanks for the solution. But unfortunately the solution still doesnt work for my problem. As per the instruction I followed all the steps, but still same error. One more thing, we do not have any call manager, instead we use SIP for IP phones. Also the switch acts as the DHCP server in our case.

After following the above steps, I tried sniffing through ETHEREAL, and could see no difference in the results. The 7940 phone still was not able to contact the TFTP server. I had put the TFTP server and IP Phone in same vlan and for DHCP had speciificaly issues option 150 ip "TFTP Address".

I does takes IP address from DHCP and also asks for TFTP servers MAC address which is replied by TFTP, but after that nothing happens and not connection is eastablished between Phone and TFTP server. The proccess repeats for some time and the final outcome is "Protocol Application Invalid" error.

Any further suggetion will be appreciable.

Kind Regards,

Ketan Kashikar (kashikarketan@gmail.com)

Silver

Re: Cisco 7940 IP Phone Problem - Protocol Application Invalid

We have run into batches of problems getting sip loads into phones - a lot depends on what image and version you are starting from. Here is a link to a tech note on the issue, I hope one of these scenarios fits your problem:

http://www.cisco.com/en/US/tech/tk652/tk701/technologies_tech_note09186a0080094584.shtml#sccptosip3

Mary Beth

New Member

Re: Cisco 7940 IP Phone Problem - Protocol Application Invalid

Please read the following section of the article about resetting the IP phone back to Factory Defaults. It fixed the problem for me.

http://www.cisco.com/en/US/partner/products/hw/phones/ps379/products_administration_guide_chapter09186a00801ebe73.html

Hope this helps.

New Member

Re: Cisco 7940 IP Phone Problem - Protocol Application Invalid

Hi

I had the smae problem with "Protocol Application Invalid" Please see http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=IP%20Communications%20and%20Video&topic=IP%20Telephony&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.1dd8dd7d where I wrote to some guy a step by step solution for upgrade and I discribed how to avoid this twrrible message :o)

3884
Views
16
Helpful
9
Replies
CreatePlease to create content