Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Cisco Call manager using PSTN Line

Hi

Eventually i have purchased

Cisco Router 2620

NM-2V

Vic-2fxo Card

=========================================

Can you please let me know how to configure the gateway to use PSTN line with my SCCP Phones which is already registered with call manager 4.1.2

=========================================

Please provide me the configuration

Thanks

7 REPLIES

Re: Cisco Call manager using PSTN Line

It depends on the gateway protocol you want to use.

Here is a document on MGCP gateway configuration:

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a008009428e.shtml

Here is one for H.323 gateway configuration:

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a0080094636.shtml

Brandon

New Member

Re: Cisco Call manager using PSTN Line

Firstly thank you for the reply

I have followed your instructions still unable to registered gateway through call manager. Here is the cisco 2620 config info.

=====================================================

melbournegroceries#sh running-config

Building configuration...

Current configuration : 917 bytes

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname melb

!

enable secret 5 $1$gBy6$c0.PnhoPtkNCQ4GJqKOr01

enable password voip

!

ip subnet-zero

no ip finger

!

voice-port 1/0/0

!

voice-port 1/0/1

!

voice-port 1/1/0

!

voice-port 1/1/1

!

!

dial-peer voice 4 pots

application MGCPAPP

port 1/1/1

!

dial-peer voice 3 pots

application MGCPAPP

port 1/1/0

!

dial-peer voice 2 pots

application MGCPAPP

port 1/0/1

!

dial-peer voice 1 pots

application MGCPAPP

port 1/0/0

!

!

interface FastEthernet0/0

ip address 192.168.0.120 255.255.255.0

speed auto

full-duplex

!

interface Serial0/0

no ip address

shutdown

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.0.121

no ip http server

!

snmp-server community yes RO

!

line con 0

transport input none

line aux 0

line vty 0 4

password voip

login

!

no scheduler allocate

end

melb#

=====================================================

=====================================================

melb#sh version

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-IS-M), Version 12.1(5), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2000 by cisco Systems, Inc.

Compiled Wed 25-Oct-00 11:43 by cmong

Image text-base: 0x80008088, data-base: 0x80CAC644

ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

melb uptime is 1 hour, 7 minutes

System returned to ROM by power-on

System image file is "flash:c2600-is-mz_121-5"

cisco 2620 (MPC860) processor (revision 0x102) with 53248K/12288K bytes of memor

y.

Processor board ID JAD042701EE (1286926306)

M860 processor: part number 0, mask 49

Bridging software.

X.25 software, Version 3.0.0.

1 FastEthernet/IEEE 802.3 interface(s)

1 Serial network interface(s)

4 Voice FXO interface(s)

32K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

melb#

=====================================================

Please advice something thanks

Re: Cisco Call manager using PSTN Line

Make sure that the MGCP domain name matches the router hostname exactly. This is case sensitive. Also, I don't see the MGCP configuration on the router as described here:

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a008017787b.shtml

You will need the following commands:

mgcp

mgcp call-agent [CCM IP Address]

ccm-manager mgcp

ccm-manager redundant-host [Backup CCM IP Address]

ccm-manager config server [TFTP IP Address]

Brandon

New Member

Re: Cisco Call manager using PSTN Line

When i type mgcp command its not accepting.

=====================================================

melb(config)#mgcp

^

% Invalid input detected at '^' marker.

melb(config)#

=====================================================

What could be the reason?

Thanks For your reply

Re: Cisco Call manager using PSTN Line

I just noticed from your show version command that the IOS version you have installed does not support voice.

Brandon

New Member

Re: Cisco Call manager using PSTN Line

Thanks for your reply

I didnt understand "feature set you have installed (IP Plus) does not support voice"

You mean to say configuration is incorrect or the device which i am using is not supported.

=====================================================

What do i do to support voice?

Thanks

Re: Cisco Call manager using PSTN Line

Your device is supported. You will need a minimum of 12.2(11)T (IOS Version) to support MGCP.

Brandon

130
Views
5
Helpful
7
Replies
CreatePlease to create content