Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

cm upgrade - urgent

if you do a bars back up from version 3.3 can you restore the data to cm version 4.1 (on the same box) also with the 3.3-4.1 upgrade pack from cisco can you do a clean 4.1 install with that or only upgrade?

Thanks

3 REPLIES
New Member

Re: cm upgrade - urgent

Hi,

Here are the answers to your questions

1.No,You can not restore the backup iof 3.3 on 4.1 version as bars only supports same version restores like 3.3.3 restore on a 3.3.3 server and not even 3.3.4.You can upgrade to 4.1 from 3.3 and then take the backup of 4.1 server ,and u can restore that backup on a newly build 4.1 server.

2.You dont need to do a clean instal for upgrades from 3.3 to 4.1,All u need to insure is that your OS and SQL patches are upto the mark for 4.1.

http://www.cisco.com/univercd/cc/td/doc/product/voice/c_callmg/ccmcomp.htm

Thanks

Aman

New Member

Re: cm upgrade - urgent

Aman,

How certain are you about point #1 above? Do you know of any documentation anywhere that states this very clarly? I have read the BARS Admin guide and release notes, and there is a very vague reference to this, but nothing in clear and precise words.

We have a situtation with a customer where we need to upgrade 2 clusters to 4.1(3) using new servers. One cluster is running 4.0(2a), while the other one is on 3.3.(4). You'd think we could just do the backup on the old servers and do a restore on the new ones (at least on the cluster running 4.0), but you don't think (or know) that it would work. Of course, the same version of BARS would be used during both Backup and Restore.

Any additional information would be appreciated.

Regards,

Joseph

Re: cm upgrade - urgent

BARS is always used for same version to same version. It's a long process.

On your new new servers, you need to install the same versions of CallManager, then use BARS on the old server to the new server. Then on the new servers, you can upgrade to the new release. You can't use BARS from 4.0 to 4.1 or 4.0 to 4.0 (example of versions of course)

If you have spare drives around, mirror the current server, pull the drive out, mirror another drive... now do the upgrade. If it flakes out on you, you still have the original mirror and a quick restore.

cheers

tc

87
Views
0
Helpful
3
Replies