Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CME: Incoming Calls from mobiles not working

Hi all,

i do some tests with a small CCME environment: Cisco 2611XM, 1* ISDN PRI (E1). So, nearly everthing is working realy fine, all outgoing calls are OK, all incoming calls from fixed lines are also working.

But i have a problem with incoming calls from mobiles (i tried different providers, all the same), after dialing i get a call conected signal, after a few seconds i got busy signal.

I´ve done some isdn q931/q921 and vtsp debugging and found some differences but i were not able to interpret them ...

When i call from mobile the router does not send a TX -> SETUP_ACK, instead a TX -> CALL_PROC is send.

On VTSP i could see

vtsp_process_event: [state:S_DIGIT_COLLECT, eveent:E_TSP_PROCEEDING]

vtsp_process_event: [state:S_DIGIT_COLLECT, event:E_TSP_DISCONNECT_PI_IND]

instead of [state:S_SETUP_INDICATED, event:E_TSP_INFO_IND] when i called from fixed line.

Any ideas where i have to search for a solution ?

Cisco 2610XM, IOS 2600-ipvoice-mz.124-7.bin, (CME 3.3)

kind regards,

Dietmar

3 REPLIES
Cisco Employee

Re: CME: Incoming Calls from mobiles not working

Dietmar,

I think the router is doing just fine.

Notice that 23 seconds after the connect ack, we get a disconnect coming in from the telco. I wanted to make sure they are not timing out on anything. It does not look like it is a timer popping, because I cannot think of any timer that goes off in 23 seconds..

Mar 8 19:55:13.496: ISDN Se1/0:15 Q931: DISCONNECT pd = 8 callref = 0x09E3

Cause i = 0x8090 - Normal call clearing

You do not need to send a setup ack. Calls should still work without a setup ack, as long as you send a proceed soon enough (which in this case we are)..

You can ignore the VTSP debugs in this case.

I had a similar issue before.. Calls from only some cell phone providers were failing. We later found out that it was only providers that used older technologies (verizon for example) failed. GSM calls worked just fine.. We were never able to determine why the difference.. I belive it is something to do with their switching setup.

Try to make calls from different cell phones:

nextel

verizon

sprint

AT&T

TMobile

etc.. Do you see a difference?

New Member

Re: CME: Incoming Calls from mobiles not working

Hello,

thank you for your answer.

I tried it once again, the 23sec are the time after i hang up the call on my mobile.

I tried 3 Providers, the output of the Debug is the same.

The isdn setup starts and continue until:

ISDN Se1/0:15 CC: CCPRI_Go: source id 0x300, call id 0x20, event 0x341 (pre-ccb recovery)

ISDN Se1/0:15 CC: CCPRI_Go: dispatching event 0x92 call id 0x20 cref 0x8DC4 Source->L3

ISDN Se1/0:15 CC: CCPCC_CallRoutingIn: executing with event = 92 in state = CALL ROUTING_IN

Here i got for about 10 sec a connected signal (continuous tone), then it change to a fast busy.

After that, nothing happen and i quit the call on the mobile.

Mar 8 18:24:51.744: ISDN Se1/0:15 CC: CCPRI_Go: source id 0x500, call id 0x0, event 0x4B (pre-ccb recovery)

Mar 8 18:24:51.744: ISDN Se1/0:15 CC: CCPRI_Go: call_id 0x20 cref 0x8DC4 event 0x4B Source->HOST

Mar 8 18:24:51.748: ISDN Se1/0:15 CC: CCPCC_CallConnected: event 0x4B b channel 20 nfas int_id 0 call_id 0x20

...

So, i´m not realy sure were i have the problem - if it is on the ISDN setup, call routing or whatever ...

regards,

Dietmar

New Member

Re: CME: Incoming Calls from mobiles not working

Solution: direct-inward-dial

After a collegue gave me some hints i started to debug dialpeers.

The problem was that i did´nt configure "direct-inward-dial" in the dial-peer statement.

dial-peer voice 100 pots

destination-pattern 0.T

direct-inward-dial

port 1/0:15

Now both calls - from fixed and from mobile - are working.

Dietmar

Dietmar

392
Views
3
Helpful
3
Replies
CreatePlease login to create content