Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CMM Configuration - Registers with Call Mgr, no RTP

Team, I am trying to swap out a 3661 with NM-HDVs for a couple of WS-SVC-CMMs each with an ACT module for CFB and XCODE. Both will register, both allow me to define CFBs and XCODEs, however I get dead air when the XCODEr needs to work and similar with CFB. I have tried registering the MAC of both the GigE1/0 and the FA3/0 (mediacard 4) with the same results. I have attached a SHO RUN, Sho SCCP, SHO INT for Gi1/0 and Fa3/0 and a SHO DSPFARM CONN showing that it appears to terminate the media stream, but I can't hear anything. I am running 12.4.5a. Call Mgr is 4.1.3 SR2. Any hints? Thanks.

5 REPLIES
Green

Re: CMM Configuration - Registers with Call Mgr, no RTP

Hi,

I do see that the FE is configured.

interface FastEthernet3/0

This interface is the one which takes care of the Media Streaming

Can you ping from the FE to each Endpoint in the Conference|Transcoding session?

The IP address: ip address 10.1.21.21 belongs to a particular VLAN?

Have you already assign this port to a VLAN in the supervisor?

//G

New Member

Re: CMM Configuration - Registers with Call Mgr, no RTP

Hi Gogasca, I'm sure this is a routing issue. I cannot find IOS documentation for the Cat6500 side of the configuration. You are correct in that I cannot ping FA3/0 10.1.21.21 from the Cat 6500. The Cat6500 is the default gateway for VLAN 21. The CMM is is slot 9 and I have Gi9/1, Fa9/2, Fa9/3, Fa9/4, Fa9/5 all in VLAN 21. I can ping the CMMs Gi9/1 port from anywhere....I just can't ping the Fa3/0 except when telnet'd into the CMM itself.

I saw some static ARPA entries in the documentation with no explanation. It seems like I need some sort of a static route on the Cat6500. Do you have a sample configuration from an IOS 6500 with a CMM that you could share? Thanks.

Green

Re: CMM Configuration - Registers with Call Mgr, no RTP

Yes, for sure,tomorrow I will post u one from my lab server.

The config looks good.

The way the CMM is designed, IOS and the code that runs on the ACT module are separate. When the ACT module receives non-RTP traffic, it hands it off

to IOS. IOS uses the gig interface to transmit, the only thing that should really be transmitted off the CMM from the ACT's interface is RTP.

Since IOS responds from the gig interface, they need to be in the same broadcast domain and therefore subnet. The ACT needs to be a /32 because if

it wasn't, IOS could try and use that interface to respond to other devices on the subnet assigned to the gig interface because of what the routing

table would look like. This wouldn't work. By giving the ACT it's own IP address, the CMM is able to avoid having to route traffic to the ACT, the

RTP is switched directly there by the catalyst. If the CMM had to "touch" these packets it's capacity would be significantly reduced, it's not really

designed to route traffic between interfaces

The ACT module only processes RTP traffic that is sent to it. This is part of the reason that all of the skinny signaling occurs using the gig interface. It wouldn't make sense to send it to the ACT, the ACT has no real intelligence that doesn't involve RTP. When the RTP steams are set up with

skinny, IOS programs the ACT module, and tells it what streams to listen to, mix, send, and where to send them using it's routing and ARP tables. This is

also the reason that proxy-arp is disabled by default on the CMM, when normally it's on by default

HTH

//G

New Member

Re: CMM Configuration - Registers with Call Mgr, no RTP

One more comment: I was able to make this work. Let me give just a little better totpology overview: I have two Cat6509s as my distribution layer in the Data Center. I have one CMM in each of these 6509s in slot 9. I have them on the smae Layer 2 VLAN.

Cat6509_1 - VLAN 21, 10.1.21.2 (HSRP active 10.1.21.1

Cat6509_2 - VLAN 21, 10.1.21.3 (HSRP standby 10.1.21.1

Cat6509_1 - VLAN 21, Gi9/1, Fa9/2, Fa9/3, Fa9/4, Fa9/5

Cat6509_2 - VLAN 21, Gi9/1, Fa9/2, Fa9/3, Fa9/4, Fa9/5

Cat6509_1 - CMM Gi1/0 10.1.21.11, Fa3/0 10.1.21.21

Cat6509_2 - CMM Gi1/0 10.1.21.12, Fa3/0 10.1.21.22

Cat6509_1 - IP Route 10.1.21.21 255.255.255.255 10.1.21.11

Cat6509_2 - IP Route 10.1.21.22 255.255.255.255 10.1.21.12

I am now able to ping from anywhere in the network to the Fa3/0 on both CMMs.

Is this the proper TAC supported method of addressing and routing to these CMMs?

New Member

Re: CMM Configuration - Registers with Call Mgr, no RTP

To try and close the loop - I removed the static routes and I can ping both the Gi1/0 interface and the Fa3/0 corresponding to the ACT in mediacard slot 4. I still had trouble with CFB. I decided to define the the CFB as a CISCO IOS Enhanced Conference Bridge and it worked. I opened a TAC case because that's just not normal behavior. TAC told me to go back to the original configuration (CISCO Conference Bridge Hardware (WS-SVC-CMM) and to upgrade to 12.4.7. 12.4.7 was the code that made this work. I had trouble with both 12.4.5a and 12.4.5b.

400
Views
0
Helpful
5
Replies
CreatePlease login to create content