Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Configuring LLQ

First attempt at configuring LLQ. Scenario is two buildings connect with a point to point T1. Main bldg has a Nortel PBX with their Reach Line Card and a Cisco 3640. Remote has a Nortel Remote Office 9150 and a Cisco 1751.

Nortel stuff uses Diffserv at 0x2E which is 46 which is EF I believe. It also uses port numbers 20480 and 20482. Signaling is done on tcp port 12800.

My config plan on each router is:

class-map match-all voice_traffic

match access-group 101

class-map match-all voice_signal

match access-group 1012

access-list 101 permit ip any any dscp eq ef

access-list 102 permit tcp any any eq 12800

policy-map voice_policy

class voice_traffic

priority 768

class voice_signal

bandwidth 8

class class-default

fair queue 376

interface serial0/0

description ############

ip address x.x.x.x x.x.x.x

no cdp enable

service-policy output voice_policy

Am i on the right track ??

Thanks

D. Evans

4 REPLIES
Blue

Re: Configuring LLQ

You should be matching on DSCP in your class maps, rather than access-lists. Your config will be simplier, and at least with some versions of IOS it will not work using access-lists.

To verify functioning use the command " show policy-map interface s0/0".

New Member

Re: Configuring LLQ

Very good, thank you !

New Member

Re: Configuring LLQ

It looks good, but what about ports 20480 and 82? Do the Nortel cards only do proprietary signaling, or is there some protocol like h.323 running as well? Just in case, below is an access list that catches a lot of the standard voip signaling protocol ports.

The af31 should catch a lot of the control traffic because you should be marking it on the gateways, who knows, maybe Nortel marks it that way too. But if there is something that was overlooked or somethings that cannot mark with dscp, then the rest of the list should suffice to catch everything else. Rule 2 is SCCP signalling for Cisco ip phones. Rules 3 and 4 are MGCP signaling. Rules 5 and 6 are h.323 signaling, I think.

You might want to be more specific with your access list, so that only traffic coming from a certain address and going to a certain address or network will be considered. That is what I have done in the access list here.

You probably need more bandwidth for signaling. Does anyone have a voip signaling bandwidth calculator? Or is there a good way to tell how much is needed? I don't know, I might allocate 32 k for signaling if you are doing 768k worth of voice traffic, but then, that depends on what codec you are using. Etc, etc.

Unless you have time-sensitve data traffic in your class-default, you should do wred on that class. I think you can implement the feature by typing "random" on the class-default.

access-list 101 permit ip 10.62.25.0 0.0.0.255 any dscp af31

access-list 101 permit tcp 10.62.25.0 0.0.0.255 any eq range 2000 2002

access-list 101 permit udp 10.62.25.0 0.0.0.255 any eq 2427

access-list 101 permit tcp 10.62.25.0 0.0.0.255 any eq 2428

access-list 101 permit tcp 10.62.25.0 0.0.0.255 any eq 1720

access-list 101 permit tcp 10.62.25.0 0.0.0.255 any eq range 11000 11999

New Member

Re: Configuring LLQ

Great info, thanks !

195
Views
0
Helpful
4
Replies
CreatePlease to create content