Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Configuring voice ports on 3524-PWR, phones register to wrong VLAN

Hi All,

How do I configure a 3524-PWR to support IP Phones and PCs through the same port, but into different VLANs? On the Cat 6500 I can use the "Set port Auxiliary Vlan" command, but what is the equivalent for the 3524? Here is the current interface config:

interface FastEthernet0/1

switchport access vlan 3

switchport voice vlan 200

With this config, the phones register into the PC's VLAN (3) instead of VLAN 200. Do I need to set up trunking on the switchport? I don't need to set IP precedence right now.

Thanks, Randy

  • Other Collaboration Voice and Video Subjects
1 REPLY
Gold

Re: Configuring voice ports on 3524-PWR, phones register to wron

For me, each Catalyst 10/100 port for voice, whether on a 3512, 3524, 3524-PWR, or 3548, is:

interface FastEthernet 0/xx

switchport trunk encapsulation dot1q

switchport trunk native vlan yyy

switchport mode trunk

switchport voice vlan zzz

switchport priority extend cos 0

spanning-tree portfast

where xx is the port number; yyy is the native or untagged VLAN for the port (i.e. the "data" VLAN, where the user's PC attached to the IP Phone sends its traffic); and zzz is the VLAN for the IP Phones in each building.

Each attached IP Phone gets its IP address via DHCP, receiving one that's appropriate for the voice VLAN it is on.

A PC or Macintosh plugged into the pass-through switchport on the back of an IP Phone that has one (7910+SW, 7940, 7960 for me), gets its IP address from DHCP, receiving one appropriate for the native or untagged VLAN it's on.

The DHCP servers on my network live in VLANs different from the voice and "user data" VLANs. So the "ip helper-address" command is found frequently on my Layer 3 interfaces. This helps get the IP address request broadcasts to a server which can respond with an offer.

Cisco forwards several kinds of UDP broadcast traffic by default, when you use the "ip helper -address" command. To limit the forwarding to BOOTP/DHCP client and server (67 and 68) traffic only, I use the "no ip forward-protocol udp" command several times on each router or multilayer switch. I block forwarding of TFTP (69), DNS (53), time service (37), NetBIOS name server (137), NetBIOS datagram server (138), and TACACS (49) broadcasts.

Hope this helps.

341
Views
10
Helpful
1
Replies
This widget could not be displayed.