Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

Confusing QoS command on switch!!???

We have 3524PWL XL, WS-C3550-24-PWR-SMI for access layer usage, 4507(sup IV) use for both routing and access layer.

PC connect to IP Phone 7960, then IP Phone connect to switches.

I read through some documentation, I found at least TWO different configurations at switch access layer.

Example 1:

interfae Fastethernet 0/11

switchport access vlan 10

switchport voice vlan 110

switchport priority extend cos 0

mls qos trust cos

spanning-tree portfast

Example 2:

interface FastEthernet0/11

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport mode trunk

switchport voice vlan 110

switchport priority extend cos 0

spanning-tree portfast

Above are basic configuration.

Which one I should use? What is different between both??

Thanks!!

4 REPLIES
New Member

Re: Confusing QoS command on switch!!???

If memory serves, the 'switchport voice vlan' command does nothing without the 'switchport trunk encapsulation dot1q' command. I beleive Example 1 above only supports a data connection and not an IP phone. Not that a phone would not work on that port, but it would be on the data vlan, rather than the voice vlan and not take advantage of QoS features.

Of course, the 3550 changes some commands. I know that Example 2 is correct for a 3524. However, the 3550 may default to dot1q encapsulation, so Example 1 could be prefectly valid for a 3550.

New Member

Re: Confusing QoS command on switch!!???

Well, which one you use depends on what you are doing. Seeing as how you have an IP phone with a PC connected to it, the second one is the one to go with. You have to configure the port to be a dot1q trunk on the 3500s to do multivlan connections to the IP Phones - which will allow phones to grab the voice vlan and PCs or other end devices plugged into the switch port on the phone to grab the access vlan.

The mls qos trus cos command can be a little scary in some scenarios, so you might want to stay away from that one. What this command essentially says is that you will trust the cos settings from the end device connected to the phone. If you have a user who knows what they are doing or an application on the rampage, you could end up having some end device shooting out packets with a cos level higher than that of the phones, which could certainly wreak havoc on your voice quality.

The other command, switchport pri extend cos 0 means that beyond the phone, you will mark all traffic with a cos value of 0. Cos values of 0 are a) the default and b) the lowest priority.

Hope that helps.

Loy

New Member

Re: Confusing QoS command on switch!!???

I'm doing something similar to example 1 without the "mls qos trust cos" statement and it seems to work just fine. I have also done it the way of example 2.

interface FastEthernet0/11

switchport access vlan 2

switchport mode access

switchport voice vlan 22

spanning-tree portfast

The phone indicates it's operating on vlan 22 and I have network access on my PC so I assume it's working on vlan 2 as it should be. I also use a dhcp-helper statement on vlan 22 and my dhcp server for the phones is on vlan 2 while my call manager (on an ics-7750) is on vlan 1

Looks like either configuration will work.

Bronze

Re: Confusing QoS command on switch!!???

"mls qos trust cos" is for switch to trust CoS from IP Phone.

I always see "example 1" at switch 4000(sup III or IV) and 3550PWR.

I always see "example 2" at switch 3524PWL.

Why they are different, it is because different IOS version, or just different command at different model of switch??????????

223
Views
0
Helpful
4
Replies
CreatePlease login to create content