Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

Connect to IPCC with JDBC

We have IPCC-x 4.0.5(a). SQL authentication is Windows only (according to TAC this is the only mode supported).

We are trying to connect to the IPCC SQL db with a JDBC driver (jtds) and it is getting a connection failed message. The URL format we're using is: jdbc:jtds:sqlserver://XX.XX.XX.XX:1433;domain=ipcc;DatabaseName=CRSSQL;SelectMethod=cursor

The user id and password is being set when the connection is created. We get the error "Network error IOException: Connection refused: connect"

Anyone run into this or anyone have a solution?


Re: Connect to IPCC with JDBC

Quite frankly, don't listen to TAC in this case.. Call Manager and IPCC run fine with mixed authentication and nobody will ever be the wiser. We change any SQL DB where we need external access.

Also, why not use Microsoft's own jdbc driver?

Furthermore, are you sure the application that runs your code really runs under an account with the appropriate permissions?

Community Member

Re: Connect to IPCC with JDBC

Thanks for the reply. Pardon my responses if they are not correct. I am just trying to relay from our web developers to this forum.

[from our developers]

It looks like port 1433 (the port that MSSQL generally listens on) is closed or otherwise not accessible on the IPCC boxes (I ran a port scanner on them from my PC). Does Cisco have IPCC running MSSQL on a non-standard port?

We also tried to using Microsoft's jdbc driver but it does not have Windows authentication build into it. Do you know of another jdbc driver that might?



Community Member

Re: Connect to IPCC with JDBC

We figured this out. On IPCC-x 4.0.5(a) the default port used for SQL is 4433 not 1433. Not sure why Cisco has it set that way. Once we knew the port we were able to connect using the jdbc driver we have.

Community Member

Re: Connect to IPCC with JDBC

Mixed authentication does not work on 5.0!!!

We found that out the hard way. We were unable to get Historical Reports with it in mixed mode. We use the mixed for a wallboard.

Cisco told us that Windows only was the only option.

To make both historical reports and the wallboard work we have to boot to mixed and change it to windows only without restarting the service.

CreatePlease to create content