Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Connection between R2 and ISDN

dear all

I am trying to connect two AS5300, one connected with an ISDN and other using R2. And I have some problem when the isdn side call a certain number at R2 side.

As ISDN error I have:

Cause i = 0x80E0 - Mandatory information element missing

does some one knows how I can solve this problem ?

here are the config and log error

ERROR:

Feb 25 14:12:12.130: ISDN Se1:23 Q931: RX <- SETUP pd = 8 callref = 0x0013

Bearer Capability i = 0x8090

Standard = CCITT

Transer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xE9808381

Exclusive, Interface 0, Channel 1

Called Party Number i = 0x80, '011XXXXXXXXXX'

Plan:Unknown, Type:Unknown

*Feb 25 14:12:12.134: ISDN Se1:23 EVENT: process_rxstate: ces/callid 1/0x7E call

type 2 CALL_INCOMING

*Feb 25 14:12:12.134: ISDN Se1:23 EVENTd: calltrkr_incoming_call: call_id=0x7E

*Feb 25 14:12:12.134: ISDN Se1:23 EVENTd: calltrkr_setup_received: isdn_info=165

5802864l, call_id=0x7E ANSWER

*Feb 25 14:12:12.134: ISDN Se1:23 EVENTd: calltrkr_setup_received: calltracker d

isabled

*Feb 25 14:12:12.134: ISDN Se1:23 EVENTd: calltrkr_setup_received: isdn_info=165

4831212l, call_id=0x7E ANSWER

*Feb 25 14:12:12.138: ISDN Se1:23 EVENTd: call_incoming: b channel 0, call type

is VOICE ULAW

*Feb 25 14:12:12.138: ISDN Se1:23 EVENTd: call_incoming: Received a VOICE call f

rom <unknown> on b channel 0 at 64 Kb/s

*Feb 25 14:12:12.154: ISDN Se1:23 EVENTd: process_pri_simple: msg 74, call id 0x

7E, bchan 0, call type VOICE

*Feb 25 14:12:12.154: ISDN Se1:23 Q931: TX -> CALL_PROC pd = 8 callref = 0x8013

Channel ID i = 0xA98381

Exclusive, Channel 1

*Feb 25 14:12:12.342: ISDN CDAPI: cdapi_find_tsm found a GTD message IAM,

GCI,f7dd958e480111d78147d0318cbbc656

ip011XXXX21XXX37:

end of gtd length is 46

*Feb 25 14:12:22.150: ISDN Se1:23 Q931: RX <- DISCONNECT pd = 8 callref = 0x001

3

*Feb 25 14:12:22.150: ISDN SERROR: LIF_StopTimer: NULL timer

*Feb 25 14:12:22.150: ISDN SERROR: LIF_StopTimer: NULL timer

*Feb 25 14:12:22.150: ISDN Se1:23 EVENT: process_rxstate: ces/callid 1/0x7E call

type 2 CALL_DISC

*Feb 25 14:12:22.150: ISDN Se1:23 EVENTd: process_rxstate: cause=0x10 (16), caus

e_present=1

*Feb 25 14:12:22.150: ISDN Se1:23 EVENTd: calltrkr_call_disconnected: isdn_info=

0x62B18BF0, call_id=0x7E

*Feb 25 14:12:22.150: ISDN Se1:23 EVENTd: calltrkr_call_disconnected: isdn_info=

0x62A2B86C, call_id=0x7E

*Feb 25 14:12:22.154: ISDN Se1:23 CDAPI: cdapi_mib_update msg CALL_DISC, remote

number , connected? No

*Feb 25 14:12:22.154: ISDN Se1:23 EVENTd: process_disc_ack: call id 0x7E, ces 1,

call type VOICE cause 0x10

*Feb 25 14:12:22.154: ISDN Se1:23 Q931: RX <- RELEASE pd = 8 callref = 0x0013

*Feb 25 14:12:22.154: ISDN Se1:23 Q931: TX -> RELEASE pd = 8 callref = 0x8013

Cause i = 0x80E0 - Mandatory information element missing

*Feb 25 14:12:22.158: ISDN SERROR: LIF_StopTimer: NULL timer

*Feb 25 14:12:22.158: ISDN SERROR: LIF_StopTimer: NULL timer

*Feb 25 14:12:22.158: ISDN Se1:23 EVENT: process_rxstate: ces/callid 1/0x7E call

type 2 CALL_CLEARED

*Feb 25 14:12:22.158: ISDN Se1:23 EVENTd: calltrkr_call_cleared: isdn_info=0x62B

18BF0, call_id=0x7E

*Feb 25 14:12:22.158: ISDN Se1:23 EVENTd: calltrkr_call_cleared: isdn_info=0x62A

2B86C, call_id=0x7E

*Feb 25 14:12:22.158: ISDN Se1:23 CDAPI: cdapi_mib_update msg CALL_DISC, remote

number , connected? No

*Feb 25 14:12:22.162: ISDN Se1:23 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x8

013

here is the config of ISDN side:

Building configuration...

Current configuration : 4382 bytes

!

version 12.2

!

boot system flash c5300-is-mz.122-13.t.bin

enable secret 5 XXXXXXXXXXXXXXXXXXX

enable password XXXXXXXXXXXXXXXXXXX

!

!

!

resource-pool disable

!

ip subnet-zero

!

!

isdn switch-type primary-5ess

!

voice call send-alert

voice rtp send-recv

!

voice class codec 55

codec preference 1 g729r8 bytes 50

codec preference 2 g729br8 bytes 50

codec preference 5 g723ar53

codec preference 7 g723ar63 bytes 144

codec preference 8 g723r53

codec preference 9 g723r63 bytes 120

!fax interface-type modem

mta receive maximum-recipients 0

!

controller T1 0

framing esf

clock source line primary

linecode b8zs

cablelength short 133

pri-group timeslots 1-24

no yellow generation

no yellow detection

!

controller T1 1

framing esf

clock source line secondary 1

linecode b8zs

cablelength short 133

pri-group timeslots 1-24

no yellow generation

no yellow detection

!

controller T1 2

shutdown

framing esf

linecode b8zs

pri-group timeslots 1-24

no yellow generation

no yellow detection

!

controller T1 3

shutdown

framing esf

linecode b8zs

pri-group timeslots 1-24

no yellow generation

no yellow detection

!

!

!

interface Ethernet0

ip address XXX.XXX.XXX.106 255.255.255.0

no ip mroute-cache

!

interface Serial0:23

no ip address

isdn switch-type primary-5ess

isdn not-end-to-end 64

isdn incoming-voice modem

isdn map address isdn plan isdn type unknown

isdn T310 5000

isdn send-alerting

isdn sending-complete

no cdp enable

!

interface Serial1:23

no ip address

isdn switch-type primary-5ess

isdn not-end-to-end 64

isdn incoming-voice modem

isdn map address isdn plan isdn type unknown

isdn T310 5000

isdn send-alerting

isdn sending-complete

no cdp enable

!

interface Serial2:23

no ip address

isdn switch-type primary-ni

no cdp enable

!

interface Serial3:23

no ip address

isdn switch-type primary-ni

no cdp enable

!

interface FastEthernet0

no ip address

no ip mroute-cache

shutdown

duplex auto

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 XXX.XXX.XXX.1

no ip http server

!

!

!

!

call rsvp-sync

!

voice-port 0:D

bearer-cap Speech

!

voice-port 1:D

bearer-cap Speech

!

voice-port 2:D

!

voice-port 3:D

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 1000 pots

incoming called-number T

direct-inward-dial

!

dial-peer voice 597 voip

destination-pattern 011XXXXXXT

progress_ind progress enable 8

voice-class codec 55

session target ipv4:XXX.XXX.XXX.78

tech-prefix 1813#

!

gateway

!

!

line con 0

line aux 0

line vty 0 4

password 12345

login

!

end

3 REPLIES
Cisco Employee

Re: Connection between R2 and ISDN

Please turn on debug isdn q931 on the 5300. The output should lead you in the right direction.....

Community Member

Re: Connection between R2 and ISDN

here is the debug q931 and the cause seem to be:

Cause i = 0x80E0 - Mandatory information element missing

*Feb 25 15:38:51.945: ISDN Se1:23 Q931: RX <- SETUP pd = 8 callref = 0x0045

Bearer Capability i = 0x8090

Standard = CCITT

Transer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xE9808383

Exclusive, Interface 0, Channel 3

Called Party Number i = 0x80, '01155842025426'

Plan:Unknown, Type:Unknown

*Feb 25 15:38:51.965: ISDN Se1:23 Q931: TX -> CALL_PROC pd = 8 callref = 0x8045

Channel ID i = 0xA98383

Exclusive, Channel 3

*Feb 25 15:39:01.973: ISDN Se1:23 Q931: RX <- DISCONNECT pd = 8 callref = 0x004

5

*Feb 25 15:39:01.977: ISDN Se1:23 Q931: RX <- RELEASE pd = 8 callref = 0x0045

*Feb 25 15:39:01.977: ISDN Se1:23 Q931: TX -> RELEASE pd = 8 callref = 0x8045

Cause i = 0x80E0 - Mandatory information element missing

*Feb 25 15:39:01.981: ISDN Se1:23 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x8

045

*Feb 25 15:39:11.673: ISDN Se1:23 Q931: RX <- SETUP pd = 8 callref = 0x0046

Bearer Capability i = 0x8090

Standard = CCITT

Transer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xE9808383

Exclusive, Interface 0, Channel 3

Called Party Number i = 0x80, '01155852436263'

Plan:Unknown, Type:Unknown

*Feb 25 15:39:11.693: ISDN Se1:23 Q931: TX -> CALL_PROC pd = 8 callref = 0x8046

Channel ID i = 0xA98383

Exclusive, Channel 3

*Feb 25 15:39:21.693: ISDN Se1:23 Q931: RX <- DISCONNECT pd = 8 callref = 0x004

6

*Feb 25 15:39:21.697: ISDN Se1:23 Q931: RX <- RELEASE pd = 8 callref = 0x0046

*Feb 25 15:39:21.697: ISDN Se1:23 Q931: TX -> RELEASE pd = 8 callref = 0x8046

Cause i = 0x80E0 - Mandatory information element missing

*Feb 25 15:39:21.701: ISDN Se1:23 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x8

046

Cisco Employee

Re: Connection between R2 and ISDN

Yes, it does. Are you connected to a real 5ESS or something else? I would also suggest adding some sort of g711 codec to the codec class and see if that helps.

326
Views
0
Helpful
3
Replies
CreatePlease to create content