Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Corporate Directory Missing

Good day to All,

Can anybody help me the cause of missing Corporate directory in directories button(7940), i experience this 4 times already, and after i reset the ipphone it backs to normal,

Im afraid this one may become a bigger problem:).

Thank you very much,

Lester

18 REPLIES
New Member

Re: Corporate Directory Missing

Hello again,

4 x means i experience with it in different ip phones

Thanks again

Hall of Fame Super Red

Re: Corporate Directory Missing

Hi Lester,

This is an odd problem isn't it. I would normally ask you to look at the Directory URL in the CCM config and make sure that it is set as the CCM publisher IP address not CCM Publisher Name (DNS issue) but I'm betting on a phone firmware issue. Can you let us know what 7940 firmware version you are running.

Thanks,

Rob

New Member

Re: Corporate Directory Missing

Thanks for your assistance Rob,

my firmware versions

App load ID

P00307020200

Boot Load ID

PC0303010200

Version

7.2(2.0)

Thanks,

lester

New Member

Re: Corporate Directory Missing

Hi Rob,

Sorry i can't find the directory URL in the CCM, where can i find that in the CCM pub or sub, which directories?

Thank you very much

Lester

Hall of Fame Super Red

Re: Corporate Directory Missing

Hi Lester,

I'm pretty sure that this is a Bug in the 7.2 phone firmware. The 7.2 firmware may have been the buggiest (is that a word?) version released ever. I just did a search and there are 384 Bugs related to this firmware with 21 of them related to Directory issues.

I think an upgrade to an 8.x version would be a great plan :)

Directory URL can be found @

Enterprise Parameters Configuration>Phone URL Parameters>URL Directories >http://x.x.x.x/CCMCIP/xmldirectory.asp

Hope this helps!

Rob

New Member

Re: Corporate Directory Missing

Thanks Rob for your help,

If im going to upgrade the firmware, is there any prerequisites, can i ask your configuration assistance? and where to obtain the firware version 8.0?

Thank you,

Lester

Hall of Fame Super Red

Re: Corporate Directory Missing

Hi Lester,

You are always welcome :) There are no prerequisites in this instance as you already have CCM Version that supports these phones. Check the Readme for the desired firmware for further tech notes.

Software Download

Cisco IP Phone Firmware (needs CCO Login)

http://www.cisco.com/cgi-bin/tablebuild.pl/ip-7900ser?psrtdcat20e2

IP Phone documentation;

http://www.cisco.com/univercd/cc/td/doc/product/voice/c_ipphon/english/index.htm

Hope this helps!

Rob

New Member

Re: Corporate Directory Missing

Hi Rob,

Im currently using CCM version 4.1(3)sr1, there should be no problem if im gonna use firmware versions 8.x that support Sip/SCCP Cisco Unified call manager version 4.1 later or earlier, right?, can you help me to choose your specific recommendation firmware?

Also in our university campus we also uses wireless 7920 and 7912. is this upcoming upgrade will not affect the normal operation of my 7920s and 7912s

Thanks for your advice.

Regards,

lester

Hall of Fame Super Red

Re: Corporate Directory Missing

Hi Lester,

No worries :) I think 8.0.7 would be a good choice.

Firmware Versions 8.0(7) for Cisco IP Phone Models 7940 and 7960

The firmware image within the 8.0(7) install program is named P00308000700, and supports the Skinny Client Control Protocol (SCCP) for the following Cisco IP Phone models:

Cisco IP Phone 7940

Cisco IP Phone 7960

This firmware version is supported on Cisco CallManager Release 5.0 and higher, and releases 4.3, 4.2, 4.1, 4.0, and 3.3.

7940 and 7960

earlier than 5.0

You can use the .exe

cmterm-7940-7960-sccp.8-0-7.exe

But I prefer using the .zip and testing the firmware on a few phones first;

Cisco IP Phone Model 7940/7960 Alternate Firmware format

The Cisco IP Phone Model 7940/7960 Firmware version 8.0(7) is also supplied in a zip file, as an alternative in case a Cisco CallManager is not available to run the executable installer program. The name of this file is cmterm-7940-7960-sccp.8-0-7.zip.

After unzipping the firmware files, they should be manually copied to the appropriate directory on the TFTP server.

http://ftp-sj.cisco.com/cisco/voice/ip-7900ser/cmterm-7940-7960-sccp.8-0-7-Readme.htm

These files will only be used for the 7940's and 7960's and will have no affect on the 7920's or 7921's.

Hope this helps!

Rob

New Member

Re: Corporate Directory Missing

Hi Rob,

We r facing the same issue,tried replacing the hostname wth IP and upgrading the FW still issue persist any suggestions.

Regards

Madan

Hall of Fame Super Red

Re: Corporate Directory Missing

Hi Madan,

Can you access the DC Directory via CCM Admin? If you can, can you find the users here using the search function?

Rob

New Member

Re: Corporate Directory Missing

Rob,

I can search thru DC directory i'm seeing all the users.

Madan

Hall of Fame Super Red

Re: Corporate Directory Missing

Hi Madan,

That is a very positive sign!

1. Go to System>Enterprise Parameters Check URL directories.

Does the default URL look like:

http://x.x.x.x/xmldirectory.asp

Rob

New Member

Re: Corporate Directory Missing

Hall of Fame Super Red

Re: Corporate Directory Missing

Hi Madan,

Are you sure? If so you are missing one "/"

Yours: http:/

Should be: http://

Let us know,

Rob

New Member

Re: Corporate Directory Missing

Hi Rob

Sorry we r using // only that was a typing mistake anyways thank you or your prompt replies.we have opened case wth cisco sugesting for a SR upgrade.We has suggested the same to the customer long back.But i dont think its got something do wth SR.FYI we r having 4.1.3 whout any SR

Regards

Madan

New Member

Corporate Directory Missing

Dear Madan,

I also having same issue. after restart phone works fine. Did you get any update from TAC. My phone model is 7940 and app Load ID is P00308010200

Thanks

Nibin

New Member

Corporate Directory Missing

I've been running in to the same problem. We are runnig two CM clusters on 8.6.2 with the same app load of

P00308010200 for the 79X0 phones and the problem randomly pops up. I've read this may have something to do with the switch IOS that the phones are connected to. any thoughts?

6095
Views
23
Helpful
18
Replies
CreatePlease to create content