Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

CRA 3.0(3) and Active Directory

Hello,

I currently have a Call Manager Integrated with Active Directory, this one is creating the users on a Domain Controller, i could install and configure and have autentication with the Domain Controller. I have configured the CTI ports, CTI route point, JTAPI user, JTAPI provider, but the Engine shows the JTAPI service down even when the service is restarted.

Does anybody knows how the JTAPI provider must be configured? I think this could be what im doing wrong and i tried a lot of ways.

I checked the logs and it says that the Ports and Route Points are all on "OOS".

I'll apreciate your help and on advice, Thanks.

Claudio

4 REPLIES
Silver

Re: CRA 3.0(3) and Active Directory

Have you created CTI Port Groups? Try to reload the CTI Port groups.

Check if all the CTI Ports are associated with the jtapi user.

This issue mainly occurs if you have associated set of CTI Ports to jtapi user and then created CTI Port groups and then deassociated some CTI Ports. Try to remove all the CTI Ports from jtapi user association and then do fresh association.

New Member

Re: CRA 3.0(3) and Active Directory

Hi and thanks for your response. I did what you told me, even i deleted CTI Ports, Route Point and JTAPI User, everytime i installed and configured it works fine, but this time the diference is that im working with Active Directory, the JTAPI configuration is the next.

JTAPI Provider: 10.1.1.2 (This is my Active Directory Server)

User: JTAPI

I created JTAPI user on the Call Manager because this is conected to Active Directory, and thats why im pointing to the active directory server. I can see the user on the Call Manager administration. Do this may be the problem or the problem is that it need a FQDN for the user?

Reading the logs i find another two errors, one tolds that cannot create JTAPI provider and the another says Initialization failed because JTAPI login string invalid.

Thank you.

Claudio.

Bronze

Re: CRA 3.0(3) and Active Directory

Hi,

The Jtapi provider should point to the callmanger not to the active directory. If you point the callmanager to active directory, whatever users you create in CCM User Page, gets created in active directory under the User Creation Base mentioned during callmanager installation in active directory configuration window.

Take a look at the below URL, gives details about configuring JTAPI Provider in CRS

http://www.cisco.com/univercd/cc/td/doc/product/voice/sw_ap_to/apps_3_1/english/admn_app/cra_adm/submenu.htm#1079148

Below URL gives more detail on CallManger

http://www.cisco.com/univercd/cc/td/doc/product/voice/c_callmg/3_3/index.htm.

For the second issue, check the jtapi user id and password for JTAPI login string invalid error.

Please make the changes and let me know result.

Regards

Venkat

New Member

Re: CRA 3.0(3) and Active Directory

Hi,

I tried what you told me before without a positive result, this is what i tried before, i'll check it the next week because the servers are on a demo.

Cool links thank you, is a gift that i apreciate it. This forum is a great source of information.

Regards,

Claudio.

120
Views
0
Helpful
4
Replies
CreatePlease to create content