Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CTI route points and ports registration unknown

I have created several ports and route points and there status in is unknown.

Currentl using CM 3.3 no service patch b

i have stopped and started CCM and cti services ..no avial

Deatailed trace,showing me nothing with regards to this issue.

I have CCM detailed and CTI detailed trace on.I also delete all trace files when services are stopped start the services reset route points and ports.But I cantsee anything in trace that point to the issue.

This server is also running ICD IVR 2.2 5 with JTAPI in partial service.

This is obviously due to the route point --port issue.

What is the best way to debug CTI route points and ports ?

This has nothing to do with Jtapi and RM user as they are correctly setup.

I dont care if CRA doesnt work.I want route points and ports to register.

Or at least route points!!!

What information should I be looking for in the trace regards to CTI route points registration unknown.

Is there any documentation that talks about CTI route point -port,debuggging the registration unknown issue i have searched CCO high and low and would love to find some documentation that talks about route point issues such as registration unknown.There is plenty with regards to CRA but that not the issue here.

please lead me to the CTI route point registration unknown troubleshooting URL.

In summary this is a registration unknown issue with CTI route points and Ports with CM 3.3 standard build from cd's new publisher disks 1 7 and CM its a dl380 g2... compaq.

If the ICD IVR never works on same server thats fine i really want to resolve the registartion unknown issue.

Thanks All

Allan

I

6 REPLIES
Cisco Employee

Re: CTI route points and ports registration unknown

You may wnat to start by verifying that the RIS Data Collector service is running on your CallManager. This is the service that gathers and provides registration status. The RISDC traces may provide an indication of the problem.

New Member

Re: CTI route points and ports registration unknown

Yes all services are running this goes without saying.

I will check RISDC trace for errors or registration issues as you have mentioned.

What about a URL that talks about CTI route point problems not pertaining to CRA consecutive ports etc .Is there not one ?

Thanks

Cisco Employee

Re: CTI route points and ports registration unknown

I don't know of any specific docs on CCO regarding troubleshooitn CTI Route Points/Ports.

What do you have the CTI RPs/Ports associated with?

They need to be associated with something, such as your JTAPI user, and when that application comes up and registers with CallManager then your ports should be registered as well.

New Member

Re: CTI route points and ports registration unknown

Yes well what your saying is unless they are associated with a user they will not come up ?

These RP's will be used with a Jtapi screen-pop so I will associate them with this user when I work out the issue.

Though my understanding I should be able to create a CTI rp with lets say a DID number and fwd all to voice mail there is no user associated in this example and it will register with CM no problems.

This is not happening on the particular box at fault.

New Member

Re: CTI route points and ports registration unknown

Rebuilt the CM and all is operational.

Thanks

Allan

New Member

Re: CTI route points and ports registration unknown

Hi,

I had the same problem that the Jtapi sevice is in Partial_Service. Rebooting will not solve this problem. I would suggest the following:

1. Apply SPB to your CM 3.3.

2. make sure your CTI Route Point and all your CTI ports are associated with the JTAPI user, i.e cccjtapi. make sure you double-check the password.

3. If associated, try to unassociate the CTI point and ports, click update, then reassociate them again to the jtapi user. Then try to stop and start the engine.

4. make sure you run the latest JTAPI client. The one that comes with the discs is not good for 3.3. Download the client from 3.3 and run it.

After I tried these steps, it worked for me.

1395
Views
5
Helpful
6
Replies