Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CUE 1.0.1 Recovery from Corrupt Software

When a CUE network module provides the message

"Fatal: Cannot Fix File Systems" at the end of

an unsuccesful boot, the limited documentation

seems to suggest performing a reset on the module

and setup to load the boot helper from tftp.

Once you get that far, what is the next step?

Use of the "software install wizard" doesn't seem to

start anything, especialy any wizard.

Use of the "software install package url "<text>" is

responding with SIOCADDRT:File exists.

So what are the next steps?

Thanks

4 REPLIES
Bronze

Re: CUE 1.0.1 Recovery from Corrupt Software

So youve successfully loaded the boothelper, and you are now doing "s i p u ftp://whatever user blah pass blah" and it fails with that error?

It is supposed to download the package specified, and then reformat and install the software. What exactly do you have entered when you say "".

New Member

Re: CUE 1.0.1 Recovery from Corrupt Software

The command syntax entered would be:

software install package url "ftp://192.168.0.1/cue-vm.1.0.1.pkg" username anonymous password cm

If this is the first attempt, I receive:

umount: /dev/hda1: not mounted

/dev/hda1: clean, 12/2443200 files, 76688/4883752 blocks

Found Valid Partition.

Connecting to host...

curl: (7) Connect failed

ERROR: Host did not respond.

Please check the host ip and try again.

se-172-30-208-3installer#>

The host router can ping the ftp server

crtl-shift-6

R3#ping 192.168.0.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/16 ms

R3#

The FTP server is setup properly.

After the first attempt, the system normally gives:

SIOCADDRT: File exists

So apparently you get one shot at this. . .

I have even tried to get the external ethernet

inteface to get this to work. . .

New Member

Re: CUE 1.0.1 Recovery from Corrupt Software

The glitch was that CUE did not want to perform

FTP to a remote FTP server via VPN; even though

FTP had worked just fine earlier via the remote

FTP server to get 12.2(15)ZJ3 code onto the router

itself.

A local FTP server (located onsite, but still on a

different subnet) worked this out.

All is better.

Bronze

Re: CUE 1.0.1 Recovery from Corrupt Software

Interesting... What kind of vpn is it? The first thing that comes to mind is maybe CUE is not handling the MTU properly.

CUE will be moving to a new journalling filesystem (reiser) that prevents corruption in the first place, so hopefully you wont have to do this again.

142
Views
0
Helpful
4
Replies
CreatePlease login to create content