Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Deleting Route Patterns = Calls Ring, but no answer

CCM 3.3(2)spC, one publisher, two subscribers, centralized and integrated with Unity 3.1.5, Exch 2000 off-box.

A strange, strange problem: I deleted our 9.@ route patterns last night (after I replaced them with specific ones), and once the patterns/devices were reset, calls to voicemail from the PSTN would just ring - callmanager would not forward any calls to our voicemail DN. IP phone to IP phone calls worked the same way; our ring no answer and foward busy are all set to our voicemail DN on all staff IP phones. However, if a user pressed the "Messages" button on their phone, they could check their messages and Unity would act normal. I did check the calling search spaces and partitions, and all was exactly as it has been for the last few months. This only started happening after I wiped out the 9.@ patterns.

Also, when I would call an internal number from an outside number, such as my cell phone, the IP phone would never ring, but I would hear it ring through my cell phone...if that makes sense. If I clicked "Update" on the phone through the CCMAdmin pages, everything goes right back to normal - including the voicemail issue.

Problem is, this is happening to all 1000+ phones at our location...is there an easier way to do this besides going through and pressing "Update" on each individual phone? Anyone have any ideas as to why this happened in the first place? Any help would be greatly appreciated.

TMH

7 REPLIES
Bronze

Re: Deleting Route Patterns = Calls Ring, but no answer

Does a reset help? You can reset the phones in bulk.

New Member

Re: Deleting Route Patterns = Calls Ring, but no answer

That was the first thing I tried - did nothing whatsoever. Only updating the phones works...

TMH

New Member

Re: Deleting Route Patterns = Calls Ring, but no answer

RESET button a phone = no change, but UPDATE button a phone = change? That is bizarre.

H.323 or mgcp gateway? Multiple t1's to the PSTN I assume, if so, are these PRI's as well?

How are the partitions and calling search spaces setup? (are the gateways, voice mail profiles, dn's, voicemail ports, etc in the same partition or in different partitions that are made reachable through CSS's?)

Have you tried resetting the phones through the device pool page to hammer a bunch of devices with a single click? (if reset doesn't work this question is moot)

What do the CM traces show when you are calling in from the outside via a cellphone and hearing ringback, but the IP phone is not ringing?

You say you created 'specific' route patterns and deleted the 9.@ patterns. What do the patterns look like - 9.XXXXXXX for seven digit, or did you get rid of the prefixing altogether, i.e. XXXXXXX or using wildcards to catch certain dialed digit strings. CallManager traces should be very telling, especially on the cellphone scenario explained above.

Beyond that which makes sense, one would have to suspect a database problem that goes away when the individual phone is updated. Does the problem 'return' to a phone that has previously shown this behavior and has been updated before?

Sorry to smoke you with buku questions, but trying to get some background to try and help.

Pat

New Member

Re: Deleting Route Patterns = Calls Ring, but no answer

I agree - it's bizarre, and we just had another occurance of it today.

They're MGCP gateways, 6 PRI's to the PSTN through a 6608 blade on a 6509.

-All staff numbers are inside the AllStaffInternalPT

-All voicemail profiles are in the null partition, along with the voicemail DN's/ports

-The CSS's on all gateways and voicemail ports contain the AllStaffInternalPT

Yep, I tried resetting the device pools, to no avail. I have six phones set up at my desk registered to different CCM's and with different building DN's on them; after a reset, none of them worked.

The CCM traces actually show that it's being forwarded to voicemail - the last redirecting DN is 6700, which is our VM pilot number.

We were only using the 9.@ pattern for our international dialing, so to keep in line with the rest of our dialing patterns, I created the 9.011! in all of the corresponding international access partitions and wiped out the 9.@ pattern. We already had our long distance patterns (9.1[2-9]X[02-9][2-9]XXXXXX) and our local patterns (9.1847XXXXXXX - we're in ten digit dialing) in the CCM. There really was no reason to keep the 9.@ in.

I had considered a database problem...and no, I haven't seen a phone problem return to a phone once it's been updated, that's what makes this so puzzling. The only thing I can think of is that when I yanked out the 9.@, there was a pattern in there that was being used that I wasn't aware of. I've checked the trace files for digit analysis, seeing which patterns are being used when digits are being dialed, but can find no other pattern.

I am just as puzzled as you are...any ideas?

TMH

Silver

Re: Deleting Route Patterns = Calls Ring, but no answer

Restart the callmanager service? For some reason when playing with route patterns, VM ports and certain other things, it doesn't get changed in memory, cache or something. -- At least in my experience. Restarting the CCM service has made bizzare things clear up for me.

New Member

Re: Deleting Route Patterns = Calls Ring, but no answer

Good point, the same has worked for me in the past...but we actually restarted all of our CCM servers at one point, and it had no effect on the problem whatsoever. I'm more inclined to believe it might be a database issue, since we're also experiencing internal caller ID showing up as "Private" on some phones. Maybe it's time I start considering an upgrade to 3.3(3)?

TMH

Re: Deleting Route Patterns = Calls Ring, but no answer

I found the following bug..

CSCdy82298

...snip

2. route pattern change won't take effect until call

manager server reboot.

This one seems related to database replication

...snip

Maybe you hit this one..

Cheers,

Martin

117
Views
0
Helpful
7
Replies
CreatePlease to create content