Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Deleting scripts in IPCC Enterprise

I have been able to delete scripts created in the script editor for quite some time now. Now all of a sudden I cannot delete a script. I get this message from the script editor. “The Master Script cannot be deleted because it is referenced by a script.” I checked all my other scripts and I deleted every past version of the other scripts I have and it still won’t let me delete them.

3 REPLIES
Bronze

Re: Deleting scripts in IPCC Enterprise

Hi,

When you say you deleted the past version of the scripts, did you delete completely ? I mean once you delete the script in Script Explorer, the script still exists as a deleted object, in order to delete it completely, follow the steps

1. Start Configuration Manager from the ICM Admin Workstation and choose Configure ICM from the drop-down box. (For ICM version 4.5 and later, choose Configure ICM/ICR from the ICM/ICR Admin Workstation group).

2.Choose Administration > Deleted Objects, highlight the script in the Tables with Deleted Records box.

3. Highlight the name of the script in the Deleted Records of the "Script" Table box.

4. Click the Delete Permanently button.

Let me know if this was the case, or if you have already done this.

Hope it helps,

Aslam.

New Member

Re: Deleting scripts in IPCC Enterprise

Thanks for the reply. I actually found that last night after looking in every option of the configuration menu. That in fact did work. I deleted the objects permanently and it allowed me to delete the scripts finally.

New Member

Yes, that solved the problem.

Yes, that solved the problem.

524
Views
0
Helpful
3
Replies
CreatePlease login to create content