Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DHCP and Aux/Native VLANs on CCM

I am running DHCP for a 2 subnet lab environment. I have a 36xx router with a 4000 switch serving my Phones, using the PC Port for computer access. I have my 4000 ports setup to use Native VLAN 31 and AuxVlan 30, Ihave two DHCP scopes setup on my CCM, one for each subnet, and the helper address configured in my router. My phones register correctly into my .30.x Subnet, but my PC's are also registering to the same subnet instead of the .31.x.

Anybody have an idea what I am missing? Thanks.

5 REPLIES
New Member

Re: DHCP and Aux/Native VLANs on CCM

mak sure that the port is showing up in both the data vlan and aux vlan when doing a "show vlan"

also make sure that your vlan interfaces on your router are setup properly

if all else fails - put static IPs on devices and troubleshoot from there

New Member

Re: DHCP and Aux/Native VLANs on CCM

Port is showing in both VLAN's. On VLAN 31 (data), I have a helper address pointing to my CCM which resides in the 30 subnet. I did find that the switch port I was working from did not have the 31 VLAN configured, and after setting that "correctly", any DHCP resolution I was getting from that port went away. I have been over the config on the switch and the router and everything "looks fine" but it still not working. Anybody have a working model of this that can post snip of their config?

New Member

Re: DHCP and Aux/Native VLANs on CCM

Sean I can give you a snippet. I have resolved this on both the 4003 and 4006. Which model are you using?

New Member

Re: DHCP and Aux/Native VLANs on CCM

I have one each here, currently trying to resolve on the 4003. Thanks!

New Member

Re: DHCP and Aux/Native VLANs on CCM

Here you go Sean. Any additional questions about this particular config, please contact via email. Notice the 4003 uses one subinterface rather than two.

Catalyst 4006 trunked with 3660

interface FastEthernet0/0

Description Trunk to local LAN

ip address 10.10.96.1 255.255.255.0

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.10.96.1

!

interface FastEthernet0/0.1

Description DATA VLAN

encapsulation dot1Q 5 native

ip address 10.10.90.1 255.255.255.0

ip helper-address 10.10.90.20

!

interface FastEthernet0/0.2

Description VOICE VLAN

encapsulation dot1Q 95

ip address 10.10.95.1 255.255.255.0

ip helper-address 10.10.125.10

Catalyst 4003 trunk with 3640

interface Ethernet0/0

Description DATA Vlan

ip address 10.10.115.1 255.255.255.0

ip helper-address 10.10.115.20

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.10.115.1

!

interface Ethernet0/0.1

Description VOICE VLAN

encapsulation dot1Q 118

ip address 10.10.118.1 255.255.255.0

ip helper-address 10.10.125.10

121
Views
0
Helpful
5
Replies
CreatePlease login to create content