Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

dhcp on cm6.01

am starting a voice lab

-with cm6.01

-4 ip phones

-the cm6 serves as tftp/dhcp

somehow my phones are not getting thru the dhcp server. already configured/activated the ff

-dhcp monitoring service on serviceability

-tftp service

-configured system/dhcp

-configured system/dhcp subnet

my sw configuration is below

interface FastEthernet0/1

switchport access vlan 100

switchport voice vlan 100

spanning-tree portfast

!

interface FastEthernet0/2

switchport access vlan 100

switchport voice vlan 100

spanning-tree portfast

!

interface FastEthernet0/3

switchport access vlan 100

switchport voice vlan 100

spanning-tree portfast

!

interface FastEthernet0/4

switchport access vlan 100

switchport voice vlan 100

spanning-tree portfast

!

any way i could see logs on phones? or any suggestion how to solve this pls..

many thx

5 REPLIES
Cisco Employee

Re: dhcp on cm6.01

is CUCM and phones in same subnet???

if not configure the ip-helper address for DHCP relay

check routing

HTH

java

if this helps, please rate

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
Community Member

Re: dhcp on cm6.01

iam using an old layer2 3524. thats why in my config i used same vlan id for voice and data..

Community Member

Re: dhcp on cm6.01

Try just setting all of your ports as trunks on that same VLAN. (Since it is a lab setup, just to see if it will get working....)

Re: dhcp on cm6.01

May have something to do with the fact that your using the same vlan for data and voice, I would change this.

Are there any other dhcp server's in the network?

Have you done any dhcp debugs on the switch?

hth, please rate

Regards,

Justin

Community Member

Re: dhcp on cm6.01

What I have ran across in the past is that you must use a helper address on the VLAN interface. In your case the command could look similiar to:

interface Vlan100

description Voice VLAN

ip address 10.1.1.1 255.255.255.0

ip helper-address 10.10.10.10

The helper address is usually the address for he DHCP server.

Good luck,

Lee

155
Views
0
Helpful
5
Replies
CreatePlease to create content