Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Dial-Peer configuration

Hello Guys,

When I dial our main phone number (212-586-1780) It rings only once and my phone shows it's connected but on the other end nobody hears the phone ringing. This is our main number for the outside callers and has to ring on the extension 3705 which is used only by internal callers. I need to bind the above 10 digits number to 3705. I know it's kind of confusing and That's why I need your help. The CMM is in Boston and there's a router in NY. The extension 3705 is configured in CCM and shows registered

Here's the config for the router in NY:

interface FastEthernet0/0

ip address 172.16.XXX.254 255.255.255.0

ip helper-address 172.16.XXX.11

ip helper-address 172.16.XXX.12

speed auto

h323-gateway voip bind srcaddr 172.16.XXX.254

!

interface Serial0/0

ip address 172.16.XXX.46 255.255.255.252

service-policy output voice

load-interval 30

shutdown

service-module t1 clock source internal

!

interface Ethernet1/0

ip address dhcp

shutdown

half-duplex

!

router eigrp 100

network 172.XXX.0.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.XXX.1

no ip http server

!

control-plane

!

!

voice-port 2/0

description #### SRST Backup Lines ####

!

voice-port 2/1

description #### SRST Backup Lines ####

!

!

dial-peer cor custom

!

!

!

dial-peer voice 101 pots

preference 1

destination-pattern 9T

port 2/0

!

dial-peer voice 102 pots

preference 2

destination-pattern 9T

port 2/1

!

dial-peer voice 103 pots

preference 3

destination-pattern 9T

!

dial-peer voice 104 pots

preference 4

destination-pattern 9T

!

!

call-manager-fallback

max-conferences 4

limit-dn 7960 3

ip source-address 172.16.XXX.254 port 2000

max-ephones 24

max-dn 120

Thanks,

13 REPLIES
Blue

Re: Dial-Peer configuration

If the call comes in on a POTS line connected to voice port 2/0 you would need this config:

dial-peer voice 201 voip

destination-pattern 3705

session target ipv4:172.X.X.X (your CCM subscriber)

voice-port 2/0

connection plar 3705

The PLAR command will create a ringdown to 3705, and the VOIP peer will direct the call to the Call Manager and ring the phone.

Your Call Manager will also need to have this router configured as a H323 gateway, which you probably already have in place.

Please rate helpful posts.

New Member

Re: Dial-Peer configuration

Thanks for the reply. I followed the instruction but it still does the same. It rings once and it shows like it's connected on my phone here in Boston but nobody in NY hears the phone ringing. How the dialed number(212-586-1780)is going to be send to 3705? I don't see any configuration for that.

Thanks,

Blue

Re: Dial-Peer configuration

Is that the correct port?

Do a show voice call summary on that router when you call to see which port is answering.

Perhaps both ports are set up by the phone company as a multiline hunt group, and you need the PLAR command on both ports.

New Member

Re: Dial-Peer configuration

The show voice call summary shows nothing. It looks like no call is coming in. Both ports are in onhook stat.

Thanks,

Blue

Re: Dial-Peer configuration

You need to work with the phone company to find out where the call is being sent. The one ring connect is consistent with a router FXO port that is not configured.

You mentioned a CMM. Is is possible the call is going to a PRI?

New Member

Re: Dial-Peer configuration

My question is where in the configuration, am I binding the 212-586-1870 to 3705? I don't see any coniguration for that? Don't I need to tell the router that send the call with the destination number 212-586-1870 to the 3705?

Thanks,

Blue

Re: Dial-Peer configuration

The mapping is the connection plar 3705. That works for a POTS line plugged into a router. The router will answer the ring and forward the call to 3705.

If the call comes into a PRI the phone company sends you called number digits, and you would need to translate those digits (or have them send 3705). That would be handled by the Call Manager.

You can't configure anything until you know what device is answering the call. Just to be clear, the 212-586-1870 is dialed by people out in the world, routed to one of your sites by the phone company, and you want internal phone 3705 to ring?

New Member

Re: Dial-Peer configuration

Thanks for your precious help. Tomorrow, I will call the telco to find out where do they send the call. Is there any debug commands that would help me to resolve this issue with tleco? The router is a Cisco 1760 with IOS version 12.1.

Thanks again,

Blue

Re: Dial-Peer configuration

You can use debug vpm signal to monitor the signalling on the FXO ports.

New Member

Re: Dial-Peer configuration

Hi again,

I tried to use the "CSIM Start" command to see if the config is correct. This is the output of the error message:

TG-NYC-GW01#csim start 96178692565

csim: called number = 96178692565, loop count = 1 ping count = 0

csim err csimDisconnected recvd DISC cid(26)

csim info: cid(26), state(0), cause(34)

csim: loop = 1, failed = 1

csim: call attempted = 1, setup failed = 1, tone failed = 0

What does this mean? Does it mean the config in the router is not right or the issue is in Telco side?

Thanks,

Blue

Re: Dial-Peer configuration

That test call should work with your 9T destination pattern and send the call out the FXO. The debug vpm signal should show something. The easiset way to test the telco line is to unplug the cable from the router and plug it into a phone and place the same call.

New Member

Re: Dial-Peer configuration

Could you please help me with this one?

I dial 212-798-5086 and get a message stating " your call did not go through". This is a DID number. I can dial 4 digits from Boston to NY but not 10 digites. The extensions are already created on the CMM. Here's the configuration for the Gateway:

control-plane

!

!

voice-port 2/0

connection plar 3705

description #### SRST Backup Lines ####

!

voice-port 2/1

connection plar 3705

description #### SRST Backup Lines ####

!

!

dial-peer cor custom

!

!

!

dial-peer voice 101 pots

preference 1

destination-pattern 9T

direct-inward-dial

port 2/0

!

dial-peer voice 102 pots

preference 2

destination-pattern 9T

port 2/1

!

dial-peer voice 103 pots

preference 3

destination-pattern 9T

!

dial-peer voice 104 pots

preference 4

destination-pattern 9T

!

dial-peer voice 201 voip

destination-pattern 3705

session target ipv4:172.16.XXX.253

incoming called-number .

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

!

call-manager-fallback

max-conferences 4

limit-dn 7960 3

ip source-address 172.16.XXX.254 port 2000

max-ephones 24

Thanks,

New Member

Re: Dial-Peer configuration

Hi Bahman,

I think the command you're looking for is num-exp, which you can use to map numbers. In my example below the Telco only sends the last 3 digits of the external number (but it depends on what you've requested; it could be more or it could be the full dialled number)

Here's an example

num-exp 047 6400

num-exp 400 6400

num-exp 401 6401

047 is the last 3 digits of the main number and goes to extension 6400

Also, I think you might an incoming dial-peer like the one below (or at least the "direct-inward-dial")

dial-peer voice 10 pots

description Reverse match peer

incoming called-number .

no digit-strip

direct-inward-dial

port 0/0/0

Good Luck

270
Views
15
Helpful
13
Replies
CreatePlease login to create content