Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

DID not working with CM 3.2 and VG200/E1

I'm in real big trouble. I can't get DID working.

We have installed a CM 3.2 cluster and have 2 VG200 with E1 interface for ISDN access.

Today i found out, that DID is not working correctly. If i make a call from a IP-Phone, the number is send as a block and DID is working perfectly.

But that's normal for Germany.

In Germany we use normaly Overlap Sending and Receiving. Any DID digit send one by one.

This is the debug output from "debug isdn q931":

5d01h: ISDN Se1/0:15: RX <- SETUP pd = 8 callref = 0x001C

5d01h: Bearer Capability i = 0x9090A3

5d01h: Channel ID i = 0xA98381

5d01h: Progress Ind i = 0x8283 - Origination address is non-ISDN

5d01h: Calling Party Number i = 0x00A3, Plan:Unknown, Type:Unknown

5d01h: Called Party Number i = 0xC1, '28032', Plan:ISDN, Type:Subscriber(local)

5d01h: ISDN Se1/0:15: TX -> RELEASE_COMP pd = 8 callref = 0x801C

5d01h: Cause i = 0x8081 - Unallocated/unassigned number

The caller dialed 2803-2345 and not 2803-2.

How can i get DID working? I tried already adding following statements to the dial peer

dial-peer voice 9991015 pots

incoming called-number 2803....

direct-inward-dial

But it did not change! Very bad for me!! ;)

What needs to be done, to get DID working?

Cu

-----------------------------------------------------

the current config:

version 12.2

no parser cache

no service single-slot-reload-enable

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname mdhl-vg200-1

!

logging rate-limit console 10 except errors

!

voice-card 1

!

ip subnet-zero

!

no ip dhcp-client network-discovery

mgcp

mgcp call-agent 172.17.12.9 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode cisco

mgcp sdp simple

mgcp package-capability rtp-package

mgcp package-capability sst-package

no mgcp timer receive-rtcp

no mgcp explicit hookstate

call rsvp-sync

isdn switch-type primary-net5

!

!

!

!

!

ccm-manager redundant-host 172.17.12.10

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 172.17.12.9

ccm-manager config

!

controller E1 1/0

pri-group timeslots 1-31 service mgcp

!

!

interface FastEthernet0/0

ip address 172.17.12.7 255.255.254.0

duplex auto

speed auto

!

interface Serial1/0:15

no ip address

no logging event link-status

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.17.12.1

no ip http server

!

!

voice-port 1/0:15

!

dial-peer voice 9991015 pots

application mgcpapp

port 1/0:15

!

!

line con 0

line aux 0

line vty 0 4

login

line vty 5 15

login

!

end

11 REPLIES
Cisco Employee

Re: DID not working with CM 3.2 and VG200/E1

Do you have the OverlapReceivingForPriFlag service parameter for CCM set to True? This is a callmanager service parameter.

Thank you,

-Mckee

New Member

Re: DID not working with CM 3.2 and VG200/E1

Yes. I set this parameter to True, reseted the gateways, but nothing changed.

I can't find any documentation, explaining what is needed to get DID working.

Would it be possible, that i need to change something more?

Cu

New Member

Re: DID not working with CM 3.2 and VG200/E1

OK!!!!!!!!!!!!!!!!!!!!!!!!!!!

I got it working!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

:))))

There was a translation pattern missing. You need to add translation pattern for the complete number.

1234.XXXX

and discard pre dot.

After that everything is working.

Cu

Bronze

Re: DID not working with CM 3.2 and VG200/E1

interface Serial1/0:15

no ip address

no logging event link-status

"isdn overlap-receiving t302 2000"

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

Try it with the Command above.

Regards

Mehmet

New Member

Re: DID not working with CM 3.2 and VG200/E1

I does not help. It did not change something.

Thanks for you help.

Cu

New Member

Re: DID not working with CM 3.2 and VG200/E1

Hello,

I found this information that you maybe able to use in your configuration problem. see if there is policy setting that are set that you are over looking.

Modular QoS Command-Line Interface Classification and Marking Example

The recommended classification and marking method is the Modular QoS Command-Line Interface (Mod QoS CLI, or MQC) feature, a template-based configuration method that separates the classification from the policy, allowing multiple QoS features to be configured together for multiple classes. You use a class map to classify traffic based on various match criteria and a policy map to determine what should happen to each class. Then you apply the policy to incoming or outgoing traffic on an interface using the service-policy interface configuration command. The following configuration example shows how to use Modular QoS to classify and mark packets:

Configuration Example 4: Classification and Marking Using MQC

access-list 100 permit udp any any range 16384 32767

access-list 100 permit tcp any any eq 1720

!

class-map voip

match access-group 100

!

policy-map mqc

class voip

set ip precedence 5

<<#various other QoS commands>>

class class-default

set ip precedence 0

<<#various other QoS commands>>

!

interface Ethernet0/0

service-policy input mqc

In this example, any traffic that matches access list 100 will be classified as class voip and set with IP Precedence 5—meaning that the three most significant bits of the IP TOS byte are set to 101. Access list 100 here matches the common UDP ports used by VoIP and H.323 signaling traffic to TCP port 1720. All other traffic is set with IP Precedence 0. The policy is called mqc and is applied to incoming traffic on Ethernet interface 0/0.

The article below may help.

http://www.cisco.com/univercd/cc/td/doc/cisintwk/intsolns/qossol/qosvoip.htm#xtocid63559

Regards

Fred Sweezer Sr.

New Member

Re: DID not working with CM 3.2 and VG200/E1

Nice to know, but not helpful with my problem! ;)

Cu

Bronze

Re: DID not working with CM 3.2 and VG200/E1

Which version of the IOS is it ?

I think it is 12.2.8T (I have heard it cant overlap receiving,but i am not sure).

Regards

mehmet

New Member

Re: DID not working with CM 3.2 and VG200/E1

I'm using 12.2.2(XN). I tseted also other version, but i had the most success with 12.2.2(XN). This version seems to have the best support for callmanager.

Or does someone have something against 12.2.2(XN).

Cu

Bronze

Re: DID not working with CM 3.2 and VG200/E1

Hi,

I had the same Problems with 12.2.2(XN) on isdn BRI.

I have now installed the 12.2.8T.

Regards

Mehmet

New Member

Re: DID not working with CM 3.2 and VG200/E1

Ok, but if i see that you use ISDN BRI, than you are not using MGCP. Right?

As i know, the Callmanager does not Support MGCP with ISDN BRI.

I think my Problem is a Callmanager Problem. Any L3 signaling is done on the callmanager(ISDN PRI Backhaul). So i think it must be a Callmanager Problem.

Let's see .... :)

Cu

125
Views
0
Helpful
11
Replies
CreatePlease to create content