Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

drops in my llq queue

hi,

my problem:

i configured a llq with 85 kb/s for voip traffic - but i have drops within this queue.

the link is a 384kb/s point-point link.

if i have drops in the llq-queue: dies this automaticly mean the voip-traffic

is greater than my 85 kb/s ???

how can i calculate the "Burst" after the "priority 85" keyword - could this be a

reason for the droped packet ???

thanks for answer !

r-wienstr1#pvc 42

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

DLCI = 42, DLCI USAGE = LOCAL, PVC STATUS = STATIC, INTERFACE = Serial0/0

input pkts 73429 output pkts 72900 in bytes 13316690

out bytes 12682375 dropped pkts 0 in pkts dropped 0

out pkts dropped 745 out bytes dropped 201392

late-dropped out pkts 745 late-dropped out bytes 201392

in FECN pkts 0 in BECN pkts 0 out FECN pkts 0

out BECN pkts 0 in DE pkts 0 out DE pkts 0

out bcast pkts 0 out bcast bytes 0

5 minute input rate 4000 bits/sec, 7 packets/sec

5 minute output rate 2000 bits/sec, 8 packets/sec

pvc create time 23:20:22, last time pvc status changed 23:20:16

service policy policy_384

Serial0/0: DLCI 42 -

Service-policy output: policy_384

Class-map: dedect_voip (match-any)

58979 packets, 12003404 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: ip precedence 5

58979 packets, 12003404 bytes

30 second rate 0 bps

Queueing

Strict Priority

Output Queue: Conversation 40

Bandwidth 85 (kbps) Burst 10000 (Bytes)

(pkts matched/bytes matched) 58979/12003404

(total drops/bytes drops) 745/201392

Class-map: dedect_premium (match-any)

84 packets, 4368 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: ip precedence 4

!

!

class-map match-any dedect_premium

match ip precedence 4

class-map match-any dedect_voip

match ip precedence 5

class-map match-any dedect_gold

match ip precedence 3

class-map match-any dedect_silver

match ip precedence 2

!

!

policy-map policy_384

class dedect_voip

priority 85 10000

class dedect_premium

bandwidth percent 30

class dedect_gold

bandwidth percent 20

class dedect_silver

bandwidth percent 10

class class-default

fair-queue

!

!

interface FastEthernet0/0

no ip address

speed 100

full-duplex

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 10.20.205.250 255.255.255.0

ip policy route-map set_ip_prec

!

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address 10.20.253.102 255.255.255.248

ip policy route-map set_ip_prec

!

!

interface Serial0/0

description Int S0/0 - Verbdg. zum BR-LinzLand

bandwidth 384

ip address 10.20.255.50 255.255.255.252

encapsulation frame-relay IETF

load-interval 30

no keepalive

frame-relay traffic-shaping

frame-relay map ip 10.20.255.49 42

frame-relay interface-dlci 42

class 384k

!

!

map-class frame-relay 384k

frame-relay cir 365000

frame-relay bc 3000

frame-relay be 0

frame-relay mincir 365000

service-policy output policy_384

frame-relay fragment 400

!

route-map set_ip_prec permit 10

match ip address voip

set ip precedence critical

!

route-map set_ip_prec permit 20

match ip address premium

set ip precedence flash-override

!

route-map set_ip_prec permit 30

match ip address gold

set ip precedence flash

!

route-map set_ip_prec permit 40

match ip address silver

set ip precedence immediate

!

route-map set_ip_prec permit 50

set ip precedence priority

!

!

ip access-list extended gold

permit tcp any range 8001 8005 any

permit tcp any any range 8001 8005

permit udp any eq 6502 any

permit udp any any eq 6502

permit tcp any eq 8100 any

permit tcp any any eq 8100

permit tcp any eq login any

permit tcp any any eq login

permit ip host 10.18.19.39 any

ip access-list extended premium

permit tcp any range 13301 13364 any

permit tcp any any range 13301 13364

permit tcp any eq 1478 any

permit tcp any any eq 1478

permit tcp any eq 1477 any

permit tcp any any eq 1477

permit tcp any eq 1998 any

permit tcp any any eq 1998

permit tcp any range 7000 7025 any

permit tcp any any range 7000 7025

ip access-list extended silver

permit tcp any eq 8080 any

permit tcp any any eq 8080

permit tcp any eq www any

permit tcp any any eq www

ip access-list extended voip

permit udp any range 4352 13055 10.17.4.0 0.0.0.255

permit udp any 10.17.4.0 0.0.0.255 range 4352 13055

!

2 REPLIES
Bronze

Re: drops in my llq queue

Yes, it seems like you are exceeding your 85kbps and that is the reason for the drops. I don't think that the burst is the problem. I would suggest that you up the 85kbps to something higher. You won't be setting that bandwidth aside, during normal operations, queueing only goes into affect once the pipe starts getting full. Plus, depending on what codec you are using you can fill that 85kbps up pretty fast.

Rick

Community Member

Re: drops in my llq queue

Here's a link on LLQ in a frame environment that might be helpful:

http://www.cisco.com/warp/public/788/voice-qos/voip-ov-fr-qos.html

99
Views
4
Helpful
2
Replies
CreatePlease to create content