Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

DTFM tones echoing to an Octel

I have an Octel VM system connected to a vg248. When some one calls into the Octel from the PSTN (Via a MGCP gateway/PRI) they get the Octel prompt and the enter their mail box number. When they type in the mailbox number the digits get echoed. 2346 ends up being 2233 to the octel and the user get kicked out because it's an invalid mail box.

This same thing works fine from an IP phone on the same network.

Am I missing some type of DTMF command in my MGCP gateway?

  • Other Collaboration Voice and Video Subjects
2 REPLIES
Cisco Employee

Re: DTFM tones echoing to an Octel

There were some problems in early IOS MGCP code, where it would send DTMF digits both inband and out-of-band. If you're running earlier code, you can try configuring no mgcp dtmf-relay voip codec all mode out-of-band but the command syntax could vary based on what version you are running. Alternatively, you could upgrade to something more recent (e.g. 12.2.11T series or 12.2.13T series) and not have the problem at all.

New Member

Re: DTFM tones echoing to an Octel

I've been experiencing a similar issue on a 3640 running 12.2(15)T1.

There are 12 FXO ports in this router and outbound calls work fine but when I hit any kind of device looking for DTWMF (AA, Directory Assistance, etc.) I get echoed DTMF tones on the IP phone I'm calling out from. For example, if I press '1', I hear the tone twice. The destination appears to not hear the tones at all (i.e there is no response). Any ideas?

97
Views
0
Helpful
2
Replies