Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

DTMF Relay outbound calls

Hi,

i've a problem,

in my dial-peer XXX voip i've configured the DTMF-Relay, so the incoming digit will be relayed by the voice gateway, but on the outbound calls, there is no possibility to configure the dtmf-relay so when i call an ivr my digits are not relayed by the router....how can i configure this parameter for outbound calls?

P.S. I'm using MGCP between voice gateway and callmanager 4.1(3)

BR,

Claudio

2 REPLIES
Silver

Re: DTMF Relay outbound calls

How is the gateway connected to the IVR? Is it using FXS/FXO or T1 lines? If yes, then you don't need dtmf-relay for outbound calls as the dtmf-relay applies only to the VoIP side of the call.

Also since you are using MGCP, you need to use the following command for DTMF relay on the VoIP side

mgcp dtmf-relay voip codec all mode cisco

Regards,

Anup

New Member

Re: DTMF Relay outbound calls

The IVR is an external systems, for example when i call the McAfee company there is an IVR the aswer the call.

My router is connected to Telecom with an ISDN Bri.

So i need the dtmf relay for the outbound calls.

I've configured this:

mgcp dtmf-relay voip codec all mode cisco

in my router, but it seems, it doesn't works.

This is my router configuration:

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname XXXXXX

!

boot-start-marker

boot system flash:c2801-spservicesk9-mz.123-14.T6.bin

boot-end-marker

!

logging buffered 51200 warnings

!

aaa new-model

!

!

aaa authentication login default group radius local

!

aaa session-id common

!

resource policy

!

clock timezone Milano 2

clock summer-time CET recurring

network-clock-participate wic 3

network-clock-select 1 BRI0/3/0

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

!

!

ip domain name XXXXXXXXXXXX

ip name-server XXXXXXXXXXXXX

no ftp-server write-enable

isdn switch-type basic-net3

isdn logging

!

voice-card 0

!

!

!

voice service voip

!

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g711alaw

!

!

!

!

!

!

!

!

!

username XXXXXXXXXXXX privilege 15 secret 5 XXXXXXXXX

!

!

!

!

interface FastEthernet0/0

no ip address

speed 100

full-duplex

!

interface FastEthernet0/0.100

description *** Link to 2950 Fa0/23 ***

encapsulation dot1Q 100

ip address XXXXXXXXX XXXXXXXXXXX

no snmp trap link-status

no cdp enable

!

interface FastEthernet0/0.130

description *** Link to 2950 Fa0/23 ***

encapsulation dot1Q 130

ip address XXXXXXXXXXXXXX XXXXXXXXXXXXXXX

no snmp trap link-status

no cdp enable

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface BRI0/3/0

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

isdn incoming-voice voice

isdn bind-l3 ccm-manager service mgcp

isdn sending-complete

!

interface BRI0/3/1

no ip address

shutdown

isdn switch-type basic-net3

isdn point-to-point-setup

!

ip classless

ip route 0.0.0.0 0.0.0.0 XXXXXXXXXXXXXX

!

!

no ip http server

no ip http secure-server

!

logging trap debugging

logging facility local1

logging XXXXXXXXXXXXXXXX

no cdp run

!

!

radius-server host XXXXXXXXXXXX auth-port 1812 acct-port 1813

radius-server key 7 XXXXXXXXXXXX

!

control-plane

!

!

!

voice-port 0/2/0

!

voice-port 0/2/1

!

voice-port 0/3/0

output attenuation 10

echo-cancel coverage 32

no vad

compand-type a-law

cptone IT

!

voice-port 0/3/1

!

ccm-manager mgcp

!

mgcp

mgcp call-agent XXXXXXXXX service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode cisco

mgcp validate domain-name

mgcp fax t38 inhibit

!

mgcp profile default

!

!

!

dial-peer voice 100 pots

description *** Gestione Chiamate Voce in Uscita ***

preference 1

service mgcp

destination-pattern .

port 0/3/0

!

dial-peer voice 555 voip

description *** Gestione Chiamate Voce in Ingresso ***

preference 1

service mgcp

destination-pattern XXXXXXXX

progress_ind setup enable 3

session target ipv4:XXXXXXXXXXXX

incoming called-number .

dtmf-relay h245-alphanumeric

!

dial-peer voice 556 voip

description *** Gestione chiamate Verso FAX ***

preference 1

service mgcp

destination-pattern XXXXXXXXXX

translate-outgoing called 1

modem passthrough nse codec g711ulaw

session target ipv4:XXXXXXXXX

incoming called-number .

dtmf-relay h245-signal h245-alphanumeric

fax rate disable

no vad

!

banner motd ^CC

^C

!

line con 0

line aux 0

line vty 0 4

privilege level 15

transport input ssh

line vty 5 15

privilege level 15

transport input ssh

!

ntp clock-period 17179212

ntp server XXXXXXXXXXXX

end

------------------------

BR,

Claudio

255
Views
0
Helpful
2
Replies
CreatePlease to create content