Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Error in adding subscriber after changed Exch srv.

Hi,

I got new exch2003 which I had linked up with my Unity 4.0.3 server. The services all started okay but havening error finding the new exch2003 server mailstore.

The error is as below

Error fetching MailStore list (for server RAD_PROD_EXCH).

hr=0x8004010F

Check that the AVDSGlobalCatalog is registered and running.

Please see your system administrator for more details.

The old mailstore is "RAD_PROD_EXCH" which is already took out from the network. My question is how do I re-associate the new mailstore we any tool without re-installing? I have tried AdvancedSettingTool.exe, PermissionWizard Tool, and Service Configuration Wizard tool. All in vain trying to re-associate to the new ex2003 server. Please help!

Thanks,

Steven

5 REPLIES
Cisco Employee

Re: Error in adding subscriber after changed Exch srv.

I'm assuming you ran the Message Store Configuration wizard when you moved the message store, right? If you did this and ran the permissions wizard (which grants SA/RA rights on each mailstore found individually for the message store facing account) you should be good to go.

You might want to run through the chapter on changing the Exchange 2003 partner server in the Unity Modification and Upgrade guide - it'll be on CCO soon but a draft of it is available on www.CiscoUnityTools.com here:

http://www.ciscounitytools.com/Documents/Cisco%20Unity%20Modification%20and%20Upgrade%20Guide%20(With%20Microsoft%20Exchange).pdf

I'd run through that real quick and make sure you didn't miss anything along the way.

New Member

Re: Error in adding subscriber after changed Exch srv.

Hi,

Thanks for your advise. It is definitely getting somewhere here. However, the old domain server which we used are no longer in the network hence I ran into error below

"Cisco Unity has NOT been properly installed

The following error(s) have occurred

- Failed getting container for new users for domain radiance.com"

Seems like the old domain is still associate with Unity 4.0.3. Is there any ways we can try instead of uninstalling Unity and reinstall again?

Thanks again,

Steven

Cisco Employee

Re: Error in adding subscriber after changed Exch srv.

Yes - again, check the Unity Modification and Upgrade guide here:

http://www.ciscounitytools.com/Documents/Cisco%20Unity%20Modification%20and%20Upgrade%20Guide%20(With%20Microsoft%20Exchange).pdf

There's a chapter called "Changing which domain controller Unity monitors without failover" which is probably where you want to start... You'll also want to check out changing the global catalog server if that applies here.

New Member

Re: Error in adding subscriber after changed Exch srv.

Hi lindborg,

Thanks for your kind pointers. The steps in the topic "Changing Which Domain Controller Cisco Unity Monitors Without Failover"

The domain server name was changed and restarted the AvDSAD services a few times. It managed to get started on this service with no problem.

However, after I ran into Step 17 which asked all subscribers and distribution ObjectChangedID value in Cisco Unity Database to 0. Basically I tried to execute the "OSQL -E" command in the command prompt. It can't get the Avcsmgr started. So now the Unity server can't be started and I can't find out how this step actually made it so. Is there a way to reverse this process? I think the draft copy of the document is very useful although there are some hiccups here and there.

Please help!

Steven

Cisco Employee

Re: Error in adding subscriber after changed Exch srv.

I'm a little confused by your statement "I tried to execute the OSQL -E command in the command prompt. It can't get the AvCsMgr started"

I don't understand what you're saying there - the OSQL is just an SQL command shell that lets you issue TSQL commands - it has nothing to do with starting AvCsMgr at all - and setting the object change Id to 0 for all objects will have no impact on Unity starting or not - this has to do with Unity pushing or pulling data to/from the directory when there's a change. I just issued the commands exactly as they are documented and it worked flawlessly as it should.

There's nothing wrong with the steps in there as documented - there's no "hiccups" in those steps, they are accurate.

If AvCsMgr isn't comming up it has nothing to do with the SQL commands as documented. Check the application event log for errors - that's always the first place to start with such problems.

274
Views
0
Helpful
5
Replies
CreatePlease to create content