Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Fax issues

I have an Ata 186 with a fax machine installed i have configured the gateways etc and all looks very good.

When i fax the end fax machine picks up the call. But nothing is printed.

When a fax machine faxes me, the fax machine rings and answers but does not print.

This is driving me mad, anybody any ideas?????

15 REPLIES

Re: Fax issues

Has the ATA been configured for fax relay or passthrough. This document might help.

http://www.cisco.com/en/US/partner/products/hw/gatecont/ps514/products_configuration_example09186a00800d698e.shtml

New Member

Re: Fax issues

Fax is configured for fax passthrough.

I have been through every pdf known to man or it certainly feels that way.

Cheers

New Member

Re: Fax issues

Which software version to you have on your ATA box.

Callmanager environment?

August

New Member

Re: Fax issues

ATA has version 2.15

Call Manager 3.3

H.323 Gateway 12.2.13

New Member

Re: Fax issues

We are using CCM 3.2(2c) and ATAs with version 2.16ms and they did work fine.

Maybe the failure is on the fax machine. (auto-answer, manual answer and so on)

On our ATAs are connected several fax machines (different vendors).

New Member

Re: Fax issues

Yes that is the next line of attack, although i have tried the fax on a normal line and all is fine. Maybe it does not like the ATA/IP network.

Get same results in and out for other fax machones auto answer is on.

I do have a teltrend converter in the loop which i need to check to see if this is causing me any issues.

Also the fax answers the call, but just does not print.

Cheers

Keith

New Member

Re: Fax issues

Another question:

Some fax machines have an option to get all faxes into a storage (e.g. when there is no paper and so on) and this option can also be enabled.

Did the fax gives an error or does the fax print out on the display that all pages have been received?

New Member

Re: Fax issues

No i get an error, when recieving the fax i get the message recieving ECM 1.1

The report comes up with a recieving error.

Silver

Re: Fax issues

Turn off ECM mode on the fax machines(this will force them to not use SuperG3 mode if they are defaulting to this). Also check your gateway interface for clock slips if the interface is an E1 or T1 - clock slips will kill fax and modem calls. Does this gateway have an AIM-VOICE-30 in it by any chance ? If so , paste the SH VER and SH RUN here so we can tell you how to set up the clocking.

New Member

Re: Fax issues

I will try bturning off the ECM mode on the FAX, although this does work normally on a straight analogue line, if this helps.

I am using the AIM-VOICE-30. I have added the following to the config, i do not have the latest config to hand.

> network-clock-participate wic 0

- network-clock-select 1 E1

> 0/0 network-clock-select 2 E1 0/1

> !

> voice-card 0 <---------

> Dspfarm <----------

> !

> controller E1 0/0

> mode atm aim 0 <------

Does this help at all.

Keith

> !

New Member

Re: Fax issues

Keith,

As you might have seen, I had a similar problem. I ended up calling TAC, and here's what they had me do:

add the following commands to my mgcp gateway:

mgcp tse payload 100

mgcp modem pass voip codec g711u (this is default, but they wanted me to put it in again anyway)

on the ATA change the AudioMode to 0x00160016 - this forces it to use G.711uLaw with no VAD.

Now, I'm not sure which of this truly fixed it, but it's working now.

Now, after I had all of this done, I still had a problem to compound matters - I had another ATA that was bad at the same time. Check the counters on the Ethernet port you have the ATA plugged into. I kept getting input errors and runts with numbers matching in quantity, this was due to a wonderfully timed bad ATA. Replaced it with another ATA and it worked like a champ.

Hope this helps.

Cheers! Now it's time for some beers.

Loy

New Member

Re: Fax issues

I'm sorry to butt in on an existing and current conversation, but I am having the exact same issues. I have ATA 188 & 186s and a 3745 MGCP Gateway running Gateway is running c3745-bino3s-mz.122-15.T8.bin software and ATA(s) running

Version: v2.16.ms ata18x (Build 030327b). I have checked the T1 interfaces and there are no slips. I have also checked the FE interface connecting to the 188 that I'm using for testing and I see NO errors on the LAN side. But I am still getting faxes dropped and nothing coming through.

Here's my mgcp config on the gateway:

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

!

hostname CCD3745

!

***nothing to see here***

!

voice-card 1

dspfarm

!

** clip **

!

!

isdn switch-type primary-ni

!

!

!

voice service voip

fax protocol pass-through g711ulaw

modem passthrough nse codec g711ulaw

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

ccm-manager redundant-host 172.20.10.10

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 172.20.10.10 172.20.10.11

ccm-manager config

mta receive maximum-recipients 0

!

!

controller T1 1/0

framing esf

linecode b8zs

pri-group timeslots 1-24 service mgcp

description Voice PRI CircuitNo 60.IPZX.512797 Block 1001

!

controller T1 1/1

framing esf

linecode b8zs

pri-group timeslots 1-24 service mgcp

description Voice PRI CircuitNo 60.IPZX.512798 Block 1002

!

controller T1 2/0

framing esf

linecode b8zs

description RAS PRI CircuitNo 60.IPZX.512799 Block 1003

!

!

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

** snip ***

!

interface Serial1/0:23

no ip address

no logging event link-status

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

interface Serial1/1:23

no ip address

no logging event link-status

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

interface GigabitEthernet3/0

ip address 172.20.10.2 255.255.255.0

media-type gbic

negotiation auto

!

** drivel **

!

!

!

!

call rsvp-sync

!

voice-port 1/0:23

echo-cancel coverage 16

!

voice-port 1/1:23

echo-cancel coverage 16

!

mgcp

mgcp call-agent 172.20.10.11 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp modem passthrough voip redundancy

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload cisco-pcm-switch-over-ulaw 126

!

mgcp profile default

!

!

!

dial-peer cor custom

!

!

!

dial-peer voice 1001 pots

application mgcpapp

port 1/0:23

!

dial-peer voice 1002 pots

application mgcpapp

port 1/1:23

!

!

My ATA is configured with AudioMode 0x00150015 and connect mode 0x90000400.

I talked with a few people here and there and I have been pointed to a bunch of different places to find the information and I have ammassed what you basically see above....

Any ideas?

Loy

New Member

Re: Fax issues

Hi Loy,

include this command in the voice gateway:

no ccm-manager fax protocol

(Cisco fax relay is enabled by default, but you can

disable it using this command. You need this for IOS 12.2.9T or later, CCM only support fax passthrough)

then do a "show ccm"

before the command

FAX mode: cisco

after the command

FAX mode: disable

this indicate that the Cisco fax relay mode is disabled and back to fax passthrough

hope this help

Eric

New Member

Re: Fax issues

Cheers

I have applied this to the gateway.

New Member

Re: Fax issues

Hi

Have you got some screen prints of your ata configuration and also your gateway configuration.

Cheers

Keith

240
Views
0
Helpful
15
Replies
CreatePlease to create content