Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

FAX on ATA : not completing full page

Hi,

We have some ATA's running with callmanager. Sometimes incoming faxes are not fully completed.

We receive most of the time just a half page.

Sending : same problem

Audio mode is already on 12 for the fax port.

any suggestions? (latest ATA firmware allready installed.)

greetz

5 REPLIES
Blue

Re: FAX on ATA : not completing full page

More information would be helpful.

What model ATA? L1 or L2?

Are the calls through a gateway to the PSTN? If so, what type of gateway? PRI or FXO, or? H323 or MGCP?

Post your gateway config if applicable.

Are the fax machines set for G3 only, or are they attempting Super G3?

New Member

Re: FAX on ATA : not completing full page

Hi,

We have ATA186 L2, calls come through a ISDN/BRI interface on a cisco 2801 H323 gateway.

Fax is kinda old so only G3 I think.

Sometimes it happends a fax fully comes in, but most of the time it receive just a halve page.

Config of the voice gateway, I left some unneeded parts out.

network-clock-participate wic 3

network-clock-select 1 BRI0/3/0

network-clock-select 2 BRI0/3/1

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

ip cef

!

!

no ip domain lookup

no ftp-server write-enable

isdn switch-type basic-net3

!

voice-card 0

!

!

!

voice service voip

modem passthrough nse codec g711alaw

!

!

voice class codec 99

codec preference 1 g711alaw

codec preference 2 g729br8

codec preference 3 g729r8

!

class-map match-all CM_CoS3

match dscp af31

class-map match-all CM_QOS

match dscp ef

!

!

policy-map QOS

description ***map dscp to cos***

class CM_QOS

set cos 5

class CM_CoS3

set cos 3

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 200

ip address 10.20.20.254 255.255.255.0

service-policy output QOS

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.20.20.254

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface BRI0/3/0

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

isdn incoming-voice voice

isdn global-disconnect

!

interface BRI0/3/1

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

isdn incoming-voice voice

isdn global-disconnect

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.20.20.250

!

voice-port 0/3/0

translate calling 10

compand-type a-law

cptone NL

timeouts interdigit 3

!

voice-port 0/3/1

translate calling 10

compand-type a-law

cptone NL

timeouts interdigit 3

!

!

!

!

dial-peer voice 100 pots

tone ringback alert-no-PI

destination-pattern 0.T

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

fax rate disable

direct-inward-dial

port 0/3/1

forward-digits all

!

dial-peer voice 500 voip

destination-pattern .T

no modem passthrough

voice-class codec 99

session target ipv4:10.10.0.2

dtmf-relay h245-alphanumeric

fax rate disable

no vad

!

dial-peer voice 1200 pots

tone ringback alert-no-PI

destination-pattern 12..

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

direct-inward-dial

port 0/3/0

forward-digits all

!

dial-peer voice 501 voip

preference 2

destination-pattern .T

no modem passthrough

voice-class codec 99

session target ipv4:10.10.0.1

dtmf-relay h245-alphanumeric

fax rate disable

no vad

!!

!

dial-peer voice 101 pots

tone ringback alert-no-PI

destination-pattern 0.T

direct-inward-dial

port 0/3/0

forward-digits all

!

!

call-manager-fallback

max-conferences 4

ip source-address 10.20.20.254 port 2000

max-ephones 24

max-dn 48

default-destination 7210

translate called 20

Blue

Re: FAX on ATA : not completing full page

Try adding fax protocol pass-through g711alaw to your VOIP dial peers.

Are you in Europe? If US you should be using g711ulaw.

New Member

Re: FAX on ATA : not completing full page

Yes, I'am in Europe.

Gonna add this command later this day and run some tests.

New Member

Re: FAX on ATA : not completing full page

Hi,

The problem you are facing is due the fact that the ATA analog-ports work only upto 9600 and if the two faxes negociate a higher speed between them, then the ATA ports cannot keep up and you either miss pages or you get half pages.

Try forcing your fax machine to use speeds >=9600.

Regards,

Christos

158
Views
0
Helpful
5
Replies