Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

FXS port problem on cisco router

Hi,

Maybe this is a very simple problem, but thought you can help on this.

I have a cisco 827-4V. It has 4 FXS ports. I have a SIP Configuration on it. I connected a telephone directly to port 1. I can make calls from the phone connected to port 1 of the 827-4V to anywhere with out any problem. However, when someone else from the SIP network dials to the number asigned to the 827-4V port 1, it gets bussy tone and on the other side, the telephone never rings.

I have other equipments like ATA's 186 on the same network working properly so I think that the problem might be on the configuration of the 827-4V. I'm attaching the current configuration. Can someone please take a fast look and tell me if I'm missing something on the voice-port configuration section or in the diail-peer to make the telephone ring and the person dialing to it not to get bussy tone???

Thanks in advance for your help!!!

Kind Regards!!

Felix

test#sh run

Building configuration...

Current configuration : 3960 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname test

!

aaa new-model

!

!

aaa session-id common

enable secret 5 $1$rbY1$byVYnag8nrnJaqF6s5z5x.

enable password 7 130A1C1F

!

clock timezone GMT -6

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

!

!

class-map match-all voice

match access-group 102

!

!

policy-map politica1

class voice

priority 128

!

!

!

!

!

!

!

!

!

!

!

interface Ethernet0

ip address xxx.xxx.xxx.xxx 255.255.255.0 secondary

ip address xxx.xxx.xxx.xxx 255.255.255.0

ip nat inside

service-policy output politica1

hold-queue 100 out

!

interface ATM0

no ip address

no ip mroute-cache

no atm ilmi-keepalive

dsl operating-mode auto

h323-gateway voip interface

h323-gateway voip id gk-mty-2 ipaddr xxx.xxx.xxx.xxx 1719 priority 120

h323-gateway voip h323-id adsl

h323-gateway voip tech-prefix 1#

!

interface ATM0.1 point-to-point

ip address xxx.xxx.xxx.xxx 255.255.255.252

ip nat outside

pvc 8/81

protocol ip xxx.xxx.xxx.xxx

encapsulation aal5snap

!

ip classless

ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx

ip route xxx.xxx.xxx.xxx 255.255.255.0 xxx.xxx.xxx.xxx

ip http server

ip http authentication local

ip pim bidir-enable

!

!

access-list 1 permit xxx.xxx.xxx.xxx 0.0.0.255

access-list 102 permit udp any any range 16384 32767

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx permit

!

bridge 1 protocol dec

call rsvp-sync

!

voice-port 1

cptone MX

ring cadence pattern01

!

voice-port 2

!

voice-port 3

!

voice-port 4

!

dial-peer voice 2 pots

incoming called-number 9876

destination-pattern 9876

port 1

!

dial-peer voice 3 voip

application session

destination-pattern ....T

session protocol sipv2

session target sip-server

acc-qos controlled-load

ip qos dscp cs5 media

!

gateway

!

sip-ua

sip-server ipv4:148.243.196.14:5060

!

!

line con 0

exec-timeout 120 0

stopbits 1

line vty 0 4

access-class 23 in

exec-timeout 120 0

password 7 0454000B

!

scheduler max-task-time 5000

end

test#

1 REPLY
New Member

Re: FXS port problem on cisco router

Hi,

On the g/w pictured here, I'd issue a "debug voip ccapi inout" and then issue a call again the the gateway. Make sure to increase your terminal buffer. If you receive lots of data, then you know the call is getting to the box and you can then read the results. Look for "peer tag xxx". That will determine what dial-peer its matching on. At that point, it may be as simple as configuring your voip dial peer to be more specific than ....T.

-Mike

102
Views
0
Helpful
1
Replies